summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Hicks <david@hicks.id.au>2017-07-30 00:56:06 +1000
committerMichał Górny <mgorny@gentoo.org>2017-07-30 11:22:46 +0200
commit8905f083f8599e878f92f78f6a6173fbc1e7528e (patch)
tree74629780b3bacc8e712aa00260a02467003be943 /sys-cluster
parentsys-cluster/libcircle: use HTTPS for GitHub (diff)
downloadgentoo-8905f083f8599e878f92f78f6a6173fbc1e7528e.tar.gz
gentoo-8905f083f8599e878f92f78f6a6173fbc1e7528e.tar.bz2
gentoo-8905f083f8599e878f92f78f6a6173fbc1e7528e.zip
sys-cluster/ceph: use HTTPS for GitHub, HOMEPAGE and SRC_URI
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ceph/ceph-0.94.9.ebuild8
-rw-r--r--sys-cluster/ceph/ceph-10.2.3-r2.ebuild8
-rw-r--r--sys-cluster/ceph/ceph-10.2.7-r1.ebuild8
-rw-r--r--sys-cluster/ceph/ceph-10.2.8.ebuild8
-rw-r--r--sys-cluster/ceph/ceph-10.2.9.ebuild8
-rw-r--r--sys-cluster/ceph/ceph-9.2.1-r2.ebuild8
6 files changed, 18 insertions, 30 deletions
diff --git a/sys-cluster/ceph/ceph-0.94.9.ebuild b/sys-cluster/ceph/ceph-0.94.9.ebuild
index 8ee34507772e..1d7eef4c590c 100644
--- a/sys-cluster/ceph/ceph-0.94.9.ebuild
+++ b/sys-cluster/ceph/ceph-0.94.9.ebuild
@@ -6,15 +6,13 @@ PYTHON_COMPAT=( python2_7 )
if [[ $PV = *9999* ]]; then
scm_eclass=git-r3
- EGIT_REPO_URI="
- git://github.com/ceph/ceph.git
- https://github.com/ceph/ceph.git"
+ EGIT_REPO_URI="https://github.com/ceph/ceph.git"
SRC_URI=""
else
[[ -n ${UPSTREAM_VER} ]] && \
UPSTREAM_PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${P}-upstream-patches-${UPSTREAM_VER}.tar.xz"
- SRC_URI="http://ceph.com/download/${P}.tar.gz
+ SRC_URI="https://download.ceph.com/tarballs/${P}.tar.gz
${UPSTREAM_PATCHSET_URI}"
fi
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
@@ -22,7 +20,7 @@ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
inherit check-reqs autotools eutils multilib python-single-r1 udev readme.gentoo-r1 systemd ${scm_eclass}
DESCRIPTION="Ceph distributed filesystem"
-HOMEPAGE="http://ceph.com/"
+HOMEPAGE="https://ceph.com/"
LICENSE="LGPL-2.1"
SLOT="0"
diff --git a/sys-cluster/ceph/ceph-10.2.3-r2.ebuild b/sys-cluster/ceph/ceph-10.2.3-r2.ebuild
index 48ba0a48e0d2..9453bf66abc5 100644
--- a/sys-cluster/ceph/ceph-10.2.3-r2.ebuild
+++ b/sys-cluster/ceph/ceph-10.2.3-r2.ebuild
@@ -9,17 +9,15 @@ inherit check-reqs autotools eutils python-r1 udev user \
if [[ ${PV} == *9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="
- git://github.com/ceph/ceph.git
- https://github.com/ceph/ceph.git"
+ EGIT_REPO_URI="https://github.com/ceph/ceph.git"
SRC_URI=""
else
- SRC_URI="http://ceph.com/download/${P}.tar.gz"
+ SRC_URI="https://download.ceph.com/tarballs/${P}.tar.gz"
KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
fi
DESCRIPTION="Ceph distributed filesystem"
-HOMEPAGE="http://ceph.com/"
+HOMEPAGE="https://ceph.com/"
LICENSE="LGPL-2.1"
SLOT="0"
diff --git a/sys-cluster/ceph/ceph-10.2.7-r1.ebuild b/sys-cluster/ceph/ceph-10.2.7-r1.ebuild
index 089ebfd6a983..e77e546d7b3c 100644
--- a/sys-cluster/ceph/ceph-10.2.7-r1.ebuild
+++ b/sys-cluster/ceph/ceph-10.2.7-r1.ebuild
@@ -9,17 +9,15 @@ inherit check-reqs autotools eutils python-r1 udev user \
if [[ ${PV} == *9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="
- git://github.com/ceph/ceph.git
- https://github.com/ceph/ceph.git"
+ EGIT_REPO_URI="https://github.com/ceph/ceph.git"
SRC_URI=""
else
- SRC_URI="http://download.ceph.com/tarballs/${P}.tar.gz"
+ SRC_URI="https://download.ceph.com/tarballs/${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi
DESCRIPTION="Ceph distributed filesystem"
-HOMEPAGE="http://ceph.com/"
+HOMEPAGE="https://ceph.com/"
LICENSE="LGPL-2.1"
SLOT="0"
diff --git a/sys-cluster/ceph/ceph-10.2.8.ebuild b/sys-cluster/ceph/ceph-10.2.8.ebuild
index 1dff5e6b0d14..90cd7f880ef3 100644
--- a/sys-cluster/ceph/ceph-10.2.8.ebuild
+++ b/sys-cluster/ceph/ceph-10.2.8.ebuild
@@ -9,17 +9,15 @@ inherit check-reqs autotools eutils python-r1 udev user \
if [[ ${PV} == *9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="
- git://github.com/ceph/ceph.git
- https://github.com/ceph/ceph.git"
+ EGIT_REPO_URI="https://github.com/ceph/ceph.git"
SRC_URI=""
else
- SRC_URI="http://download.ceph.com/tarballs/${P}.tar.gz"
+ SRC_URI="https://download.ceph.com/tarballs/${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi
DESCRIPTION="Ceph distributed filesystem"
-HOMEPAGE="http://ceph.com/"
+HOMEPAGE="https://ceph.com/"
LICENSE="LGPL-2.1"
SLOT="0"
diff --git a/sys-cluster/ceph/ceph-10.2.9.ebuild b/sys-cluster/ceph/ceph-10.2.9.ebuild
index 1dff5e6b0d14..90cd7f880ef3 100644
--- a/sys-cluster/ceph/ceph-10.2.9.ebuild
+++ b/sys-cluster/ceph/ceph-10.2.9.ebuild
@@ -9,17 +9,15 @@ inherit check-reqs autotools eutils python-r1 udev user \
if [[ ${PV} == *9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="
- git://github.com/ceph/ceph.git
- https://github.com/ceph/ceph.git"
+ EGIT_REPO_URI="https://github.com/ceph/ceph.git"
SRC_URI=""
else
- SRC_URI="http://download.ceph.com/tarballs/${P}.tar.gz"
+ SRC_URI="https://download.ceph.com/tarballs/${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi
DESCRIPTION="Ceph distributed filesystem"
-HOMEPAGE="http://ceph.com/"
+HOMEPAGE="https://ceph.com/"
LICENSE="LGPL-2.1"
SLOT="0"
diff --git a/sys-cluster/ceph/ceph-9.2.1-r2.ebuild b/sys-cluster/ceph/ceph-9.2.1-r2.ebuild
index a77b780b22c4..529686284af0 100644
--- a/sys-cluster/ceph/ceph-9.2.1-r2.ebuild
+++ b/sys-cluster/ceph/ceph-9.2.1-r2.ebuild
@@ -6,19 +6,17 @@ PYTHON_COMPAT=( python2_7 )
if [[ $PV = *9999* ]]; then
scm_eclass=git-r3
- EGIT_REPO_URI="
- git://github.com/ceph/ceph.git
- https://github.com/ceph/ceph.git"
+ EGIT_REPO_URI="https://github.com/ceph/ceph.git"
SRC_URI=""
else
- SRC_URI="http://ceph.com/download/${P}.tar.gz"
+ SRC_URI="https://download.ceph.com/tarballs/${P}.tar.gz"
fi
KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
inherit check-reqs autotools eutils multilib python-single-r1 udev user readme.gentoo systemd versionator ${scm_eclass}
DESCRIPTION="Ceph distributed filesystem"
-HOMEPAGE="http://ceph.com/"
+HOMEPAGE="https://ceph.com/"
LICENSE="LGPL-2.1"
SLOT="0"