summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2016-11-03 08:35:56 -0700
committerPatrick McLean <chutzpah@gentoo.org>2016-11-03 09:49:42 -0600
commit8f92bc0179717fff7d7d0248302cfdedd7e92a0e (patch)
treed7882bd74898283a8153f300781b91f51dae3bca /sys-cluster
parentdev-libs/jansson: Bump to version 2.9 (bug #598832) and to EAPI-6. (diff)
downloadgentoo-8f92bc0179717fff7d7d0248302cfdedd7e92a0e.tar.gz
gentoo-8f92bc0179717fff7d7d0248302cfdedd7e92a0e.tar.bz2
gentoo-8f92bc0179717fff7d7d0248302cfdedd7e92a0e.zip
sys-cluster/ceph: Revision bump to 10.2.3-r1 fix shebang issue
Package-Manager: portage-2.3.2
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ceph/ceph-10.2.3-r2.ebuild (renamed from sys-cluster/ceph/ceph-10.2.3-r1.ebuild)11
1 files changed, 8 insertions, 3 deletions
diff --git a/sys-cluster/ceph/ceph-10.2.3-r1.ebuild b/sys-cluster/ceph/ceph-10.2.3-r2.ebuild
index 5f40c53bf6ad..30211faa57ae 100644
--- a/sys-cluster/ceph/ceph-10.2.3-r1.ebuild
+++ b/sys-cluster/ceph/ceph-10.2.3-r2.ebuild
@@ -212,7 +212,7 @@ src_configure() {
)
# we can only use python2.7 for building at the moment
- python_export python2.7 PYTHON EPYTHON
+ python_setup 'python2*'
econf "${myeconfargs[@]}"
}
@@ -251,11 +251,16 @@ src_install() {
systemd_install_serviced "${FILESDIR}/ceph-osd_at.service.conf" "ceph-osd@.service"
systemd_install_serviced "${FILESDIR}/ceph-mon_at.service.conf" "ceph-mon@.service"
- python_fix_shebang "${ED}"/usr/{,s}bin/
-
udev_dorules udev/*.rules
readme.gentoo_create_doc
+
+ python_setup 'python2*'
+ python_fix_shebang "${ED}"/usr/{,s}bin/
+
+ # python_fix_shebang apparently is not idempotent
+ sed -i -r 's:(/usr/lib/python-exec/python[0-9]\.[0-9]/python)[0-9]\.[0-9]:\1:' \
+ "${ED}"/usr/{sbin/ceph-disk,bin/ceph-detect-init} || die "sed failed"
}
pkg_postinst() {