summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGraeme Lawes <graemelawes@gmail.com>2019-06-24 22:54:32 -0400
committerMichał Górny <mgorny@gentoo.org>2019-06-27 16:56:34 +0200
commitacb75018d8c55fab6e74784431bd6246f06dadfa (patch)
tree9c434ac1509ae6c44ff367dfda5f3fc651aaa9a7 /sys-cluster
parentsys-apps/s6-linux-init: Fix sysv-utils location and deps (diff)
downloadgentoo-acb75018d8c55fab6e74784431bd6246f06dadfa.tar.gz
gentoo-acb75018d8c55fab6e74784431bd6246f06dadfa.tar.bz2
gentoo-acb75018d8c55fab6e74784431bd6246f06dadfa.zip
sys-cluster/teleport: add v4.0.1
Signed-off-by: Graeme Lawes <graemelawes@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/teleport/Manifest1
-rw-r--r--sys-cluster/teleport/teleport-4.0.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sys-cluster/teleport/Manifest b/sys-cluster/teleport/Manifest
index 71c801b74e97..44fb4ed605e9 100644
--- a/sys-cluster/teleport/Manifest
+++ b/sys-cluster/teleport/Manifest
@@ -1,2 +1,3 @@
DIST teleport-3.2.6.tar.gz 22620079 BLAKE2B 07b4bcb5b53a511c25f0556fad33b461307b524554e993097f634b1751d7fd3c664de0478427efa18dc20e597fb73f3c5bd09ba961754456245e1306372ed0ee SHA512 20be34820f9b9f29c492f8dabe8914012b66ebfb9db51f3dff0e19b8a1f7b85b948cc1036861d03ca6de9e6f30ba0b43caf4760bc95c74e45a38f0cad080820c
DIST teleport-4.0.0.tar.gz 34913323 BLAKE2B 2890d18fed82d9a2da18be6ce9c981ddc1a4ac374862d853f09001c88ed3f9092b9a006c98f6d489dcaae8a702827f98ee12e870708d6746f429f9457debbb33 SHA512 b59ee7e99808475d50e84feff160e2a3c71f04d67dc7d8caa9476251c3e1f51d057de7384f4750b60c121db630c49a8315f9903d8f7ae3e04469f4532ca7078c
+DIST teleport-4.0.1.tar.gz 34914632 BLAKE2B 88861a36b4cea94d24ccbb03294202a88845f444df31642b2878d8e3c9c0f46f4ed70b4f713e32889895e59be3629c1e861446c051ea5a74aaa4b7b044f17f6b SHA512 db5d477e430fc7d439e352a2e6605f6662a206b0395268f19d52422994344e1b26bb89f4eae0dd0a453cc0e3d19549bd03959e37e29dccf2b8504994922eb946
diff --git a/sys-cluster/teleport/teleport-4.0.1.ebuild b/sys-cluster/teleport/teleport-4.0.1.ebuild
new file mode 100644
index 000000000000..546c0f2921f3
--- /dev/null
+++ b/sys-cluster/teleport/teleport-4.0.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit golang-build systemd
+
+DESCRIPTION="Modern SSH server for teams managing distributed infrastructure"
+HOMEPAGE="https://gravitational.com/teleport"
+
+EGO_PN="github.com/gravitational/${PN}/..."
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3 golang-vcs
+ EGIT_REPO_URI="https://github.com/gravitational/${PN}.git"
+else
+ inherit golang-vcs-snapshot
+ SRC_URI="https://github.com/gravitational/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+IUSE="pam"
+LICENSE="Apache-2.0"
+RESTRICT="test strip"
+SLOT="0"
+
+DEPEND="app-arch/zip"
+RDEPEND="pam? ( sys-libs/pam )"
+
+src_compile() {
+ BUILDFLAGS="" GOPATH="${S}" emake -j1 -C src/${EGO_PN%/*} full
+}
+
+src_install() {
+ keepdir /var/lib/${PN} /etc/${PN}
+ dobin src/${EGO_PN%/*}/build/{tsh,tctl,teleport}
+
+ insinto /etc/${PN}
+ newins "${FILESDIR}"/${PN}.yaml ${PN}.yaml
+
+ newinitd "${FILESDIR}"/${PN}.init.d ${PN}
+ newconfd "${FILESDIR}"/${PN}.conf.d ${PN}
+
+ systemd_newunit "${FILESDIR}"/${PN}.service ${PN}.service
+ systemd_install_serviced "${FILESDIR}"/${PN}.service.conf ${PN}.service
+}
+
+src_test() {
+ BUILDFLAGS="" GOPATH="${S}" emake -C src/${EGO_PN%/*} test
+}