summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-12 11:39:27 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-13 10:42:20 +0100
commitc66c1b0eca9b2c0205ab93809489fa03b7bdd5e3 (patch)
treeb43ff25bacdc4a85e7ec75fc5dafffc3b1536c01 /sys-cluster
parentsys-auth/keystone: Remove Python 2 support (diff)
downloadgentoo-c66c1b0eca9b2c0205ab93809489fa03b7bdd5e3.tar.gz
gentoo-c66c1b0eca9b2c0205ab93809489fa03b7bdd5e3.tar.bz2
gentoo-c66c1b0eca9b2c0205ab93809489fa03b7bdd5e3.zip
sys-cluster/neutron: Remove Python 2 support
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/neutron/neutron-14.0.2.ebuild3
-rw-r--r--sys-cluster/neutron/neutron-14.0.3.ebuild3
-rw-r--r--sys-cluster/neutron/neutron-14.0.4.ebuild3
-rw-r--r--sys-cluster/neutron/neutron-15.0.0.ebuild3
-rw-r--r--sys-cluster/neutron/neutron-15.0.1.ebuild3
-rw-r--r--sys-cluster/neutron/neutron-2018.2.9999.ebuild3
-rw-r--r--sys-cluster/neutron/neutron-2019.1.9999.ebuild3
-rw-r--r--sys-cluster/neutron/neutron-2019.2.9999.ebuild3
8 files changed, 8 insertions, 16 deletions
diff --git a/sys-cluster/neutron/neutron-14.0.2.ebuild b/sys-cluster/neutron/neutron-14.0.2.ebuild
index 3361dc6d27cc..aabbe08f02c2 100644
--- a/sys-cluster/neutron/neutron-14.0.2.ebuild
+++ b/sys-cluster/neutron/neutron-14.0.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
# still no 34 :( https://bugs.launchpad.net/neutron/+bug/1630439
inherit distutils-r1 linux-info user
@@ -98,7 +98,6 @@ RDEPEND="
>=dev-python/ovsdbapp-0.9.1[${PYTHON_USEDEP}]
>=dev-python/psutil-3.2.2[${PYTHON_USEDEP}]
>=dev-python/pyroute2-0.5.3[${PYTHON_USEDEP}]
- >=dev-python/weakrefmethod-1.0.2[$(python_gen_usedep 'python2_7')]
>=dev-python/python-novaclient-9.1.0[${PYTHON_USEDEP}]
>=dev-python/python-designateclient-2.7.0[${PYTHON_USEDEP}]
>=dev-python/os-xenapi-0.3.1[${PYTHON_USEDEP}]
diff --git a/sys-cluster/neutron/neutron-14.0.3.ebuild b/sys-cluster/neutron/neutron-14.0.3.ebuild
index 3361dc6d27cc..aabbe08f02c2 100644
--- a/sys-cluster/neutron/neutron-14.0.3.ebuild
+++ b/sys-cluster/neutron/neutron-14.0.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
# still no 34 :( https://bugs.launchpad.net/neutron/+bug/1630439
inherit distutils-r1 linux-info user
@@ -98,7 +98,6 @@ RDEPEND="
>=dev-python/ovsdbapp-0.9.1[${PYTHON_USEDEP}]
>=dev-python/psutil-3.2.2[${PYTHON_USEDEP}]
>=dev-python/pyroute2-0.5.3[${PYTHON_USEDEP}]
- >=dev-python/weakrefmethod-1.0.2[$(python_gen_usedep 'python2_7')]
>=dev-python/python-novaclient-9.1.0[${PYTHON_USEDEP}]
>=dev-python/python-designateclient-2.7.0[${PYTHON_USEDEP}]
>=dev-python/os-xenapi-0.3.1[${PYTHON_USEDEP}]
diff --git a/sys-cluster/neutron/neutron-14.0.4.ebuild b/sys-cluster/neutron/neutron-14.0.4.ebuild
index 301f8b3311a4..0e21778417eb 100644
--- a/sys-cluster/neutron/neutron-14.0.4.ebuild
+++ b/sys-cluster/neutron/neutron-14.0.4.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
# still no 34 :( https://bugs.launchpad.net/neutron/+bug/1630439
inherit distutils-r1 linux-info user
@@ -98,7 +98,6 @@ RDEPEND="
>=dev-python/ovsdbapp-0.9.1[${PYTHON_USEDEP}]
>=dev-python/psutil-3.2.2[${PYTHON_USEDEP}]
>=dev-python/pyroute2-0.5.3[${PYTHON_USEDEP}]
- >=dev-python/weakrefmethod-1.0.2[$(python_gen_usedep 'python2_7')]
>=dev-python/python-novaclient-9.1.0[${PYTHON_USEDEP}]
>=dev-python/python-designateclient-2.7.0[${PYTHON_USEDEP}]
>=dev-python/os-xenapi-0.3.1[${PYTHON_USEDEP}]
diff --git a/sys-cluster/neutron/neutron-15.0.0.ebuild b/sys-cluster/neutron/neutron-15.0.0.ebuild
index 6586813539f1..082eab07ed24 100644
--- a/sys-cluster/neutron/neutron-15.0.0.ebuild
+++ b/sys-cluster/neutron/neutron-15.0.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
# still no 34 :( https://bugs.launchpad.net/neutron/+bug/1630439
inherit distutils-r1 linux-info user
@@ -99,7 +99,6 @@ RDEPEND="
>=dev-python/ovsdbapp-0.9.1[${PYTHON_USEDEP}]
>=dev-python/psutil-3.2.2[${PYTHON_USEDEP}]
>=dev-python/pyroute2-0.5.3[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/weakrefmethod-1.0.2[${PYTHON_USEDEP}]' 'python2_7')
>=dev-python/python-novaclient-9.1.0[${PYTHON_USEDEP}]
>=dev-python/openstacksdk-0.31.2[${PYTHON_USEDEP}]
>=dev-python/python-designateclient-2.7.0[${PYTHON_USEDEP}]
diff --git a/sys-cluster/neutron/neutron-15.0.1.ebuild b/sys-cluster/neutron/neutron-15.0.1.ebuild
index df01b28f22ca..ba485cb5c831 100644
--- a/sys-cluster/neutron/neutron-15.0.1.ebuild
+++ b/sys-cluster/neutron/neutron-15.0.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
# still no 34 :( https://bugs.launchpad.net/neutron/+bug/1630439
inherit distutils-r1 linux-info user
@@ -99,7 +99,6 @@ RDEPEND="
>=dev-python/ovsdbapp-0.9.1[${PYTHON_USEDEP}]
>=dev-python/psutil-3.2.2[${PYTHON_USEDEP}]
>=dev-python/pyroute2-0.5.3[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/weakrefmethod-1.0.2[${PYTHON_USEDEP}]' 'python2_7')
>=dev-python/python-novaclient-9.1.0[${PYTHON_USEDEP}]
>=dev-python/openstacksdk-0.31.2[${PYTHON_USEDEP}]
>=dev-python/python-designateclient-2.7.0[${PYTHON_USEDEP}]
diff --git a/sys-cluster/neutron/neutron-2018.2.9999.ebuild b/sys-cluster/neutron/neutron-2018.2.9999.ebuild
index 4c5dc00e264c..d9d0f19bac82 100644
--- a/sys-cluster/neutron/neutron-2018.2.9999.ebuild
+++ b/sys-cluster/neutron/neutron-2018.2.9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_6 )
+PYTHON_COMPAT=( python3_6 )
# still no 34 :( https://bugs.launchpad.net/neutron/+bug/1630439
inherit distutils-r1 linux-info user
@@ -98,7 +98,6 @@ RDEPEND="
>=dev-python/ovsdbapp-0.9.1[${PYTHON_USEDEP}]
>=dev-python/psutil-3.2.2[${PYTHON_USEDEP}]
>=dev-python/pyroute2-0.4.21[${PYTHON_USEDEP}]
- >=dev-python/weakrefmethod-1.0.2[$(python_gen_usedep 'python2_7')]
>=dev-python/python-novaclient-9.1.0[${PYTHON_USEDEP}]
>=dev-python/python-designateclient-2.7.0[${PYTHON_USEDEP}]
>=dev-python/os-xenapi-0.3.1[${PYTHON_USEDEP}]
diff --git a/sys-cluster/neutron/neutron-2019.1.9999.ebuild b/sys-cluster/neutron/neutron-2019.1.9999.ebuild
index 287b8474dda8..2435f5317d6a 100644
--- a/sys-cluster/neutron/neutron-2019.1.9999.ebuild
+++ b/sys-cluster/neutron/neutron-2019.1.9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
# still no 34 :( https://bugs.launchpad.net/neutron/+bug/1630439
inherit distutils-r1 linux-info user
@@ -98,7 +98,6 @@ RDEPEND="
>=dev-python/ovsdbapp-0.9.1[${PYTHON_USEDEP}]
>=dev-python/psutil-3.2.2[${PYTHON_USEDEP}]
>=dev-python/pyroute2-0.5.3[${PYTHON_USEDEP}]
- >=dev-python/weakrefmethod-1.0.2[$(python_gen_usedep 'python2_7')]
>=dev-python/python-novaclient-9.1.0[${PYTHON_USEDEP}]
>=dev-python/python-designateclient-2.7.0[${PYTHON_USEDEP}]
>=dev-python/os-xenapi-0.3.1[${PYTHON_USEDEP}]
diff --git a/sys-cluster/neutron/neutron-2019.2.9999.ebuild b/sys-cluster/neutron/neutron-2019.2.9999.ebuild
index df01b28f22ca..ba485cb5c831 100644
--- a/sys-cluster/neutron/neutron-2019.2.9999.ebuild
+++ b/sys-cluster/neutron/neutron-2019.2.9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
# still no 34 :( https://bugs.launchpad.net/neutron/+bug/1630439
inherit distutils-r1 linux-info user
@@ -99,7 +99,6 @@ RDEPEND="
>=dev-python/ovsdbapp-0.9.1[${PYTHON_USEDEP}]
>=dev-python/psutil-3.2.2[${PYTHON_USEDEP}]
>=dev-python/pyroute2-0.5.3[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/weakrefmethod-1.0.2[${PYTHON_USEDEP}]' 'python2_7')
>=dev-python/python-novaclient-9.1.0[${PYTHON_USEDEP}]
>=dev-python/openstacksdk-0.31.2[${PYTHON_USEDEP}]
>=dev-python/python-designateclient-2.7.0[${PYTHON_USEDEP}]