summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2016-07-22 12:56:45 -0600
committerChristoph Junghans <ottxor@gentoo.org>2016-07-22 14:11:59 -0600
commitd24a974c03ba5ed32c722be7508dfb14828341c2 (patch)
tree5400d38c0675afb27a0691a0ca467ca5377c5490 /sys-cluster
parentnet-misc/wireguard: version bump (diff)
downloadgentoo-d24a974c03ba5ed32c722be7508dfb14828341c2.tar.gz
gentoo-d24a974c03ba5ed32c722be7508dfb14828341c2.tar.bz2
gentoo-d24a974c03ba5ed32c722be7508dfb14828341c2.zip
sys-cluster/hpx: version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/hpx/Manifest1
-rw-r--r--sys-cluster/hpx/hpx-0.9.99.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/sys-cluster/hpx/Manifest b/sys-cluster/hpx/Manifest
index 9948751f96a1..2eec6c91cc94 100644
--- a/sys-cluster/hpx/Manifest
+++ b/sys-cluster/hpx/Manifest
@@ -1,3 +1,4 @@
DIST hpx-0.9.9.tar.gz 3461235 SHA256 cb17ac303f49795300c6b803725036aa09b434a7a23a610744457d3481be3738 SHA512 95332c924548f7d07e24c56d3d72e8aa5977a1347666fb2a0f3782fec040e83e5760750a1696cf8152d7b3f8b90ce719fe24018086a5165429b3f9851c2f7e1f WHIRLPOOL 370646b98c89133a8fd23cb17ecaefc477e09b07508884f4343526050a12fae117f1fd0e24881b9896beca97ca08d4bad8526b39cfec1cad0ce48d8826ea3c43
DIST hpx_0.9.10.tar.gz 3016064 SHA256 af84455003bbf49fd81477138e6c7e699b7c24a4933de04d709c1437a9ad6aad SHA512 4c5ce7014d781c47415818898b99e5379e1547dd5f54fdefc9202de149ca4a0e3bf13c863cdea9ef70f7e3eb2c808cfda35d723a7f681745b8514a1887cbbb75 WHIRLPOOL 2fbc2c32532eb8141e6eb86a8e99ed4a7d4a6bb87bff9b383c4e4b5b0628fb5d6975672eaf5423f87b13f2f1d07e039362450b0276fa120f5a5abc8d7077408c
DIST hpx_0.9.8.7z 2089649 SHA256 9e04685b07e4155e6d3e00c944e5fe91c0c815a2b3bc7bc345eb59d8708bac91 SHA512 1789582ee776173d4aa67b512d2df225c734b98ffe59a8f1eee38b5112ac7c02e0c7c478f72062e5b6a5d5053ce1848729c374093378f63200acf51a208fb3c7 WHIRLPOOL b4b5a8a83aa4d07466ee0570b9fdadd906281e626eed2ce82e3a8e03681de1591a46af2254cbd387eb2d0bfac22c6796537fbbb37764be7dd424b97dd0d433c7
+DIST hpx_0.9.99.tar.gz 3779841 SHA256 072e8ed614eb81353ed3b4628835349fb08b42515f2f8d62855921354c1ae92b SHA512 57c03c01c4a9f770e56a60645ec352338365fe05c544b18ff2e944044284315a7e76bbdc2c7193fe55e6992dcb51a51d1042372fdd141b572bd8e18bf1afc363 WHIRLPOOL 1d2241c23ef43cf3cbc68fe59c5122165aff1793f2c36928badeb8e24a6bb8f3c35cef17a04672b308905e43d5a2c87cc252f0727c9b92079420da182904e301
diff --git a/sys-cluster/hpx/hpx-0.9.99.ebuild b/sys-cluster/hpx/hpx-0.9.99.ebuild
new file mode 100644
index 000000000000..105cd3121b2f
--- /dev/null
+++ b/sys-cluster/hpx/hpx-0.9.99.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+if [ ${PV} == 9999 ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/STEllAR-GROUP/hpx.git"
+else
+ SRC_URI="http://stellar.cct.lsu.edu/files/${PN}_${PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+ S="${WORKDIR}/${PN}_${PV}"
+fi
+
+inherit cmake-utils fortran-2 multilib python-single-r1
+
+DESCRIPTION="C++ runtime system for parallel and distributed applications"
+HOMEPAGE="http://stellar.cct.lsu.edu/tag/hpx/"
+
+SLOT="0"
+LICENSE="Boost-1.0"
+IUSE="doc examples jemalloc papi +perftools tbb test"
+
+RDEPEND="
+ tbb? ( dev-cpp/tbb )
+ >=dev-libs/boost-1.49
+ papi? ( dev-libs/papi )
+ perftools? ( >=dev-util/google-perftools-1.7.1 )
+ >=sys-apps/hwloc-1.8
+ >=sys-libs/libunwind-1
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( ${PYTHON_DEPS} )
+ doc? ( >=dev-libs/boost-1.56.0-r1:=[tools] )
+"
+REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )
+ jemalloc? ( !perftools !tbb )
+ perftools? ( !jemalloc !tbb )
+ tbb? ( !jemalloc !perftools )
+ "
+
+pkg_setup() {
+ use test && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ CMAKE_BUILD_TYPE=Release
+ local mycmakeargs=(
+ -DHPX_BUILD_EXAMPLES=OFF
+ -DHPX_MALLOC=system
+ -DLIB=$(get_libdir)
+ -Dcmake_dir=cmake
+ -DHPX_BUILD_DOCUMENTATION=$(usex doc)
+ -DHPX_JEMALLOC=$(usex jemalloc)
+ -DBUILD_TESTING=$(usex test)
+ -DHPX_GOOGLE_PERFTOOLS=$(usex perftools)
+ -DHPX_PAPI=$(usex papi)
+ )
+
+ use perftools && mycmakeargs+=( -DHPX_MALLOC=tcmalloc )
+ use jemalloc && mycmakeargs+=( -DHPX_MALLOC=jemalloc )
+ use tbb && mycmakeargs+=( -DHPX_MALLOC=tbbmalloc )
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ # avoid over-suscribing
+ cmake-utils_src_make -j1 tests
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}