summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-01-27 21:44:25 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-01-27 22:13:02 -0600
commitd9b57bc67eefacce442cb56874e1f5cad5ada35e (patch)
tree81f2c4467f14e6b5ad80bcb4a56860d8ecba2705 /sys-cluster
parentsys-cluster/heat: remove ocata (diff)
downloadgentoo-d9b57bc67eefacce442cb56874e1f5cad5ada35e.tar.gz
gentoo-d9b57bc67eefacce442cb56874e1f5cad5ada35e.tar.bz2
gentoo-d9b57bc67eefacce442cb56874e1f5cad5ada35e.zip
sys-cluster/nova: remove ocata
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/nova/Manifest3
-rw-r--r--sys-cluster/nova/files/nova.initd21
-rw-r--r--sys-cluster/nova/files/nova.initd-225
-rw-r--r--sys-cluster/nova/nova-15.1.0.ebuild232
-rw-r--r--sys-cluster/nova/nova-16.0.4.ebuild6
-rw-r--r--sys-cluster/nova/nova-2017.1.9999.ebuild232
-rw-r--r--sys-cluster/nova/nova-2017.2.9999.ebuild8
7 files changed, 15 insertions, 512 deletions
diff --git a/sys-cluster/nova/Manifest b/sys-cluster/nova/Manifest
index d7e3583ed3c8..da1cfb44b38b 100644
--- a/sys-cluster/nova/Manifest
+++ b/sys-cluster/nova/Manifest
@@ -1,6 +1,3 @@
-DIST nova-15.1.0.tar.gz 5774942 BLAKE2B 6507658dabf1cc9da34c40bf3c5fb77c9e5692ceeea6fe4b38cca8be3cf532db6bbdd14dd71c78e1545791eaf26f60bd9337fca4561d811d1116a32458a86c6d SHA512 a35cc1a1891f0440470cb31cd23f835190d5961a962afc308f54ffe1bb0e47eb0e411915b47e8b89e7f76a2b3c348997848d86fd10123a375c7fbb8c118f66b0
DIST nova-16.0.4.tar.gz 10922054 BLAKE2B 1fb76f0a06149cb67543921cc9f49cd869ebcb85a813079cdde7ed38aded81d0ec5f157b7d031a9269c3df66081cac1d0732286356dc9f8af58de02ba688a9c9 SHA512 8841faca0d3864a7f63f4c6eec637e6676df2b1473dacd0265a34ce4cf8e50bc587892de2f3d54d1e7a499adb8e9c06aca6d7956d010ddabae1ea61c7c5b0581
-DIST nova.conf.sample-15.1.0 344760 BLAKE2B 0c227259325b201740a6a6e0f9a174b8a463ad30b9b09ca819ba23d85ba5471c4e958e23cf96bc8b2dab358521dfc52c216dffc110b46338e80b1821face84e4 SHA512 5c55c752c8752876acbd8d2348abb39d6a8449f637ad2a6515f5c9f4619dbad73c4ae7a6ac4cd164656a0c466ed000a4d68a291050a03a5641fe96b3dd7f732d
DIST nova.conf.sample-16.0.4 360926 BLAKE2B 0cdfcff1d5faf5803de72b8113085591df4d1c7feb0591df786a5bf0e13ff133c1fcc4a2c3ebfdadf2a60943a7810e18813a00f5f78987daf3c271e3ba627911 SHA512 68f548e998396c7b18692fb3b1e9bf267f9bc06d73f602bb8f20bba426b6ede01e270447906f1685133cdbfd43b76ed5a9913b0167ce70f1ff3debd1ca11d378
-DIST nova.conf.sample-2017.1.9999 344760 BLAKE2B 0c227259325b201740a6a6e0f9a174b8a463ad30b9b09ca819ba23d85ba5471c4e958e23cf96bc8b2dab358521dfc52c216dffc110b46338e80b1821face84e4 SHA512 5c55c752c8752876acbd8d2348abb39d6a8449f637ad2a6515f5c9f4619dbad73c4ae7a6ac4cd164656a0c466ed000a4d68a291050a03a5641fe96b3dd7f732d
DIST nova.conf.sample-2017.2.9999 360926 BLAKE2B 0cdfcff1d5faf5803de72b8113085591df4d1c7feb0591df786a5bf0e13ff133c1fcc4a2c3ebfdadf2a60943a7810e18813a00f5f78987daf3c271e3ba627911 SHA512 68f548e998396c7b18692fb3b1e9bf267f9bc06d73f602bb8f20bba426b6ede01e270447906f1685133cdbfd43b76ed5a9913b0167ce70f1ff3debd1ca11d378
diff --git a/sys-cluster/nova/files/nova.initd b/sys-cluster/nova/files/nova.initd
index 7d679ed95fc9..ba722949182e 100644
--- a/sys-cluster/nova/files/nova.initd
+++ b/sys-cluster/nova/files/nova.initd
@@ -1,30 +1,25 @@
#!/sbin/openrc-run
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
description="Starts ${SVCNAME} service for OpenStack"
-command="/usr/bin/${SVCNAME} -- --config-file /etc/nova/nova.conf"
-pidfile=/var/run/nova/${SVCNAME}.pid
+command="/usr/bin/${SVCNAME}"
+command_args="--config-file /etc/nova/nova.conf"
+pidfile=/run/${SVCNAME}.pid
+command_background=true
required_files=/etc/nova/nova.conf
-start_stop_daemon_args="--quiet --user ${NOVA_USER:-nova}"
if [ "$SVCNAME" == nova-compute ]; then
required_files="${required_files} /etc/nova/nova-compute.conf"
- command="${command} --config-file /etc/nova/nova-compute.conf"
+ command_args="${command_args} --config-file /etc/nova/nova-compute.conf"
fi
-
+start_stop_daemon_args="-u ${NOVA_USER:-nova}"
+retry="SIGTERM/15"
depend() {
use net
}
start_pre() {
- checkpath --directory --owner ${NOVA_USER:-nova}:${NOVA_GROUP:-nova} --mode 0775 ${NOVA_RUN:-/var/run/nova}
checkpath --directory --owner ${NOVA_USER:-nova}:${NOVA_GROUP:-nova} --mode 0775 ${NOVA_RUN:-/var/lock/nova}
}
-
-start() {
- ebegin "Starting ${SVCNAME}"
- start-stop-daemon -S -b -m -p ${pidfile} -q -u ${NOVA_USER:-nova} -x ${command}
- eend $?
-}
diff --git a/sys-cluster/nova/files/nova.initd-2 b/sys-cluster/nova/files/nova.initd-2
deleted file mode 100644
index cb82c947ddfe..000000000000
--- a/sys-cluster/nova/files/nova.initd-2
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-description="Starts ${SVCNAME} service for OpenStack"
-
-command="/usr/bin/${SVCNAME}"
-command_args="--config-file /etc/nova/nova.conf"
-pidfile=/run/${SVCNAME}.pid
-command_background=true
-required_files=/etc/nova/nova.conf
-if [ "$SVCNAME" == nova-compute ]; then
- required_files="${required_files} /etc/nova/nova-compute.conf"
- command_args="${command_args} --config-file /etc/nova/nova-compute.conf"
-fi
-start_stop_daemon_args="-u ${NOVA_USER:-nova}"
-retry="SIGTERM/15"
-
-depend() {
- use net
-}
-
-start_pre() {
- checkpath --directory --owner ${NOVA_USER:-nova}:${NOVA_GROUP:-nova} --mode 0775 ${NOVA_RUN:-/var/lock/nova}
-}
diff --git a/sys-cluster/nova/nova-15.1.0.ebuild b/sys-cluster/nova/nova-15.1.0.ebuild
deleted file mode 100644
index 51f6f6060bf6..000000000000
--- a/sys-cluster/nova/nova-15.1.0.ebuild
+++ /dev/null
@@ -1,232 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit distutils-r1 eutils linux-info multilib user
-
-DESCRIPTION="Cloud computing fabric controller (main part of an IaaS system) in Python"
-HOMEPAGE="https://launchpad.net/nova"
-SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/openstack/nova/ocata/nova.conf.sample -> nova.conf.sample-${PV}
- https://tarballs.openstack.org/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="+compute compute-only iscsi +memcached mysql +novncproxy openvswitch postgres +rabbitmq sqlite"
-REQUIRED_USE="
- !compute-only? ( || ( mysql postgres sqlite ) )
- compute-only? ( compute !rabbitmq !memcached !mysql !postgres !sqlite )"
-
-CDEPEND="
- >=dev-python/setuptools-16.0[${PYTHON_USEDEP}]
- !~dev-python/setuptools-24.0.0[${PYTHON_USEDEP}]
- !~dev-python/setuptools-34.0.0[${PYTHON_USEDEP}]
- !~dev-python/setuptools-34.0.1[${PYTHON_USEDEP}]
- !~dev-python/setuptools-34.0.2[${PYTHON_USEDEP}]
- !~dev-python/setuptools-34.0.3[${PYTHON_USEDEP}]
- !~dev-python/setuptools-34.1.0[${PYTHON_USEDEP}]
- !~dev-python/setuptools-34.1.1[${PYTHON_USEDEP}]
- !~dev-python/setuptools-34.2.0[${PYTHON_USEDEP}]
- !~dev-python/setuptools-34.3.0[${PYTHON_USEDEP}]
- !~dev-python/setuptools-34.3.1[${PYTHON_USEDEP}]
- !~dev-python/setuptools-34.3.2[${PYTHON_USEDEP}]
- !~dev-python/setuptools-36.2.0[${PYTHON_USEDEP}]
- >=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
-DEPEND="
- ${CDEPEND}
- app-admin/sudo"
-
-RDEPEND="
- ${CDEPEND}
- compute-only? (
- >=dev-python/sqlalchemy-1.0.10[${PYTHON_USEDEP}]
- <dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
- )
- sqlite? (
- >=dev-python/sqlalchemy-1.0.10[sqlite,${PYTHON_USEDEP}]
- <dev-python/sqlalchemy-1.1.0[sqlite,${PYTHON_USEDEP}]
- )
- mysql? (
- >=dev-python/pymysql-0.7.6[${PYTHON_USEDEP}]
- !~dev-python/pymysql-0.7.7[${PYTHON_USEDEP}]
- >=dev-python/sqlalchemy-1.0.10[${PYTHON_USEDEP}]
- <dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
- )
- postgres? (
- >=dev-python/psycopg-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/sqlalchemy-1.0.10[${PYTHON_USEDEP}]
- <dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
- )
- >=dev-python/decorator-3.4.0[${PYTHON_USEDEP}]
- >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.8[${PYTHON_USEDEP}]
- !~dev-python/jinja-2.9.0[${PYTHON_USEDEP}]
- !~dev-python/jinja-2.9.1[${PYTHON_USEDEP}]
- !~dev-python/jinja-2.9.2[${PYTHON_USEDEP}]
- !~dev-python/jinja-2.9.3[${PYTHON_USEDEP}]
- !~dev-python/jinja-2.9.4[${PYTHON_USEDEP}]
- >=dev-python/keystonemiddleware-4.12.0[${PYTHON_USEDEP}]
- >=dev-python/lxml-2.3[${PYTHON_USEDEP}]
- !~dev-python/lxml-3.7.0[${PYTHON_USEDEP}]
- >=dev-python/routes-1.12.3[${PYTHON_USEDEP}]
- !~dev-python/routes-2.0[${PYTHON_USEDEP}]
- !~dev-python/routes-2.1[$(python_gen_usedep 'python2_7')]
- !~dev-python/routes-2.3[${PYTHON_USEDEP}]
- >=dev-python/cryptography-1.0[${PYTHON_USEDEP}]
- !~dev-python/cryptography-1.3.0[${PYTHON_USEDEP}]
- >=dev-python/webob-1.6.0[${PYTHON_USEDEP}]
- >=dev-python/greenlet-0.3.2[${PYTHON_USEDEP}]
- >=dev-python/pastedeploy-1.5.0-r1[${PYTHON_USEDEP}]
- dev-python/paste[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
- <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
- >=dev-python/sqlalchemy-migrate-0.9.6[${PYTHON_USEDEP}]
- >=dev-python/netaddr-0.7.13[${PYTHON_USEDEP}]
- !~dev-python/netaddr-0.7.16[${PYTHON_USEDEP}]
- >=dev-python/netifaces-0.10.4[${PYTHON_USEDEP}]
- >=dev-python/paramiko-2.0[${PYTHON_USEDEP}]
- >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
- >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/jsonschema-2.5.0[${PYTHON_USEDEP}]
- <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/python-cinderclient-1.6.0[${PYTHON_USEDEP}]
- !~dev-python/python-cinderclient-1.7.0[${PYTHON_USEDEP}]
- !~dev-python/python-cinderclient-1.7.1[${PYTHON_USEDEP}]
- >=dev-python/keystoneauth-2.18.0[${PYTHON_USEDEP}]
- >=dev-python/python-neutronclient-5.1.0[${PYTHON_USEDEP}]
- >=dev-python/python-glanceclient-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
- !~dev-python/requests-2.12.2[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=dev-python/stevedore-1.17.1[${PYTHON_USEDEP}]
- >=dev-python/websockify-0.8.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-cache-1.5.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-concurrency-3.8.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-3.14.0[${PYTHON_USEDEP}]
- !~dev-python/oslo-config-3.18.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-context-2.9.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-log-3.11.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-reports-0.6.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-3.18.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-db-4.15.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-rootwrap-5.0.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-messaging-5.14.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-policy-1.17.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-privsep-1.9.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-service-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/rfc3986-0.3.1[${PYTHON_USEDEP}]
- >=dev-python/oslo-middleware-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/psutil-3.0.1[${PYTHON_USEDEP}]
- >=dev-python/oslo-versionedobjects-1.17.0[${PYTHON_USEDEP}]
- >=dev-python/os-brick-1.8.0[${PYTHON_USEDEP}]
- >=dev-python/os-vif-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/os-win-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/castellan-0.4.0[${PYTHON_USEDEP}]
- >=dev-python/microversion-parse-0.1.2[${PYTHON_USEDEP}]
- >=dev-python/os-xenapi-0.1.1[${PYTHON_USEDEP}]
- dev-python/libvirt-python[${PYTHON_USEDEP}]
- app-emulation/libvirt[iscsi?]
- novncproxy? ( www-apps/novnc )
- sys-apps/iproute2
- openvswitch? ( net-misc/openvswitch )
- rabbitmq? ( net-misc/rabbitmq-server )
- memcached? (
- net-misc/memcached
- >=dev-python/python-memcached-1.58
- )
- sys-fs/sysfsutils
- sys-fs/multipath-tools
- net-misc/bridge-utils
- compute? (
- app-cdr/cdrtools
- sys-fs/dosfstools
- app-emulation/qemu
- )
- iscsi? (
- sys-fs/lsscsi
- >=sys-block/open-iscsi-2.0.873-r1
- )"
-
-#PATCHES=(
-#)
-
-pkg_setup() {
- linux-info_pkg_setup
- CONFIG_CHECK_MODULES="BLK_DEV_NBD VHOST_NET IP6_NF_FILTER IP6_NF_IPTABLES IP_NF_TARGET_REJECT \
- IP_NF_MANGLE IP_NF_TARGET_MASQUERADE NF_NAT_IPV4 IP_NF_FILTER IP_NF_IPTABLES \
- NF_CONNTRACK_IPV4 NF_DEFRAG_IPV4 NF_NAT_IPV4 NF_NAT NF_CONNTRACK NETFILTER_XTABLES \
- ISCSI_TCP SCSI_DH DM_MULTIPATH DM_SNAPSHOT"
- if linux_config_exists; then
- for module in ${CONFIG_CHECK_MODULES}; do
- linux_chkconfig_present ${module} || ewarn "${module} needs to be enabled in kernel"
- done
- fi
- enewgroup nova
- enewuser nova -1 -1 /var/lib/nova nova
-}
-
-python_prepare_all() {
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use !compute-only; then
- for svc in api cert conductor consoleauth network scheduler spicehtml5proxy xvpvncproxy; do
- newinitd "${FILESDIR}/nova.initd" "nova-${svc}"
- done
- fi
- use compute && newinitd "${FILESDIR}/nova.initd" "nova-compute"
- use novncproxy && newinitd "${FILESDIR}/nova.initd" "nova-novncproxy"
-
- diropts -m 0750 -o nova -g qemu
- dodir /var/log/nova /var/lib/nova/instances
- diropts -m 0750 -o nova -g nova
-
- insinto /etc/nova
- insopts -m 0640 -o nova -g nova
- newins "${DISTDIR}/nova.conf.sample-${PV}" "nova.conf.sample"
- doins "${FILESDIR}/nova-compute.conf"
- doins "${S}/etc/nova/"*
- # rootwrap filters
- insopts -m 0644
- insinto /etc/nova/rootwrap.d
- doins "etc/nova/rootwrap.d/api-metadata.filters"
- doins "etc/nova/rootwrap.d/compute.filters"
- doins "etc/nova/rootwrap.d/network.filters"
-
- # add sudoers definitions for user nova
- insinto /etc/sudoers.d/
- insopts -m 0600 -o root -g root
- doins "${FILESDIR}/nova-sudoers"
-
- if use iscsi ; then
- # Install udev rules for handle iscsi disk with right links under /dev
- udev_newrules "${FILESDIR}/openstack-scsi-disk.rules" 60-openstack-scsi-disk.rules
-
- insinto /etc/nova/
- doins "${FILESDIR}/scsi-openscsi-link.sh"
- fi
-}
-
-python_install() {
- distutils-r1_python_install
- # copy migration conf file (not coppied on install via setup.py script)
- insinto "$(python_get_sitedir)/db/sqlalchemy/migrate_repo/"
- doins "nova/db/sqlalchemy/migrate_repo/migrate.cfg"
- # copy the CA cert dir (not coppied on install via setup.py script)
- cp -R "${S}/nova/CA" "${D}/$(python_get_sitedir)/nova/" || die "installing CA files failed"
-}
-
-pkg_postinst() {
- if use iscsi ; then
- elog "iscsid needs to be running if you want cinder to connect"
- fi
-}
diff --git a/sys-cluster/nova/nova-16.0.4.ebuild b/sys-cluster/nova/nova-16.0.4.ebuild
index 7fe984e7df04..8856721e03fb 100644
--- a/sys-cluster/nova/nova-16.0.4.ebuild
+++ b/sys-cluster/nova/nova-16.0.4.ebuild
@@ -199,11 +199,11 @@ python_install_all() {
if use !compute-only; then
for svc in api conductor consoleauth network scheduler spicehtml5proxy xvpvncproxy; do
- newinitd "${FILESDIR}/nova.initd-2" "nova-${svc}"
+ newinitd "${FILESDIR}/nova.initd" "nova-${svc}"
done
fi
- use compute && newinitd "${FILESDIR}/nova.initd-2" "nova-compute"
- use novncproxy && newinitd "${FILESDIR}/nova.initd-2" "nova-novncproxy"
+ use compute && newinitd "${FILESDIR}/nova.initd" "nova-compute"
+ use novncproxy && newinitd "${FILESDIR}/nova.initd" "nova-novncproxy"
diropts -m 0750 -o nova -g qemu
dodir /var/log/nova /var/lib/nova/instances
diff --git a/sys-cluster/nova/nova-2017.1.9999.ebuild b/sys-cluster/nova/nova-2017.1.9999.ebuild
deleted file mode 100644
index fa38dc987200..000000000000
--- a/sys-cluster/nova/nova-2017.1.9999.ebuild
+++ /dev/null
@@ -1,232 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit distutils-r1 eutils git-r3 linux-info multilib user
-
-DESCRIPTION="Cloud computing fabric controller (main part of an IaaS system) in Python"
-HOMEPAGE="https://launchpad.net/nova"
-SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/openstack/nova/ocata/nova.conf.sample -> nova.conf.sample-${PV}"
-EGIT_REPO_URI="https://github.com/openstack/nova.git"
-EGIT_BRANCH="stable/ocata"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS=""
-IUSE="+compute compute-only iscsi +memcached mysql +novncproxy openvswitch postgres +rabbitmq sqlite"
-REQUIRED_USE="
- !compute-only? ( || ( mysql postgres sqlite ) )
- compute-only? ( compute !rabbitmq !memcached !mysql !postgres !sqlite )"
-
-CDEPEND="
- >=dev-python/setuptools-16.0[${PYTHON_USEDEP}]
- !~dev-python/setuptools-24.0.0[${PYTHON_USEDEP}]
- !~dev-python/setuptools-34.0.0[${PYTHON_USEDEP}]
- !~dev-python/setuptools-34.0.1[${PYTHON_USEDEP}]
- !~dev-python/setuptools-34.0.2[${PYTHON_USEDEP}]
- !~dev-python/setuptools-34.0.3[${PYTHON_USEDEP}]
- !~dev-python/setuptools-34.1.0[${PYTHON_USEDEP}]
- !~dev-python/setuptools-34.1.1[${PYTHON_USEDEP}]
- !~dev-python/setuptools-34.2.0[${PYTHON_USEDEP}]
- !~dev-python/setuptools-34.3.0[${PYTHON_USEDEP}]
- !~dev-python/setuptools-34.3.1[${PYTHON_USEDEP}]
- !~dev-python/setuptools-34.3.2[${PYTHON_USEDEP}]
- >=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
-DEPEND="
- ${CDEPEND}
- app-admin/sudo"
-
-RDEPEND="
- ${CDEPEND}
- compute-only? (
- >=dev-python/sqlalchemy-1.0.10[${PYTHON_USEDEP}]
- <dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
- )
- sqlite? (
- >=dev-python/sqlalchemy-1.0.10[sqlite,${PYTHON_USEDEP}]
- <dev-python/sqlalchemy-1.1.0[sqlite,${PYTHON_USEDEP}]
- )
- mysql? (
- >=dev-python/pymysql-0.7.6[${PYTHON_USEDEP}]
- !~dev-python/pymysql-0.7.7[${PYTHON_USEDEP}]
- >=dev-python/sqlalchemy-1.0.10[${PYTHON_USEDEP}]
- <dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
- )
- postgres? (
- >=dev-python/psycopg-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/sqlalchemy-1.0.10[${PYTHON_USEDEP}]
- <dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
- )
- >=dev-python/decorator-3.4.0[${PYTHON_USEDEP}]
- >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.8[${PYTHON_USEDEP}]
- !~dev-python/jinja-2.9.0[${PYTHON_USEDEP}]
- !~dev-python/jinja-2.9.1[${PYTHON_USEDEP}]
- !~dev-python/jinja-2.9.2[${PYTHON_USEDEP}]
- !~dev-python/jinja-2.9.3[${PYTHON_USEDEP}]
- !~dev-python/jinja-2.9.4[${PYTHON_USEDEP}]
- >=dev-python/keystonemiddleware-4.12.0[${PYTHON_USEDEP}]
- >=dev-python/lxml-2.3[${PYTHON_USEDEP}]
- !~dev-python/lxml-3.7.0[${PYTHON_USEDEP}]
- >=dev-python/routes-1.12.3[${PYTHON_USEDEP}]
- !~dev-python/routes-2.0[${PYTHON_USEDEP}]
- !~dev-python/routes-2.1[$(python_gen_usedep 'python2_7')]
- !~dev-python/routes-2.3[${PYTHON_USEDEP}]
- >=dev-python/cryptography-1.0[${PYTHON_USEDEP}]
- !~dev-python/cryptography-1.3.0[${PYTHON_USEDEP}]
- >=dev-python/webob-1.6.0[${PYTHON_USEDEP}]
- >=dev-python/greenlet-0.3.2[${PYTHON_USEDEP}]
- >=dev-python/pastedeploy-1.5.0-r1[${PYTHON_USEDEP}]
- dev-python/paste[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
- <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
- >=dev-python/sqlalchemy-migrate-0.9.6[${PYTHON_USEDEP}]
- >=dev-python/netaddr-0.7.13[${PYTHON_USEDEP}]
- !~dev-python/netaddr-0.7.16[${PYTHON_USEDEP}]
- >=dev-python/netifaces-0.10.4[${PYTHON_USEDEP}]
- >=dev-python/paramiko-2.0[${PYTHON_USEDEP}]
- >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
- >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/jsonschema-2.5.0[${PYTHON_USEDEP}]
- <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/python-cinderclient-1.6.0[${PYTHON_USEDEP}]
- !~dev-python/python-cinderclient-1.7.0[${PYTHON_USEDEP}]
- !~dev-python/python-cinderclient-1.7.1[${PYTHON_USEDEP}]
- >=dev-python/keystoneauth-2.18.0[${PYTHON_USEDEP}]
- >=dev-python/python-neutronclient-5.1.0[${PYTHON_USEDEP}]
- >=dev-python/python-glanceclient-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
- !~dev-python/requests-2.12.2[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=dev-python/stevedore-1.17.1[${PYTHON_USEDEP}]
- >=dev-python/websockify-0.8.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-cache-1.5.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-concurrency-3.8.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-3.14.0[${PYTHON_USEDEP}]
- !~dev-python/oslo-config-3.18.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-context-2.9.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-log-3.11.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-reports-0.6.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-3.18.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-db-4.15.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-rootwrap-5.0.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-messaging-5.14.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-policy-1.17.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-privsep-1.9.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-service-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/rfc3986-0.3.1[${PYTHON_USEDEP}]
- >=dev-python/oslo-middleware-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/psutil-3.0.1[${PYTHON_USEDEP}]
- >=dev-python/oslo-versionedobjects-1.17.0[${PYTHON_USEDEP}]
- >=dev-python/os-brick-1.8.0[${PYTHON_USEDEP}]
- >=dev-python/os-vif-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/os-win-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/castellan-0.4.0[${PYTHON_USEDEP}]
- >=dev-python/microversion-parse-0.1.2[${PYTHON_USEDEP}]
- >=dev-python/os-xenapi-0.1.1[${PYTHON_USEDEP}]
- dev-python/libvirt-python[${PYTHON_USEDEP}]
- app-emulation/libvirt[iscsi?]
- novncproxy? ( www-apps/novnc )
- sys-apps/iproute2
- openvswitch? ( net-misc/openvswitch )
- rabbitmq? ( net-misc/rabbitmq-server )
- memcached? (
- net-misc/memcached
- >=dev-python/python-memcached-1.58
- )
- sys-fs/sysfsutils
- sys-fs/multipath-tools
- net-misc/bridge-utils
- compute? (
- app-cdr/cdrtools
- sys-fs/dosfstools
- app-emulation/qemu
- )
- iscsi? (
- sys-fs/lsscsi
- >=sys-block/open-iscsi-2.0.873-r1
- )"
-
-#PATCHES=(
-#)
-
-pkg_setup() {
- linux-info_pkg_setup
- CONFIG_CHECK_MODULES="BLK_DEV_NBD VHOST_NET IP6_NF_FILTER IP6_NF_IPTABLES IP_NF_TARGET_REJECT \
- IP_NF_MANGLE IP_NF_TARGET_MASQUERADE NF_NAT_IPV4 IP_NF_FILTER IP_NF_IPTABLES \
- NF_CONNTRACK_IPV4 NF_DEFRAG_IPV4 NF_NAT_IPV4 NF_NAT NF_CONNTRACK NETFILTER_XTABLES \
- ISCSI_TCP SCSI_DH DM_MULTIPATH DM_SNAPSHOT"
- if linux_config_exists; then
- for module in ${CONFIG_CHECK_MODULES}; do
- linux_chkconfig_present ${module} || ewarn "${module} needs to be enabled in kernel"
- done
- fi
- enewgroup nova
- enewuser nova -1 -1 /var/lib/nova nova
-}
-
-python_prepare_all() {
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use !compute-only; then
- for svc in api cert conductor consoleauth network scheduler spicehtml5proxy xvpvncproxy; do
- newinitd "${FILESDIR}/nova.initd" "nova-${svc}"
- done
- fi
- use compute && newinitd "${FILESDIR}/nova.initd" "nova-compute"
- use novncproxy && newinitd "${FILESDIR}/nova.initd" "nova-novncproxy"
-
- diropts -m 0750 -o nova -g qemu
- dodir /var/log/nova /var/lib/nova/instances
- diropts -m 0750 -o nova -g nova
-
- insinto /etc/nova
- insopts -m 0640 -o nova -g nova
- newins "${DISTDIR}/nova.conf.sample-${PV}" "nova.conf.sample"
- doins "${FILESDIR}/nova-compute.conf"
- doins "${S}/etc/nova/"*
- # rootwrap filters
- insopts -m 0644
- insinto /etc/nova/rootwrap.d
- doins "etc/nova/rootwrap.d/api-metadata.filters"
- doins "etc/nova/rootwrap.d/compute.filters"
- doins "etc/nova/rootwrap.d/network.filters"
-
- # add sudoers definitions for user nova
- insinto /etc/sudoers.d/
- insopts -m 0600 -o root -g root
- doins "${FILESDIR}/nova-sudoers"
-
- if use iscsi ; then
- # Install udev rules for handle iscsi disk with right links under /dev
- udev_newrules "${FILESDIR}/openstack-scsi-disk.rules" 60-openstack-scsi-disk.rules
-
- insinto /etc/nova/
- doins "${FILESDIR}/scsi-openscsi-link.sh"
- fi
-}
-
-python_install() {
- distutils-r1_python_install
- # copy migration conf file (not coppied on install via setup.py script)
- insinto "$(python_get_sitedir)/db/sqlalchemy/migrate_repo/"
- doins "nova/db/sqlalchemy/migrate_repo/migrate.cfg"
- # copy the CA cert dir (not coppied on install via setup.py script)
- cp -R "${S}/nova/CA" "${D}/$(python_get_sitedir)/nova/" || die "installing CA files failed"
-}
-
-pkg_postinst() {
- if use iscsi ; then
- elog "iscsid needs to be running if you want cinder to connect"
- fi
-}
diff --git a/sys-cluster/nova/nova-2017.2.9999.ebuild b/sys-cluster/nova/nova-2017.2.9999.ebuild
index 4bc17bcde842..b3bfe7036dfd 100644
--- a/sys-cluster/nova/nova-2017.2.9999.ebuild
+++ b/sys-cluster/nova/nova-2017.2.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -200,11 +200,11 @@ python_install_all() {
if use !compute-only; then
for svc in api conductor consoleauth network scheduler spicehtml5proxy xvpvncproxy; do
- newinitd "${FILESDIR}/nova.initd-2" "nova-${svc}"
+ newinitd "${FILESDIR}/nova.initd" "nova-${svc}"
done
fi
- use compute && newinitd "${FILESDIR}/nova.initd-2" "nova-compute"
- use novncproxy && newinitd "${FILESDIR}/nova.initd-2" "nova-novncproxy"
+ use compute && newinitd "${FILESDIR}/nova.initd" "nova-compute"
+ use novncproxy && newinitd "${FILESDIR}/nova.initd" "nova-novncproxy"
diropts -m 0750 -o nova -g qemu
dodir /var/log/nova /var/lib/nova/instances