summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2016-10-24 16:38:28 -0600
committerChristoph Junghans <ottxor@gentoo.org>2016-10-24 16:38:40 -0600
commitef99c4775e6802611ac2175a67a8c837cb3d4924 (patch)
tree1aff2977c320203402d39d4a215f61d3c2550546 /sys-cluster
parentapp-misc/ckb: Fix dependency on quazip (diff)
downloadgentoo-ef99c4775e6802611ac2175a67a8c837cb3d4924.tar.gz
gentoo-ef99c4775e6802611ac2175a67a8c837cb3d4924.tar.bz2
gentoo-ef99c4775e6802611ac2175a67a8c837cb3d4924.zip
sys-cluster/legion: version bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/legion/Manifest1
-rw-r--r--sys-cluster/legion/legion-16.10.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-cluster/legion/Manifest b/sys-cluster/legion/Manifest
index f02219e60c8c..0008690e1ba5 100644
--- a/sys-cluster/legion/Manifest
+++ b/sys-cluster/legion/Manifest
@@ -1 +1,2 @@
DIST legion-16.08.0.tar.gz 2501054 SHA256 c2a344e54124172b49d97e0e0033021e9ed3d9ddb4158b0620430c5597f6ccba SHA512 8847fa8c0c7683812dd6ffb038a4d6d3427fdfde62ec917ab32e9a15cd7320321cab2b106479589aa2451cabd98cd0b1dc88b4ff668f991bb4c95f383de785a5 WHIRLPOOL 355f54164fca71c49891869644c841814600c09253bc807297bc79391f13f05fbe93029f29918167cd79a745928b0d991bc671ccd841320a32ce67941f34705c
+DIST legion-16.10.0.tar.gz 2474656 SHA256 92190ae5ff0a1f6356890446e026479ed715230d4761a40d4834af256a722099 SHA512 cfe610fef047def835f95adcc4ae52d7844a4a89a5bdebb2ec40b0e63a66aba9d180bd78e559762b1ac18f84c1ca1142c3e73238dbe4c516672a8843335442a5 WHIRLPOOL 3a0e083b9d8d5c5071f1914e7cc3fda0c7c5bc2f4d187506aee9d3c1def8a046ec7732f2ce105bc3ee93075f35fc2ee7952020e2806e7f43be962018147111fb
diff --git a/sys-cluster/legion/legion-16.10.0.ebuild b/sys-cluster/legion/legion-16.10.0.ebuild
new file mode 100644
index 000000000000..be3148893cd1
--- /dev/null
+++ b/sys-cluster/legion/legion-16.10.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+CMAKE_MIN_VERSION=3.6
+
+inherit cmake-utils
+
+DESCRIPTION="A data-centric parallel programming system"
+HOMEPAGE="http://legion.stanford.edu/"
+SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gasnet +hwloc"
+
+DEPEND="
+ gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
+ hwloc? ( sys-apps/hwloc )
+ "
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_configure() {
+ mycmakeargs=(
+ -DLegion_USE_HWLOC=$(usex hwloc)
+ -DLegion_USE_GASNet=$(usex gasnet)
+ -DBUILD_SHARED_LIBS=ON
+ -DLegion_BUILD_EXAMPLES=ON
+ )
+ cmake-utils_src_configure
+}