summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-08-11 15:03:00 -0400
committerBrian Evans <grknight@gentoo.org>2016-08-11 15:04:14 -0400
commitfbac5e93460b4e3d06037d73e5a519449c8118b2 (patch)
tree5d1faf7fca08eeed98cbb3a8135bb5f787687d9a /sys-cluster
parentapp-crypt/pinentry: Use -std=c++11 if using Qt >= 5.7 (diff)
downloadgentoo-fbac5e93460b4e3d06037d73e5a519449c8118b2.tar.gz
gentoo-fbac5e93460b4e3d06037d73e5a519449c8118b2.tar.bz2
gentoo-fbac5e93460b4e3d06037d73e5a519449c8118b2.zip
sys-cluster/galera: Version bump
Include Node name change for garbd wrt bug 581518 Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/galera/Manifest1
-rw-r--r--sys-cluster/galera/files/garb.cnf3
-rw-r--r--sys-cluster/galera/files/garb.sh6
-rw-r--r--sys-cluster/galera/galera-25.3.17.ebuild87
4 files changed, 94 insertions, 3 deletions
diff --git a/sys-cluster/galera/Manifest b/sys-cluster/galera/Manifest
index 8ff186dd7f7b..c6394d914489 100644
--- a/sys-cluster/galera/Manifest
+++ b/sys-cluster/galera/Manifest
@@ -1 +1,2 @@
DIST galera-3-25.3.15.tar.gz 2994995 SHA256 0de1c1c8304e7f1dfa43ef2a2b15c8ca724556d5b187c31c8a93c755737163af SHA512 717c431d29653cba3252dae5a845e82c02e4cb122a6477253e68688600bf130a753f89f94b7b2461695ede9033ca0107324831d2c5b7d2d0479a0936d2779e84 WHIRLPOOL e0fa0de7e0a75563f78feec488fda64bc4ec9cc97a369e18fbf3c817c520a8a5e3118a4c95f14cf987f019f4f9c96f86df32c4b87c66ec7750c401e0017daf76
+DIST galera-3-25.3.17.tar.gz 2999905 SHA256 521d97dd4618ec3e889756527144e12eb99a95f852a83d13afca57986a4a575a SHA512 b54985a74ed4c4d21c368c56a8442961648670eef18f03f2813a9fac34972532ea2f6c79997945de1c9dd1b4dfd5b862a38c052ef6e0d94bd5c85e05e042e61f WHIRLPOOL b755a9f33747c079a4fc47cddd8993c46fd422139f4c5e5de92be146ee09a2f38b07b02e5250a9b726cabec6c4194b593aa8407d6ef37cd6f7aeb04a036ea155
diff --git a/sys-cluster/galera/files/garb.cnf b/sys-cluster/galera/files/garb.cnf
index 4f0047a02c25..63b79c1d2259 100644
--- a/sys-cluster/galera/files/garb.cnf
+++ b/sys-cluster/galera/files/garb.cnf
@@ -7,6 +7,9 @@
# Galera cluster name, should be the same as on the rest of the nodes.
# GALERA_GROUP=""
+# Arbitrator node name, give a specific name to this node in cluster.
+# NODE_NAME=""
+
# Optional Galera internal options string (e.g. SSL settings)
# see http://www.codership.com/wiki/doku.php?id=galera_parameters
# GALERA_OPTIONS=""
diff --git a/sys-cluster/galera/files/garb.sh b/sys-cluster/galera/files/garb.sh
index da7d55093f5d..f03eaffc076a 100644
--- a/sys-cluster/galera/files/garb.sh
+++ b/sys-cluster/galera/files/garb.sh
@@ -1,5 +1,5 @@
#!/sbin/openrc-run
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
depend() {
@@ -24,7 +24,8 @@ start() {
OPTIONS="-a gcomm://${GALERA_NODES// /,} -g ${GALERA_GROUP}"
[ -n "${GALERA_OPTIONS}" ] && OPTIONS="${OPTIONS} -o ${GALERA_OPTIONS}"
- [ -n "${LOG_FILE}" ] && OPTIONS="${OPTIONS} -l ${LOG_FILE}"
+ [ -n "${LOG_FILE}" ] && OPTIONS="${OPTIONS} -l ${LOG_FILE}"
+ [ -n "${NODE_NAME}" ] && OPTIONS="${OPTIONS} -n ${NODE_NAME}"
start-stop-daemon \
--start \
@@ -46,4 +47,3 @@ stop() {
--pidfile "${PIDFILE}"
eend $?
}
-
diff --git a/sys-cluster/galera/galera-25.3.17.ebuild b/sys-cluster/galera/galera-25.3.17.ebuild
new file mode 100644
index 000000000000..f3b2b293e5f8
--- /dev/null
+++ b/sys-cluster/galera/galera-25.3.17.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_P="${PN}-3-${PV}"
+
+inherit scons-utils toolchain-funcs user flag-o-matic
+DESCRIPTION="Synchronous multi-master replication engine that provides the wsrep API"
+HOMEPAGE="http://www.galeracluster.com"
+SRC_URI="http://releases.galeracluster.com/source/galera-3-${PV}.tar.gz"
+LICENSE="GPL-2 BSD"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="cpu_flags_x86_sse4_2 garbd test"
+
+CDEPEND="
+ dev-libs/openssl:0=
+ >=dev-libs/boost-1.41:0=
+ "
+DEPEND="${DEPEND}
+ ${CDEPEND}
+ dev-libs/check
+ >=sys-devel/gcc-4.4
+ >=dev-cpp/asio-1.10.1[ssl]
+ "
+#Run time only
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+# Respect {C,LD}FLAGS.
+PATCHES=( "${FILESDIR}/galera-3.15-strip-extra-cflags.patch" )
+
+pkg_preinst() {
+ if use garbd ; then
+ enewgroup garbd
+ enewuser garbd -1 -1 -1 garbd
+ fi
+}
+
+src_prepare() {
+ default
+
+ # Remove bundled dev-cpp/asio
+ rm -r "${S}/asio" || die
+
+ #Remove optional garbd daemon
+ if ! use garbd ; then
+ rm -r "${S}/garb" || die
+ fi
+}
+
+src_configure() {
+ tc-export CC CXX
+ # Uses hardware specific code that seems to depend on SSE4.2
+ if use cpu_flags_x86_sse4_2 ; then
+ append-cflags -msse4.2
+ else
+ append-cflags -DCRC32C_NO_HARDWARE
+ fi
+ # strict_build_flags=0 disables -Werror, -pedantic, -Weffc++,
+ # and -Wold-style-cast
+ MYSCONS=(
+ ssl=1
+ tests=$(usex test 1 0)
+ strict_build_flags=0
+ )
+}
+
+src_compile() {
+ escons --warn=no-missing-sconscript "${MYSCONS[@]}"
+}
+
+src_install() {
+ dodoc scripts/packages/README scripts/packages/README-MySQL
+ if use garbd ; then
+ dobin garb/garbd
+ newconfd "${FILESDIR}/garb.cnf" garbd
+ newinitd "${FILESDIR}/garb.sh" garbd
+ doman man/garbd.8
+ fi
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe libgalera_smm.so
+}