summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-29 00:45:23 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-29 00:49:40 +0100
commit56227c8be30ea6f3b60e9b6d512ea77f43ab8042 (patch)
treee85e70427747c37cfc6da48190305ca40ecf8a5e /sys-devel/autoconf
parentsys-devel/autoconf-wrapper: Bump to version 15 (diff)
downloadgentoo-56227c8be30ea6f3b60e9b6d512ea77f43ab8042.tar.gz
gentoo-56227c8be30ea6f3b60e9b6d512ea77f43ab8042.tar.bz2
gentoo-56227c8be30ea6f3b60e9b6d512ea77f43ab8042.zip
sys-devel/autoconf: Bump to version 2.71
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-devel/autoconf')
-rw-r--r--sys-devel/autoconf/Manifest1
-rw-r--r--sys-devel/autoconf/autoconf-2.71.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/sys-devel/autoconf/Manifest b/sys-devel/autoconf/Manifest
index 0a40af81ae80..26d4a38e2e7f 100644
--- a/sys-devel/autoconf/Manifest
+++ b/sys-devel/autoconf/Manifest
@@ -4,3 +4,4 @@ DIST autoconf-2.69-runstatedir_patches.tar.xz 257096 BLAKE2B ae765e0ca7fe8261117
DIST autoconf-2.69.tar.xz 1214744 BLAKE2B 71d33d72a06e9a05fbed0eda73bc9d8a3805c7c90bf082959862f93f3c5f01192114176e84d84ecb58fa99512eafbc0ab21ad1407be18c8c63bb3dc1117c482d SHA512 995d3e5a8eb1eb37e2b7fae53c6ec7a9b4df997286b7d643344818f94636756b1bf5ff5ea9155e755cb9461149a853dfbf2886fc6bd7132e5afa9c168e306e9b
DIST autoconf-2.70-patches-01.tar.xz 27284 BLAKE2B fa4ef923d487f600de98d765d3db23c73cd546f777c19986f9179cbe0e9eb254e3bb4c8107b6ce9f2c1f008b4c72033565711f0d8b63e6538b83ec56a2d75875 SHA512 648604ec24decbc48d281049eca94e7e7146d013c006297d9d9c71b749bd856684b8ab8550ac8961ce506b036ad25b7236dfb5e53114c10edfefbd58ecc55020
DIST autoconf-2.70.tar.xz 1346528 BLAKE2B 7a14f966f1fb89a250aedb03d483ab1f92d73a7085bc289094b62984620563922d041e717274270af0afaf52f058b4c6402c1af14cce58d70d5d884414797c80 SHA512 af4af6b8811baa424c00990b368a6cbfb1d598dde9ee08dce2a5fc32cb9517e6e683a59d6852507f6a72d499fc298c4171b6f06962cf3ba40cf1557cfb6069fe
+DIST autoconf-2.71.tar.xz 1292296 BLAKE2B 7fd4b98b4cfff10720e8da6ee91045637991643b50fcb3e47a0ecfcc01600f7b7b36fd1c0a5f08b68a418f1bdbd8d5a98de1008157595dd37cc3a31facb61416 SHA512 73d32b4adcbe24e3bafa9f43f59ed3b6efbd3de0f194e5ec90375f35da1199c583f5d3e89139b7edbad35171403709270e339ffa56a2ecb9b3123e9285021ff0
diff --git a/sys-devel/autoconf/autoconf-2.71.ebuild b/sys-devel/autoconf/autoconf-2.71.ebuild
new file mode 100644
index 000000000000..e5bc4fffa76c
--- /dev/null
+++ b/sys-devel/autoconf/autoconf-2.71.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/autoconf.git"
+ inherit git-r3
+else
+ # For _beta handling replace with real version number
+ MY_PV="${PV}"
+ MY_P="${PN}-${MY_PV}"
+ #PATCH_TARBALL_NAME="${PN}-2.70-patches-01"
+ SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.xz -> ${P}.tar.xz
+ https://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.xz -> ${P}.tar.xz"
+ #SRC_URI+=" https://dev.gentoo.org/~polynomial-c/${PATCH_TARBALL_NAME}.tar.xz"
+ [[ "${PV}" == *_beta* ]] || \
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+inherit toolchain-autoconf
+
+DESCRIPTION="Used to create autoconfiguration files"
+HOMEPAGE="https://www.gnu.org/software/autoconf/autoconf.html"
+
+LICENSE="GPL-3"
+SLOT="${PV/_*}"
+IUSE="emacs"
+
+BDEPEND=">=sys-devel/m4-1.4.16
+ >=dev-lang/perl-5.6"
+RDEPEND="${BDEPEND}
+ >=sys-devel/autoconf-wrapper-15
+ sys-devel/gnuconfig
+ !~sys-devel/${P}:2.5"
+[[ ${PV} == "9999" ]] && BDEPEND+=" >=sys-apps/texinfo-4.3"
+PDEPEND="emacs? ( app-emacs/autoconf-mode )"
+
+src_prepare() {
+ # usr/bin/libtool is provided by binutils-apple, need gnu libtool
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ PATCHES+=( "${FILESDIR}"/${PN}-2.61-darwin.patch )
+ fi
+
+ # Save timestamp to avoid later makeinfo call
+ touch -r doc/{,old_}autoconf.texi || die
+
+ local pdir
+ for pdir in "${WORKDIR}"/{upstream_,}patches ; do
+ if [[ -d "${pdir}" ]] ; then
+ eapply ${pdir}
+ fi
+ done
+
+ toolchain-autoconf_src_prepare
+
+ # Restore timestamp to avoid makeinfo call
+ # We already have an up to date autoconf.info page at this point.
+ touch -r doc/{old_,}autoconf.texi || die
+}
+
+src_install() {
+ default
+
+ local f
+ for f in config.{guess,sub} ; do
+ ln -fs ../../gnuconfig/${f} \
+ "${ED}"/usr/share/autoconf-*/build-aux/${f} || die
+ done
+}