summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-11-20 21:24:59 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2018-11-20 21:25:27 +0000
commit9b91d2d1cd183610dcfee1abea744485ac0d34f6 (patch)
treed0449a9b32d62b1c5bad3ac99159313a4ea0e77e /sys-devel/autogen/autogen-5.18.16.ebuild
parentdev-libs/elfutils: bump up to 0.175, bug #671560 (diff)
downloadgentoo-9b91d2d1cd183610dcfee1abea744485ac0d34f6.tar.gz
gentoo-9b91d2d1cd183610dcfee1abea744485ac0d34f6.tar.bz2
gentoo-9b91d2d1cd183610dcfee1abea744485ac0d34f6.zip
sys-devel/autogen: bump up to 5.18.16, bug #671564
Reported-by: Lars Wendler (Polynomial-C) Closes: https://bugs.gentoo.org/671564 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/autogen/autogen-5.18.16.ebuild')
-rw-r--r--sys-devel/autogen/autogen-5.18.16.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-devel/autogen/autogen-5.18.16.ebuild b/sys-devel/autogen/autogen-5.18.16.ebuild
new file mode 100644
index 000000000000..fc70a815c931
--- /dev/null
+++ b/sys-devel/autogen/autogen-5.18.16.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Program and text file generation"
+HOMEPAGE="https://www.gnu.org/software/autogen/"
+SRC_URI="mirror://gnu/${PN}/rel${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="libopts static-libs"
+
+RDEPEND=">=dev-scheme/guile-2.0:=
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.18.16-no-werror.patch
+)
+
+src_configure() {
+ # suppress possibly incorrect -R flag
+ export ag_cv_test_ldflags=
+
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+
+ if ! use libopts ; then
+ rm "${ED}"/usr/share/autogen/libopts-*.tar.gz || die
+ fi
+}