summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-02-25 02:39:04 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-02-25 02:58:45 +0100
commit43d394421ca6fcc030952d60200f2888fcd37cb6 (patch)
tree36d38b6f93e0e6ccdcde11b49593bb3eecdf665b /sys-devel/automake/automake-1.10.3-r3.ebuild
parentnet-p2p/cpuminer-opt: 3.8.3.2 version bump (diff)
downloadgentoo-43d394421ca6fcc030952d60200f2888fcd37cb6.tar.gz
gentoo-43d394421ca6fcc030952d60200f2888fcd37cb6.tar.bz2
gentoo-43d394421ca6fcc030952d60200f2888fcd37cb6.zip
sys-devel/automake: Rev bump to address several issues
Ebuild changes: =============== - EAPI bumped to EAPI=6 (1.9.x-1.14.x). - Avoid (low risk) race in /tmp (1.10.x-1.15.x). [Bug 522638] - Avoid makeinfo requirement when bootstraping (1.14.x-1.15.x). [Bug 628912] - Fix man4.test failure (1.11.x). [Bug 583108] - Add Python 2.7 requirement for test suite. [Bug 483358, 623432] - Fix test failures when using >=app-arch/gzip-1.8 (1.14.x). [Bug 604570] - Updated GIT/SRC_URI to use HTTPS (1.14.x-1.15.x). - Live ebuild updated with changes from above (9999). Closes: https://bugs.gentoo.org/583108 Closes: https://bugs.gentoo.org/483358 Closes: https://bugs.gentoo.org/623432 Closes: https://bugs.gentoo.org/604570 Bug: https://bugs.gentoo.org/522638 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-devel/automake/automake-1.10.3-r3.ebuild')
-rw-r--r--sys-devel/automake/automake-1.10.3-r3.ebuild95
1 files changed, 95 insertions, 0 deletions
diff --git a/sys-devel/automake/automake-1.10.3-r3.ebuild b/sys-devel/automake/automake-1.10.3-r3.ebuild
new file mode 100644
index 000000000000..7ce1045c9103
--- /dev/null
+++ b/sys-devel/automake/automake-1.10.3-r3.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-any-r1
+
+DESCRIPTION="Used to generate Makefile.in from Makefile.am"
+HOMEPAGE="https://www.gnu.org/software/automake/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+# Use Gentoo versioning for slotting.
+SLOT="${PV:0:4}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="test"
+
+RDEPEND="dev-lang/perl
+ >=sys-devel/automake-wrapper-10
+ >=sys-devel/autoconf-2.69:*
+ sys-devel/gnuconfig"
+DEPEND="${RDEPEND}
+ sys-apps/help2man
+ test? ( ${PYTHON_DEPS} )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.10-perl-5.16.patch #424453
+ "${FILESDIR}"/${PN}-1.11-install-sh-avoid-low-risk-race-in-tmp.patch
+ "${FILESDIR}"/${PN}-1.13-perl-escape-curly-bracket-r1.patch
+)
+
+src_prepare() {
+ default
+ export WANT_AUTOCONF=2.5
+ chmod a+rx tests/*.test
+}
+
+src_configure() {
+ econf --docdir="\$(datarootdir)/doc/${PF}"
+}
+
+# slot the info pages. do this w/out munging the source so we don't have
+# to depend on texinfo to regen things. #464146 (among others)
+slot_info_pages() {
+ pushd "${ED%/}"/usr/share/info >/dev/null || die
+ rm -f dir || die
+
+ # Rewrite all the references to other pages.
+ # before: * aclocal-invocation: (automake)aclocal Invocation. Generating aclocal.m4.
+ # after: * aclocal-invocation v1.13: (automake-1.13)aclocal Invocation. Generating aclocal.m4.
+ local p pages=( *.info ) args=()
+ for p in "${pages[@]/%.info}" ; do
+ args+=(
+ -e "/START-INFO-DIR-ENTRY/,/END-INFO-DIR-ENTRY/s|: (${p})| v${SLOT}&|"
+ -e "s:(${p}):(${p}-${SLOT}):g"
+ )
+ done
+ sed -i "${args[@]}" * || die
+
+ # Rewrite all the file references, and rename them in the process.
+ local f d
+ for f in * ; do
+ d=${f/.info/-${SLOT}.info}
+ mv "${f}" "${d}" || die
+ sed -i -e "s:${f}:${d}:g" * || die
+ done
+
+ popd >/dev/null || die
+}
+
+src_test() {
+ python_setup
+
+ default
+}
+
+src_install() {
+ default
+ slot_info_pages
+
+ # SLOT the docs and junk
+ local x
+ for x in aclocal automake ; do
+ help2man "perl -Ilib ${x}" > ${x}-${SLOT}.1
+ doman ${x}-${SLOT}.1
+ rm -f "${ED%/}"/usr/bin/${x}
+ done
+
+ # remove all config.guess and config.sub files replacing them
+ # w/a symlink to a specific gnuconfig version
+ for x in guess sub ; do
+ dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
+ done
+}