summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /sys-devel/binutils-apple/binutils-apple-3.2.ebuild
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-devel/binutils-apple/binutils-apple-3.2.ebuild')
-rw-r--r--sys-devel/binutils-apple/binutils-apple-3.2.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/sys-devel/binutils-apple/binutils-apple-3.2.ebuild b/sys-devel/binutils-apple/binutils-apple-3.2.ebuild
index e60586c9425b..4ccf5b257b9c 100644
--- a/sys-devel/binutils-apple/binutils-apple-3.2.ebuild
+++ b/sys-devel/binutils-apple/binutils-apple-3.2.ebuild
@@ -134,7 +134,7 @@ compile_ld64() {
# but not on tiger.
[[ ${CHOST} == *-apple-darwin8 ]] && \
append-flags -isystem "${S}"/${CCTOOLS}/include/
- emake || die "emake failed for ld64"
+ emake
use test && emake build_test
}
@@ -146,13 +146,12 @@ compile_cctools() {
EFITOOLS= \
COMMON_SUBDIRS='libstuff ar misc otool' \
SUBDIRS_32= \
- RC_CFLAGS="${CFLAGS}" OFLAG="${CFLAGS}" \
- || die "emake failed for the cctools"
+ RC_CFLAGS="${CFLAGS}" OFLAG="${CFLAGS}"
+
cd "${S}"/${CCTOOLS}/as
emake \
BUILD_OBSOLETE_ARCH= \
- RC_CFLAGS="-DASLIBEXECDIR=\"\\\"${EPREFIX}${LIBPATH}/\\\"\" ${CFLAGS}" \
- || die "emake failed for as"
+ RC_CFLAGS="-DASLIBEXECDIR=\"\\\"${EPREFIX}${LIBPATH}/\\\"\" ${CFLAGS}"
}
src_compile() {