summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2016-09-10 16:38:28 +0200
committerFabian Groffen <grobian@gentoo.org>2016-09-10 16:40:27 +0200
commit49925c0dd0a4ab8599c955244cee2d0764cc08e9 (patch)
tree212726b265d87b1ef67ecc7236a091efdbf6910c /sys-devel/binutils-apple/binutils-apple-7.3.1.ebuild
parentsys-devel/gcc-apple: bump to EAPI=5 and remove all conditional code from glob... (diff)
downloadgentoo-49925c0dd0a4ab8599c955244cee2d0764cc08e9.tar.gz
gentoo-49925c0dd0a4ab8599c955244cee2d0764cc08e9.tar.bz2
gentoo-49925c0dd0a4ab8599c955244cee2d0764cc08e9.zip
sys-devel/binutils-apple: bump to EAPI=5 and remove all conditional code from global scope, bug #593392
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-devel/binutils-apple/binutils-apple-7.3.1.ebuild')
-rw-r--r--sys-devel/binutils-apple/binutils-apple-7.3.1.ebuild35
1 files changed, 18 insertions, 17 deletions
diff --git a/sys-devel/binutils-apple/binutils-apple-7.3.1.ebuild b/sys-devel/binutils-apple/binutils-apple-7.3.1.ebuild
index 70febd45e7fa..55be11280a7b 100644
--- a/sys-devel/binutils-apple/binutils-apple-7.3.1.ebuild
+++ b/sys-devel/binutils-apple/binutils-apple-7.3.1.ebuild
@@ -41,27 +41,12 @@ RDEPEND="sys-devel/binutils-config
DEPEND="${RDEPEND}
test? ( >=dev-lang/perl-5.8.8 )"
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY} == cross-* ]] ; then
- export CTARGET=${CATEGORY#cross-}
- fi
-fi
-is_cross() { [[ ${CHOST} != ${CTARGET} ]] ; }
-
SLOT="7"
-LIBPATH=/usr/$(get_libdir)/binutils/${CTARGET}/${PV}
-INCPATH=${LIBPATH}/include
-DATAPATH=/usr/share/binutils-data/${CTARGET}/${PV}
-if is_cross ; then
- BINPATH=/usr/${CHOST}/${CTARGET}/binutils-bin/${PV}
-else
- BINPATH=/usr/${CTARGET}/binutils-bin/${PV}
-fi
-
S=${WORKDIR}
+is_cross() { [[ ${CHOST} != ${CTARGET} ]] ; }
+
src_prepare() {
if use multitarget ; then
ewarn "You have enabled support for non-standard target architectures"
@@ -199,6 +184,22 @@ src_configure() {
ENABLE_LTO=0
use lto && ENABLE_LTO=1
+ export CTARGET=${CTARGET:-${CHOST}}
+ if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
+ fi
+ fi
+
+ LIBPATH=/usr/$(get_libdir)/binutils/${CTARGET}/${PV}
+ INCPATH=${LIBPATH}/include
+ DATAPATH=/usr/share/binutils-data/${CTARGET}/${PV}
+ if is_cross ; then
+ BINPATH=/usr/${CHOST}/${CTARGET}/binutils-bin/${PV}
+ else
+ BINPATH=/usr/${CTARGET}/binutils-bin/${PV}
+ fi
+
# CPPFLAGS only affects ld64, cctools don't use 'em (which currently is
# what we want)
append-cppflags -DNDEBUG