summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-09-26 00:15:36 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2017-09-26 00:18:01 +0100
commitde2ce41d168f7f86bf9e997c3f29a1bd85efec37 (patch)
treebabc7243ab967b20780abe12423197d4b28b83db /sys-devel/binutils-hppa64/binutils-hppa64-2.29.1.ebuild
parentsys-libs/binutils-libs: bump up to 2.29.1 (diff)
downloadgentoo-de2ce41d168f7f86bf9e997c3f29a1bd85efec37.tar.gz
gentoo-de2ce41d168f7f86bf9e997c3f29a1bd85efec37.tar.bz2
gentoo-de2ce41d168f7f86bf9e997c3f29a1bd85efec37.zip
sys-devel/binutils-hppa64: bump up to 2.29.1
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'sys-devel/binutils-hppa64/binutils-hppa64-2.29.1.ebuild')
-rw-r--r--sys-devel/binutils-hppa64/binutils-hppa64-2.29.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-devel/binutils-hppa64/binutils-hppa64-2.29.1.ebuild b/sys-devel/binutils-hppa64/binutils-hppa64-2.29.1.ebuild
new file mode 100644
index 000000000000..46b29bfae895
--- /dev/null
+++ b/sys-devel/binutils-hppa64/binutils-hppa64-2.29.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+export CTARGET=hppa64-${CHOST#*-}
+
+PATCHVER="1.0"
+PATCH_BINUTILS_VER="2.29"
+ELF2FLT_VER=""
+inherit toolchain-binutils
+
+DESCRIPTION="binutils package for building 64bit kernels on HPPA"
+
+KEYWORDS="-* ~hppa"
+
+# 66_all_binutils-2.22-warn-textrel.patch fails to apply with
+# patch-2.5.9, so require a version that for sure works
+DEPEND+=" >=sys-devel/patch-2.6.1"
+
+src_install() {
+ toolchain-binutils_src_install
+
+ # tweak the default fake list a little bit
+ cd "${D}"/etc/env.d/binutils
+ sed -i '/FAKE_TARGETS=/s:"$: hppa64-linux":' ${CTARGET}-${BVER} || die
+}