summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-06-02 19:41:19 -0400
committerAaron Bauman <bman@gentoo.org>2018-06-02 22:58:17 -0400
commit6cc935c2f528a0a95d158e6a9c9ccf603a23111f (patch)
tree878e213b4767ec3f4d240bbddf191301c3c418ce /sys-devel/bison/bison-1.875d.ebuild
parentsys-devel/remake: drop old EAPI (diff)
downloadgentoo-6cc935c2f528a0a95d158e6a9c9ccf603a23111f.tar.gz
gentoo-6cc935c2f528a0a95d158e6a9c9ccf603a23111f.tar.bz2
gentoo-6cc935c2f528a0a95d158e6a9c9ccf603a23111f.zip
sys-devel/bison: drop old EAPI
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sys-devel/bison/bison-1.875d.ebuild')
-rw-r--r--sys-devel/bison/bison-1.875d.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/sys-devel/bison/bison-1.875d.ebuild b/sys-devel/bison/bison-1.875d.ebuild
deleted file mode 100644
index c59adc82dd9e..000000000000
--- a/sys-devel/bison/bison-1.875d.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit toolchain-funcs flag-o-matic eutils
-
-DESCRIPTION="A yacc-compatible parser generator"
-HOMEPAGE="https://www.gnu.org/software/bison/bison.html"
-SRC_URI="ftp://alpha.gnu.org/pub/gnu/bison/${P}.tar.bz2
- https://dev.gentoo.org/~mgorny/dist/${P}-patchset.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="nls static"
-
-DEPEND="sys-devel/m4
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${WORKDIR}"/${P}-patchset/${PN}-1.32-extfix.patch
-}
-
-src_compile() {
- # Bug 39842 says that bison segfaults when built on amd64 with
- # optimizations. This will probably be fixed in a future gcc
- # version, but for the moment just disable optimizations for that
- # arch (04 Feb 2004 agriffis)
- [ "$ARCH" == "amd64" ] && append-flags -O0
-
- # Bug 29017 says that bison has compile-time issues with
- # -march=k6* prior to 3.4CVS. Use -march=i586 instead
- # (04 Feb 2004 agriffis)
- #
- if (( $(gcc-major-version) == 3 && $(gcc-minor-version) < 4 )) ; then
- replace-cpu-flags k6 k6-1 k6-2 i586
- fi
-
- econf $(use_enable nls) || die
- use static && append-ldflags -static
- emake || die
-}
-
-src_install() {
- make DESTDIR="${D}" \
- datadir=/usr/share \
- mandir=/usr/share/man \
- infodir=/usr/share/info \
- install || die
-
- # This one is installed by dev-util/yacc
- mv "${D}"/usr/bin/yacc "${D}"/usr/bin/yacc.bison || die
-
- # We do not need this.
- rm -f "${D}"/usr/lib/liby.a
-
- dodoc AUTHORS NEWS ChangeLog README REFERENCES OChangeLog doc/FAQ
-}
-
-pkg_postinst() {
- if [[ ! -e ${ROOT}/usr/bin/yacc ]] ; then
- ln -s yacc.bison "${ROOT}"/usr/bin/yacc
- fi
-}