summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-05-28 10:44:37 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-05-28 10:56:54 +0200
commit425c689bb3656063537f053125894f2c56a1e015 (patch)
treeddf4083e4b59f40d5917993b47a2d9f42d1f9901 /sys-devel/bison/bison-3.0.5.ebuild
parentprofiles: Mask package net-misc/urlview for removal (diff)
downloadgentoo-425c689bb3656063537f053125894f2c56a1e015.tar.gz
gentoo-425c689bb3656063537f053125894f2c56a1e015.tar.bz2
gentoo-425c689bb3656063537f053125894f2c56a1e015.zip
sys-devel/bison: Bump to version 3.0.5
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sys-devel/bison/bison-3.0.5.ebuild')
-rw-r--r--sys-devel/bison/bison-3.0.5.ebuild83
1 files changed, 83 insertions, 0 deletions
diff --git a/sys-devel/bison/bison-3.0.5.ebuild b/sys-devel/bison/bison-3.0.5.ebuild
new file mode 100644
index 000000000000..8c4763c45fdd
--- /dev/null
+++ b/sys-devel/bison/bison-3.0.5.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="A general-purpose (yacc-compatible) parser generator"
+HOMEPAGE="https://www.gnu.org/software/bison/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
+ https://dev.gentoo.org/~polynomial-c/${P}-patches-01.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples nls static test"
+
+RDEPEND=">=sys-devel/m4-1.4.16"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ examples? ( dev-lang/perl )
+ nls? ( sys-devel/gettext )
+ test? ( dev-lang/perl )"
+
+DOCS=( AUTHORS ChangeLog-2012 NEWS README THANKS TODO ) # ChangeLog-1998 PACKAGING README-alpha README-release
+
+PATCHES=(
+ "${WORKDIR}"/patches/${P}-optional-perl.patch #538300
+ "${WORKDIR}"/patches/${P}-avoid_autoreconf.patch
+)
+
+src_prepare() {
+ default
+ # The makefiles make the man page depend on the configure script
+ # which we patched above. Touch it to prevent regeneration.
+ touch doc/bison.1 #548778 #538300#9
+ # Avoid regenerating the info page when the timezone is diff. #574492
+ sed -i '2iexport TZ=UTC' build-aux/mdate-sh || die
+ # ugly workaround to avoid maintainer mode (see #647410 and #648012)
+ printf '#!/bin/sh\nexit 0\n' > build-aux/missing || die
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ # We don't need perl unless we run tests.
+ use test || export ac_cv_path_PERL=true
+ local myeconfargs=(
+ --docdir='$(datarootdir)'/doc/${PF}
+ $(use_enable examples)
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ # This one is installed by dev-util/yacc
+ mv "${ED%/}"/usr/bin/yacc{,.bison} || die
+ mv "${ED%/}"/usr/share/man/man1/yacc{,.bison}.1 || die
+
+ # We do not need liby.a
+ rm -r "${ED%/}"/usr/lib* || die
+
+ # Move to documentation directory and leave compressing for EAPI>=4
+ mv "${ED%/}"/usr/share/${PN}/README "${ED%/}"/usr/share/doc/${PF}/README.data
+}
+
+pkg_postinst() {
+ local f="${EROOT}/usr/bin/yacc"
+ if [[ ! -e ${f} ]] ; then
+ ln -s yacc.bison "${f}"
+ fi
+}
+
+pkg_postrm() {
+ # clean up the dead symlink when we get unmerged #377469
+ local f="${EROOT}/usr/bin/yacc"
+ if [[ -L ${f} && ! -e ${f} ]] ; then
+ rm -f "${f}"
+ fi
+}