summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2016-06-22 14:46:17 -0600
committerChristoph Junghans <ottxor@gentoo.org>2016-06-22 14:46:32 -0600
commitdc43ac2896702bebcb536ed1d785b0657b250c9d (patch)
tree82d54881f4b6821314a11d20ec8fd71cf5531367 /sys-devel/byfl
parentmedia-gfx/gimp: CVE-2016-4994 (bug #586666) (diff)
downloadgentoo-dc43ac2896702bebcb536ed1d785b0657b250c9d.tar.gz
gentoo-dc43ac2896702bebcb536ed1d785b0657b250c9d.tar.bz2
gentoo-dc43ac2896702bebcb536ed1d785b0657b250c9d.zip
sys-devel/byfl: fix deps (bug #586736)
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-devel/byfl')
-rw-r--r--sys-devel/byfl/Manifest1
-rw-r--r--sys-devel/byfl/byfl-1.4-r1.ebuild (renamed from sys-devel/byfl/byfl-1.4.ebuild)22
-rw-r--r--sys-devel/byfl/byfl-1.5.ebuild48
-rw-r--r--sys-devel/byfl/byfl-9999.ebuild23
4 files changed, 75 insertions, 19 deletions
diff --git a/sys-devel/byfl/Manifest b/sys-devel/byfl/Manifest
index d42b968686e8..6ceaf2fc9917 100644
--- a/sys-devel/byfl/Manifest
+++ b/sys-devel/byfl/Manifest
@@ -1 +1,2 @@
DIST byfl-1.4-llvm-3.7.0.tar.gz 544669 SHA256 b523a28fb05cb8f0f7641a326c08074306a38a3dcd61c95e69049a98a7ae0cce SHA512 6fb204cf704d3f20e3d408f4cbe8071e1198b75615757c1877a8886753ff9087d9ff04a8279540b26805ed9a0e7cea6543a08de491990c9c912b40f1984bdcb4 WHIRLPOOL 63504c5bda6bd4b9f2cb84ca4f6c0aae2f6b24186d7487c670df4e6d217367e2d794ecda9c8811f6c7db70dc848dfa7ebc9cf09a331bb6b8929cd1af6f143ac2
+DIST byfl-1.5-llvm-3.8.0.tar.gz 544478 SHA256 5d0a8e796b2e1e34448d86570048d267bc3fcc7c1acb6019138631fe3a9cc6e8 SHA512 f1718a6bc43fed74e4d9907c8ff0a407c800176f2bfd2f68bfac2e6626cfe1d0be6835c91375d6ffe6a5a428da7ce80c3eb42a25c36ff69aab65600308dbdd7d WHIRLPOOL 09a095a8db34464d5c666178015aa67e4143ae999e41d78710095b0c9d9186583301a204e74d02c2da78bc68a54503a7784ac2baf0844c90de8a69c6a86ca795
diff --git a/sys-devel/byfl/byfl-1.4.ebuild b/sys-devel/byfl/byfl-1.4-r1.ebuild
index 8d88af4085ad..55f157810b31 100644
--- a/sys-devel/byfl/byfl-1.4.ebuild
+++ b/sys-devel/byfl/byfl-1.4-r1.ebuild
@@ -1,18 +1,16 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit autotools-utils flag-o-matic
+inherit flag-o-matic
if [ "${PV}" = "9999" ]; then
- LLVM_VERSION="3.7.0"
- # Switch to ^b when we switch to EAPI=6.
- EGIT_REPO_URI="git://github.com/losalamos/B${PN:1}.git https://github.com/losalamos/${PN}.git"
- inherit git-2
+ LLVM_VERSION="3.8.0"
+ EGIT_REPO_URI="git://github.com/losalamos/${PN^b}.git https://github.com/losalamos/${PN}.git"
+ inherit autotools git-r3
KEYWORDS=""
- AUTOTOOLS_AUTORECONF=1
else
LLVM_VERSION="3.7.0"
MY_P="${P}-llvm-${LLVM_VERSION}"
@@ -31,6 +29,7 @@ IUSE="hdf5 static-libs sqlite"
RDEPEND="
>=sys-devel/clang-${LLVM_VERSION}
>=sys-devel/llvm-${LLVM_VERSION}
+ <sys-devel/llvm-3.8
sys-devel/binutils:*
dev-lang/perl:=
dev-perl/Switch
@@ -38,8 +37,13 @@ RDEPEND="
sqlite? ( dev-db/sqlite:3 )"
DEPEND="${RDEPEND}"
+src_prepare() {
+ default
+ [[ ${PV} = 9999 ]] && eautoreconf
+}
+
src_configure() {
append-cxxflags -std=c++11
use sqlite || export ac_cv_lib_sqlite3_sqlite3_errstr=no
- autotools-utils_src_configure H5CXX=$(usex hdf5 h5c++ no)
+ econf H5CXX=$(usex hdf5 h5c++ no)
}
diff --git a/sys-devel/byfl/byfl-1.5.ebuild b/sys-devel/byfl/byfl-1.5.ebuild
new file mode 100644
index 000000000000..c0ffb16d75a3
--- /dev/null
+++ b/sys-devel/byfl/byfl-1.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit flag-o-matic
+
+if [ "${PV}" = "9999" ]; then
+ LLVM_VERSION="3.8.0"
+ EGIT_REPO_URI="git://github.com/losalamos/${PN^b}.git https://github.com/losalamos/${PN}.git"
+ inherit autotools git-r3
+ KEYWORDS=""
+else
+ LLVM_VERSION="3.8.0"
+ MY_P="${P}-llvm-${LLVM_VERSION}"
+ SRC_URI="https://github.com/losalamos/Byfl/releases/download/v${MY_P#${PN}-}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~amd64-linux"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="Compiler-based Application Analysis"
+HOMEPAGE="https://github.com/losalamos/Byfl"
+
+SLOT="0"
+LICENSE="BSD"
+IUSE="hdf5 static-libs sqlite"
+
+RDEPEND="
+ >=sys-devel/clang-${LLVM_VERSION}
+ >=sys-devel/llvm-${LLVM_VERSION}
+ sys-devel/binutils:*
+ dev-lang/perl:=
+ dev-perl/Switch
+ hdf5? ( sci-libs/hdf5[cxx] )
+ sqlite? ( dev-db/sqlite:3 )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} = 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+ use sqlite || export ac_cv_lib_sqlite3_sqlite3_errstr=no
+ econf H5CXX=$(usex hdf5 h5c++ no)
+}
diff --git a/sys-devel/byfl/byfl-9999.ebuild b/sys-devel/byfl/byfl-9999.ebuild
index 8d88af4085ad..c0ffb16d75a3 100644
--- a/sys-devel/byfl/byfl-9999.ebuild
+++ b/sys-devel/byfl/byfl-9999.ebuild
@@ -1,20 +1,18 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit autotools-utils flag-o-matic
+inherit flag-o-matic
if [ "${PV}" = "9999" ]; then
- LLVM_VERSION="3.7.0"
- # Switch to ^b when we switch to EAPI=6.
- EGIT_REPO_URI="git://github.com/losalamos/B${PN:1}.git https://github.com/losalamos/${PN}.git"
- inherit git-2
+ LLVM_VERSION="3.8.0"
+ EGIT_REPO_URI="git://github.com/losalamos/${PN^b}.git https://github.com/losalamos/${PN}.git"
+ inherit autotools git-r3
KEYWORDS=""
- AUTOTOOLS_AUTORECONF=1
else
- LLVM_VERSION="3.7.0"
+ LLVM_VERSION="3.8.0"
MY_P="${P}-llvm-${LLVM_VERSION}"
SRC_URI="https://github.com/losalamos/Byfl/releases/download/v${MY_P#${PN}-}/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~amd64-linux"
@@ -38,8 +36,13 @@ RDEPEND="
sqlite? ( dev-db/sqlite:3 )"
DEPEND="${RDEPEND}"
+src_prepare() {
+ default
+ [[ ${PV} = 9999 ]] && eautoreconf
+}
+
src_configure() {
append-cxxflags -std=c++11
use sqlite || export ac_cv_lib_sqlite3_sqlite3_errstr=no
- autotools-utils_src_configure H5CXX=$(usex hdf5 h5c++ no)
+ econf H5CXX=$(usex hdf5 h5c++ no)
}