summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-09-20 11:33:24 +0200
committerMichał Górny <mgorny@gentoo.org>2019-09-21 00:11:53 +0200
commiteb39c54512409db092f8c914321bf39c25bd6a34 (patch)
tree27d9c265ab677d8c2ffbfe674e68824c9cf6366d /sys-devel/clang-common/clang-common-9.0.0.ebuild
parentsys-devel/lld: Bump to 9.0.0 (diff)
downloadgentoo-eb39c54512409db092f8c914321bf39c25bd6a34.tar.gz
gentoo-eb39c54512409db092f8c914321bf39c25bd6a34.tar.bz2
gentoo-eb39c54512409db092f8c914321bf39c25bd6a34.zip
sys-devel/clang-common: Bump to 9.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang-common/clang-common-9.0.0.ebuild')
-rw-r--r--sys-devel/clang-common/clang-common-9.0.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-devel/clang-common/clang-common-9.0.0.ebuild b/sys-devel/clang-common/clang-common-9.0.0.ebuild
new file mode 100644
index 000000000000..a32af474a9c8
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-9.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1
+
+MY_P=cfe-${PV/_/}.src
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+SRC_URI="https://releases.llvm.org/${PV}/${MY_P}.tar.xz"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+PDEPEND="sys-devel/clang:*"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ einfo "Unpacking parts of ${MY_P}.tar.xz ..."
+ tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/utils/bash-autocomplete.sh" || die
+}
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ newbashcomp utils/bash-autocomplete.sh clang
+}