summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-04-04 19:27:00 +0200
committerMichał Górny <mgorny@gentoo.org>2018-04-04 19:37:21 +0200
commit86bef6af43fb45e5247131884622a3f25ee6b64a (patch)
treefd8c46b843605e30a0f59ba22e93babbdc0ca3be /sys-devel/clang-common
parentapp-accessibility/speech-tools: amd64 stable (diff)
downloadgentoo-86bef6af43fb45e5247131884622a3f25ee6b64a.tar.gz
gentoo-86bef6af43fb45e5247131884622a3f25ee6b64a.tar.bz2
gentoo-86bef6af43fb45e5247131884622a3f25ee6b64a.zip
sys-devel/clang-common: New package for common clang files
New package for clang files shared between multiple slots. Currently includes bash completion. Closes: https://bugs.gentoo.org/652414
Diffstat (limited to 'sys-devel/clang-common')
-rw-r--r--sys-devel/clang-common/Manifest1
-rw-r--r--sys-devel/clang-common/clang-common-6.0.0.ebuild33
-rw-r--r--sys-devel/clang-common/clang-common-6.0.9999.ebuild33
-rw-r--r--sys-devel/clang-common/clang-common-9999.ebuild32
-rw-r--r--sys-devel/clang-common/metadata.xml7
5 files changed, 106 insertions, 0 deletions
diff --git a/sys-devel/clang-common/Manifest b/sys-devel/clang-common/Manifest
new file mode 100644
index 000000000000..521d758b33f3
--- /dev/null
+++ b/sys-devel/clang-common/Manifest
@@ -0,0 +1 @@
+DIST cfe-6.0.0.src.tar.xz 11959224 BLAKE2B 257edbaedf72bd941b67b4aa2f152a96a37bbea72d21d22d4445152685efe40d75b9a7a39955545643e841ad6693ef12e52b207b9119098774f39e858b64bc09 SHA512 e886dd27448503bbfc7fd4f68eb089c19b2f2be4f0e5b26d3df253833f60b91d70b472a6b530063386e2252075b110ce9f5942800feddf6c34b94a75cf7bd5c6
diff --git a/sys-devel/clang-common/clang-common-6.0.0.ebuild b/sys-devel/clang-common/clang-common-6.0.0.ebuild
new file mode 100644
index 000000000000..05dbb18f31a4
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-6.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+MY_P=cfe-${PV/_/}.src
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+SRC_URI="https://releases.llvm.org/${PV/_//}/${MY_P}.tar.xz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+PDEPEND="sys-devel/clang:*"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ einfo "Unpacking parts of ${MY_P}.tar.xz ..."
+ tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/utils/bash-autocomplete.sh" || die
+}
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ newbashcomp utils/bash-autocomplete.sh clang
+}
diff --git a/sys-devel/clang-common/clang-common-6.0.9999.ebuild b/sys-devel/clang-common/clang-common-6.0.9999.ebuild
new file mode 100644
index 000000000000..23946cca1614
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-6.0.9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1 git-r3
+
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://git.llvm.org/git/clang.git
+ https://github.com/llvm-mirror/clang.git"
+EGIT_BRANCH="release_60"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+PDEPEND="sys-devel/clang:*"
+
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' utils/bash-autocomplete.sh
+}
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ newbashcomp utils/bash-autocomplete.sh clang
+}
diff --git a/sys-devel/clang-common/clang-common-9999.ebuild b/sys-devel/clang-common/clang-common-9999.ebuild
new file mode 100644
index 000000000000..145e395e1fe0
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1 git-r3
+
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://git.llvm.org/git/clang.git
+ https://github.com/llvm-mirror/clang.git"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+PDEPEND="sys-devel/clang:*"
+
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' utils/bash-autocomplete.sh
+}
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ newbashcomp utils/bash-autocomplete.sh clang
+}
diff --git a/sys-devel/clang-common/metadata.xml b/sys-devel/clang-common/metadata.xml
new file mode 100644
index 000000000000..89c4bdb96049
--- /dev/null
+++ b/sys-devel/clang-common/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>llvm@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>