summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-01 18:37:42 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-03 12:46:13 +0100
commitbc3e82c78d2d861be2dc2bfd12de34b0661318e0 (patch)
treeb8b76c2d02845a43f3a6d1bec909566fe5392515 /sys-devel/clang-common
parentdev-python/lit: Port 9+ to llvm.org.eclass (diff)
downloadgentoo-bc3e82c78d2d861be2dc2bfd12de34b0661318e0.tar.gz
gentoo-bc3e82c78d2d861be2dc2bfd12de34b0661318e0.tar.bz2
gentoo-bc3e82c78d2d861be2dc2bfd12de34b0661318e0.zip
sys-devel/clang-common: Port 9+ to llvm.org.eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang-common')
-rw-r--r--sys-devel/clang-common/clang-common-10.0.0.9999.ebuild19
-rw-r--r--sys-devel/clang-common/clang-common-9.0.0.ebuild19
-rw-r--r--sys-devel/clang-common/clang-common-9.0.1.9999.ebuild20
3 files changed, 15 insertions, 43 deletions
diff --git a/sys-devel/clang-common/clang-common-10.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-10.0.0.9999.ebuild
index 6b707e3d41ff..d1bfe71d2f80 100644
--- a/sys-devel/clang-common/clang-common-10.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-10.0.0.9999.ebuild
@@ -3,13 +3,13 @@
EAPI=7
-inherit bash-completion-r1 git-r3
+inherit bash-completion-r1 llvm.org
DESCRIPTION="Common files shared between multiple slots of clang"
HOMEPAGE="https://llvm.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
-S=${WORKDIR}/${P}/clang
+LLVM_COMPONENTS=( clang/utils/bash-autocomplete.sh )
+llvm.org_set_globals
+S=${WORKDIR}/clang/utils
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -18,15 +18,6 @@ IUSE=""
PDEPEND="sys-devel/clang:*"
-src_unpack() {
- git-r3_fetch
- git-r3_checkout '' '' '' clang/utils/bash-autocomplete.sh
-}
-
-src_configure() { :; }
-src_compile() { :; }
-src_test() { :; }
-
src_install() {
- newbashcomp utils/bash-autocomplete.sh clang
+ newbashcomp bash-autocomplete.sh clang
}
diff --git a/sys-devel/clang-common/clang-common-9.0.0.ebuild b/sys-devel/clang-common/clang-common-9.0.0.ebuild
index 609bdcde4cc0..3fc7a056a923 100644
--- a/sys-devel/clang-common/clang-common-9.0.0.ebuild
+++ b/sys-devel/clang-common/clang-common-9.0.0.ebuild
@@ -3,13 +3,13 @@
EAPI=7
-inherit bash-completion-r1
+inherit bash-completion-r1 llvm.org
-MY_P=cfe-${PV/_/}.src
DESCRIPTION="Common files shared between multiple slots of clang"
HOMEPAGE="https://llvm.org/"
-SRC_URI="https://releases.llvm.org/${PV}/${MY_P}.tar.xz"
-S=${WORKDIR}/${MY_P}
+LLVM_COMPONENTS=( clang/utils/bash-autocomplete.sh )
+llvm.org_set_globals
+S=${WORKDIR}/clang/utils
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -18,15 +18,6 @@ IUSE=""
PDEPEND="sys-devel/clang:*"
-src_unpack() {
- einfo "Unpacking parts of ${MY_P}.tar.xz ..."
- tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/utils/bash-autocomplete.sh" || die
-}
-
-src_configure() { :; }
-src_compile() { :; }
-src_test() { :; }
-
src_install() {
- newbashcomp utils/bash-autocomplete.sh clang
+ newbashcomp bash-autocomplete.sh clang
}
diff --git a/sys-devel/clang-common/clang-common-9.0.1.9999.ebuild b/sys-devel/clang-common/clang-common-9.0.1.9999.ebuild
index eecb0ff749dc..d1bfe71d2f80 100644
--- a/sys-devel/clang-common/clang-common-9.0.1.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-9.0.1.9999.ebuild
@@ -3,14 +3,13 @@
EAPI=7
-inherit bash-completion-r1 git-r3
+inherit bash-completion-r1 llvm.org
DESCRIPTION="Common files shared between multiple slots of clang"
HOMEPAGE="https://llvm.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
-EGIT_BRANCH="release/9.x"
-S=${WORKDIR}/${P}/clang
+LLVM_COMPONENTS=( clang/utils/bash-autocomplete.sh )
+llvm.org_set_globals
+S=${WORKDIR}/clang/utils
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -19,15 +18,6 @@ IUSE=""
PDEPEND="sys-devel/clang:*"
-src_unpack() {
- git-r3_fetch
- git-r3_checkout '' '' '' clang/utils/bash-autocomplete.sh
-}
-
-src_configure() { :; }
-src_compile() { :; }
-src_test() { :; }
-
src_install() {
- newbashcomp utils/bash-autocomplete.sh clang
+ newbashcomp bash-autocomplete.sh clang
}