summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-01 09:34:40 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-01 14:15:46 +0100
commitd067f3e9cf078b9ec16b56f751b54c71d350b971 (patch)
tree94381e2cd010d202e34eb89a7bc88487978b8ed4 /sys-devel/clang-common
parentdev-util/lldb: Switch live to monorepo (diff)
downloadgentoo-d067f3e9cf078b9ec16b56f751b54c71d350b971.tar.gz
gentoo-d067f3e9cf078b9ec16b56f751b54c71d350b971.tar.bz2
gentoo-d067f3e9cf078b9ec16b56f751b54c71d350b971.zip
sys-devel/clang-common: Switch live to monorepo
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang-common')
-rw-r--r--sys-devel/clang-common/clang-common-10.0.0.9999.ebuild6
-rw-r--r--sys-devel/clang-common/clang-common-9.0.1.9999.ebuild8
2 files changed, 7 insertions, 7 deletions
diff --git a/sys-devel/clang-common/clang-common-10.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-10.0.0.9999.ebuild
index d1ce28354dec..6b707e3d41ff 100644
--- a/sys-devel/clang-common/clang-common-10.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-10.0.0.9999.ebuild
@@ -8,8 +8,8 @@ inherit bash-completion-r1 git-r3
DESCRIPTION="Common files shared between multiple slots of clang"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/clang.git
- https://github.com/llvm-mirror/clang.git"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+S=${WORKDIR}/${P}/clang
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -20,7 +20,7 @@ PDEPEND="sys-devel/clang:*"
src_unpack() {
git-r3_fetch
- git-r3_checkout '' '' '' utils/bash-autocomplete.sh
+ git-r3_checkout '' '' '' clang/utils/bash-autocomplete.sh
}
src_configure() { :; }
diff --git a/sys-devel/clang-common/clang-common-9.0.1.9999.ebuild b/sys-devel/clang-common/clang-common-9.0.1.9999.ebuild
index cc703baf0c50..eecb0ff749dc 100644
--- a/sys-devel/clang-common/clang-common-9.0.1.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-9.0.1.9999.ebuild
@@ -8,9 +8,9 @@ inherit bash-completion-r1 git-r3
DESCRIPTION="Common files shared between multiple slots of clang"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/clang.git
- https://github.com/llvm-mirror/clang.git"
-EGIT_BRANCH="release_90"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+EGIT_BRANCH="release/9.x"
+S=${WORKDIR}/${P}/clang
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -21,7 +21,7 @@ PDEPEND="sys-devel/clang:*"
src_unpack() {
git-r3_fetch
- git-r3_checkout '' '' '' utils/bash-autocomplete.sh
+ git-r3_checkout '' '' '' clang/utils/bash-autocomplete.sh
}
src_configure() { :; }