summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-23 21:31:35 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-23 21:34:57 +0100
commit044fc400e5e211469b962066c6725156ba301014 (patch)
tree0b94b17b9d8f297c7c5a1ea1aa0c798b03854bc9 /sys-devel/clang-runtime
parentsys-libs/libomp: Bump to 10.0.0rc6 (diff)
downloadgentoo-044fc400e5e211469b962066c6725156ba301014.tar.gz
gentoo-044fc400e5e211469b962066c6725156ba301014.tar.bz2
gentoo-044fc400e5e211469b962066c6725156ba301014.zip
sys-devel/clang-runtime: Bump to 10.0.0rc6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-10.0.0_rc6.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-10.0.0_rc6.ebuild b/sys-devel/clang-runtime/clang-runtime-10.0.0_rc6.ebuild
new file mode 100644
index 000000000000..65e66879ab98
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-10.0.0_rc6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS=""
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"