summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-03-20 15:14:59 +0100
committerMichał Górny <mgorny@gentoo.org>2019-03-20 16:01:50 +0100
commit1ba097098a902ca7fea0c3951cd2f5fe8808e560 (patch)
tree5703f4c22ae1cc79abc4dac4ce4388728dacc715 /sys-devel/clang-runtime
parentsys-libs/libomp: Bump to 8.0.0 final (diff)
downloadgentoo-1ba097098a902ca7fea0c3951cd2f5fe8808e560.tar.gz
gentoo-1ba097098a902ca7fea0c3951cd2f5fe8808e560.tar.bz2
gentoo-1ba097098a902ca7fea0c3951cd2f5fe8808e560.zip
sys-devel/clang-runtime: Bump to 8.0.0 final
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-8.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-8.0.0.ebuild b/sys-devel/clang-runtime/clang-runtime-8.0.0.ebuild
new file mode 100644
index 000000000000..97c0d55cf2a5
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-8.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="${PV%_*}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="+compiler-rt crt libcxx openmp +sanitize"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ crt? (
+ || (
+ sys-libs/netbsd-csu[${MULTILIB_USEDEP}]
+ sys-freebsd/freebsd-lib[${MULTILIB_USEDEP}]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
+
+REQUIRED_USE="sanitize? ( compiler-rt )"