summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-21 08:29:30 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-21 09:30:01 +0100
commit631ae5f16994eff71947bb6f8a5e6b39dfcd868f (patch)
tree7cf1359a0fc51c45e9e2d449c1dcc307ddcae72f /sys-devel/clang-runtime
parentsys-libs/libomp: Bump to 9.0.1 final (diff)
downloadgentoo-631ae5f16994eff71947bb6f8a5e6b39dfcd868f.tar.gz
gentoo-631ae5f16994eff71947bb6f8a5e6b39dfcd868f.tar.bz2
gentoo-631ae5f16994eff71947bb6f8a5e6b39dfcd868f.zip
sys-devel/clang-runtime: Bump to 9.0.1 final
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-9.0.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-9.0.1.ebuild b/sys-devel/clang-runtime/clang-runtime-9.0.1.ebuild
new file mode 100644
index 000000000000..6250baa76c9e
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-9.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"