summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-01-16 14:50:20 +0100
committerMichał Górny <mgorny@gentoo.org>2019-01-16 15:52:37 +0100
commitb178b59bff9cdc8566af6e441a74e2cd651f3cae (patch)
tree9a0bdd9a2f4bf50cc6843e34e4e2ead2ee746dc5 /sys-devel/clang-runtime
parentsys-libs/libomp: Add a live ebuild for 8.* branch (diff)
downloadgentoo-b178b59bff9cdc8566af6e441a74e2cd651f3cae.tar.gz
gentoo-b178b59bff9cdc8566af6e441a74e2cd651f3cae.tar.bz2
gentoo-b178b59bff9cdc8566af6e441a74e2cd651f3cae.zip
sys-devel/clang-runtime: Add a live ebuild for 8.* branch
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-8.0.9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-8.0.9999.ebuild b/sys-devel/clang-runtime/clang-runtime-8.0.9999.ebuild
new file mode 100644
index 000000000000..d9cfd5fe10db
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-8.0.9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+# Note: keep it matching clang-9999 version
+SLOT="8.0.0"
+KEYWORDS=""
+IUSE="+compiler-rt crt libcxx openmp +sanitize"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ crt? (
+ || (
+ sys-libs/netbsd-csu[${MULTILIB_USEDEP}]
+ sys-freebsd/freebsd-lib[${MULTILIB_USEDEP}]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
+
+REQUIRED_USE="sanitize? ( compiler-rt )"