summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-03 22:54:53 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-03 23:21:43 +0100
commitc9fa69866b2f01db87804fb027f45db445154d27 (patch)
tree620da8ccbed563cba6231b9f89ad1285789ff385 /sys-devel/clang-runtime
parentsys-libs/libomp: Add a live ebuild for 6.0 branch (diff)
downloadgentoo-c9fa69866b2f01db87804fb027f45db445154d27.tar.gz
gentoo-c9fa69866b2f01db87804fb027f45db445154d27.tar.bz2
gentoo-c9fa69866b2f01db87804fb027f45db445154d27.zip
sys-devel/clang-runtime: Add a live ebuild for 6.0 branch
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-6.0.9999.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-6.0.9999.ebuild b/sys-devel/clang-runtime/clang-runtime-6.0.9999.ebuild
new file mode 100644
index 000000000000..333b352d98bd
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-6.0.9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+# Note: keep it matching clang-9999 version
+SLOT="6.0.0"
+KEYWORDS=""
+IUSE="+compiler-rt libcxx openmp +sanitize"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
+
+REQUIRED_USE="sanitize? ( compiler-rt )"