summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-21 17:46:05 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-21 21:31:26 +0200
commitd5599a6353921fd0cd388853f15b521a47bae51e (patch)
tree464fffa2d9b0a83e21afb673d93136fed76c1ec9 /sys-devel/clang-runtime
parentsys-libs/libomp: Bump to 10.0.1 (diff)
downloadgentoo-d5599a6353921fd0cd388853f15b521a47bae51e.tar.gz
gentoo-d5599a6353921fd0cd388853f15b521a47bae51e.tar.bz2
gentoo-d5599a6353921fd0cd388853f15b521a47bae51e.zip
sys-devel/clang-runtime: Bump to 10.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-10.0.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-10.0.1.ebuild b/sys-devel/clang-runtime/clang-runtime-10.0.1.ebuild
new file mode 100644
index 000000000000..b2858aa38746
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-10.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"