summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-21 09:13:36 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-21 09:33:53 +0200
commitdbf35e66bd6dd82f993f4199fc0a0785c00f79c7 (patch)
treeb7ad00626755461057b505fc371ebb52bfcb898a /sys-devel/clang-runtime
parentsys-libs/libomp: Add 9.0 branch live ebuild (diff)
downloadgentoo-dbf35e66bd6dd82f993f4199fc0a0785c00f79c7.tar.gz
gentoo-dbf35e66bd6dd82f993f4199fc0a0785c00f79c7.tar.bz2
gentoo-dbf35e66bd6dd82f993f4199fc0a0785c00f79c7.zip
sys-devel/clang-runtime: Add 9.0 branch live ebuild
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-9.0.9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-9.0.9999.ebuild b/sys-devel/clang-runtime/clang-runtime-9.0.9999.ebuild
new file mode 100644
index 000000000000..2b4d595159ba
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-9.0.9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+# Note: keep it matching clang-9999 version
+SLOT="9.0.0"
+KEYWORDS=""
+IUSE="+compiler-rt crt libcxx openmp +sanitize"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ crt? (
+ || (
+ sys-libs/netbsd-csu[${MULTILIB_USEDEP}]
+ sys-freebsd/freebsd-lib[${MULTILIB_USEDEP}]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
+
+REQUIRED_USE="sanitize? ( compiler-rt )"