summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2016-01-27 23:35:24 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2016-01-27 23:35:36 +0100
commite63ee31ad20bfd2d7e2159c63b62913bfd001353 (patch)
treee170bf2d969d24f8437c75021805c7a78f6ae0d2 /sys-devel/clang/clang-3.8.0_rc1-r100.ebuild
parentsys-fs/spl-0.6.5.4{,-r1}: Version Bump (diff)
downloadgentoo-e63ee31ad20bfd2d7e2159c63b62913bfd001353.tar.gz
gentoo-e63ee31ad20bfd2d7e2159c63b62913bfd001353.tar.bz2
gentoo-e63ee31ad20bfd2d7e2159c63b62913bfd001353.zip
sys-devel/llvm: add (masked) 3.8 release candidate for testing
Package-Manager: portage-2.2.27
Diffstat (limited to 'sys-devel/clang/clang-3.8.0_rc1-r100.ebuild')
-rw-r--r--sys-devel/clang/clang-3.8.0_rc1-r100.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-devel/clang/clang-3.8.0_rc1-r100.ebuild b/sys-devel/clang/clang-3.8.0_rc1-r100.ebuild
new file mode 100644
index 000000000000..1ba7a7085955
--- /dev/null
+++ b/sys-devel/clang/clang-3.8.0_rc1-r100.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib-build
+
+DESCRIPTION="C language family frontend for LLVM (meta-ebuild)"
+HOMEPAGE="http://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="UoI-NCSA"
+SLOT="0/3.7"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="debug multitarget python +static-analyzer"
+
+RDEPEND="~sys-devel/llvm-${PV}[clang(-),debug=,multitarget?,python?,static-analyzer?,${MULTILIB_USEDEP}]"
+
+# Please keep this package around since it's quite likely that we'll
+# return to separate LLVM & clang ebuilds when the cmake build system
+# is complete.
+
+pkg_postinst() {
+ if has_version ">=dev-util/ccache-3.1.9-r2" ; then
+ #add ccache links as clang might get installed after ccache
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ fi
+}
+
+pkg_postrm() {
+ if has_version ">=dev-util/ccache-3.1.9-r2" && [[ -z ${REPLACED_BY_VERSION} ]]; then
+ # --remove-links would remove all links, --install-links updates them
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ fi
+}