summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-09 23:58:54 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-10 00:11:25 +0100
commit3c93f9d2a10e4c1725440850e77d2bc12cfce6a8 (patch)
tree29b86bedf46d7988935289bd0d4dd72191973fcd /sys-devel/clang/clang-5.0.1.ebuild
parentsys-libs/uclibc-ng: fall back on 1.0.26 (diff)
downloadgentoo-3c93f9d2a10e4c1725440850e77d2bc12cfce6a8.tar.gz
gentoo-3c93f9d2a10e4c1725440850e77d2bc12cfce6a8.tar.bz2
gentoo-3c93f9d2a10e4c1725440850e77d2bc12cfce6a8.zip
sys-devel/clang: Raise libcxx dep for USE=default-libcxx
Require the same or newer sys-libs/libcxx version when 'default-libcxx' flag is used. This may reduce the risk of libc++ version problems on pure libc++ systems (e.g. FreeBSD) by promoting early libc++ upgrade, and it is consistent with the dependency in sys-devel/clang-runtime.
Diffstat (limited to 'sys-devel/clang/clang-5.0.1.ebuild')
-rw-r--r--sys-devel/clang/clang-5.0.1.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/sys-devel/clang/clang-5.0.1.ebuild b/sys-devel/clang/clang-5.0.1.ebuild
index f215ab8b2002..4c30e033af76 100644
--- a/sys-devel/clang/clang-5.0.1.ebuild
+++ b/sys-devel/clang/clang-5.0.1.ebuild
@@ -54,7 +54,7 @@ RDEPEND="${RDEPEND}
PDEPEND="
~sys-devel/clang-runtime-${PV}
default-compiler-rt? ( =sys-libs/compiler-rt-${PV%_*}* )
- default-libcxx? ( sys-libs/libcxx )"
+ default-libcxx? ( >=sys-libs/libcxx-${PV} )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
|| ( ${ALL_LLVM_TARGETS[*]} )"