summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-04-01 23:48:30 +0200
committerMichał Górny <mgorny@gentoo.org>2018-04-02 00:27:16 +0200
commit52937c53de83b925db8a7b20cebf0e18284bc75e (patch)
tree6b2b9e6e3b7379b857fd4ad679f6d6fb4d14f27c /sys-devel/clang/clang-5.0.1.ebuild
parentsys-devel/llvm: Backport -Wl,-rpath FreeBSD fix to 5.0.1 (diff)
downloadgentoo-52937c53de83b925db8a7b20cebf0e18284bc75e.tar.gz
gentoo-52937c53de83b925db8a7b20cebf0e18284bc75e.tar.bz2
gentoo-52937c53de83b925db8a7b20cebf0e18284bc75e.zip
sys-devel/clang: Backport FreeBSD test fixes to 5.0.1
Diffstat (limited to 'sys-devel/clang/clang-5.0.1.ebuild')
-rw-r--r--sys-devel/clang/clang-5.0.1.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/sys-devel/clang/clang-5.0.1.ebuild b/sys-devel/clang/clang-5.0.1.ebuild
index b16d9564915d..c79d4d26b48f 100644
--- a/sys-devel/clang/clang-5.0.1.ebuild
+++ b/sys-devel/clang/clang-5.0.1.ebuild
@@ -65,13 +65,6 @@ S=${WORKDIR}/x/y/${MY_P}
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo
-PATCHES=(
- # fix finding compiler-rt libs
- "${FILESDIR}"/5.0.1/0001-Driver-Use-arch-type-to-find-compiler-rt-libraries-o.patch
- # add Prefix include paths for Darwin
- "${FILESDIR}"/5.0.1/darwin_prefix-include-paths.patch
-)
-
# Multilib notes:
# 1. ABI_* flags control ABIs libclang* is built for only.
# 2. clang is always capable of compiling code for all ABIs for enabled
@@ -113,6 +106,18 @@ src_unpack() {
}
src_prepare() {
+ # fix finding compiler-rt libs
+ eapply "${FILESDIR}"/5.0.1/0001-Driver-Use-arch-type-to-find-compiler-rt-libraries-o.patch
+ # fix setting LD_LIBRARY_PATH for tests on *BSD
+ eapply "${FILESDIR}"/5.0.1/0002-test-Fix-clang-test-for-FreeBSD-and-NetBSD.patch
+ # add Prefix include paths for Darwin
+ eapply "${FILESDIR}"/5.0.1/darwin_prefix-include-paths.patch
+
+ cd tools/extra || die
+ # fix setting LD_LIBRARY_PATH for tests on *BSD (extra part)
+ eapply "${FILESDIR}"/5.0.1/extra/0001-Assume-the-shared-library-path-variable-is-LD_LIBRAR.patch
+ cd ../.. || die
+
cmake-utils_src_prepare
eprefixify lib/Frontend/InitHeaderSearch.cpp
}