summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-06 14:47:25 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-06 15:04:15 +0100
commitbfb9c86dffdb56600ba35241c2a7d66666d1d47a (patch)
treec27aa60f0036e5ac8a85201d7ac5f5b4ab7903e4 /sys-devel/clang/files
parentdev-python/clang-python: Remove 9.0.0* (diff)
downloadgentoo-bfb9c86dffdb56600ba35241c2a7d66666d1d47a.tar.gz
gentoo-bfb9c86dffdb56600ba35241c2a7d66666d1d47a.tar.bz2
gentoo-bfb9c86dffdb56600ba35241c2a7d66666d1d47a.zip
sys-devel/clang: Remove 9.0.0*
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang/files')
-rw-r--r--sys-devel/clang/files/9.0.0/0001-clang-unittest-Import-LLVMTestingSupport-if-necessar.patch39
-rw-r--r--sys-devel/clang/files/9.0.0/0002-Initialize-all-fields-in-ABIArgInfo.patch43
-rw-r--r--sys-devel/clang/files/9.0.0/0003-Fix-Driver-modules.cpp-test-to-work-when-build-direc.patch35
3 files changed, 0 insertions, 117 deletions
diff --git a/sys-devel/clang/files/9.0.0/0001-clang-unittest-Import-LLVMTestingSupport-if-necessar.patch b/sys-devel/clang/files/9.0.0/0001-clang-unittest-Import-LLVMTestingSupport-if-necessar.patch
deleted file mode 100644
index 67ae5a8e4dcf..000000000000
--- a/sys-devel/clang/files/9.0.0/0001-clang-unittest-Import-LLVMTestingSupport-if-necessar.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From bfb5b0cb86cf90d9fa794f873644aa642b652c43 Mon Sep 17 00:00:00 2001
-From: Michal Gorny <mgorny@gentoo.org>
-Date: Thu, 12 Sep 2019 13:06:12 +0000
-Subject: [PATCH] [clang] [unittest] Import LLVMTestingSupport if necessary
-
-Add LLVMTestingSupport directory from LLVM_MAIN_SRC_DIR when building
-clang stand-alone and LLVMTestingSupport library is not present. This
-is needed to fix stand-alone builds without clang-tools-extra.
-
-Differential Revision: https://reviews.llvm.org/D67452
-
-llvm-svn: 371733
----
- clang/unittests/CMakeLists.txt | 9 +++++++++
- 1 file changed, 9 insertions(+)
-
-diff --git a/unittests/CMakeLists.txt b/unittests/CMakeLists.txt
-index 9a41000cf43..4c222e24599 100644
---- a/unittests/CMakeLists.txt
-+++ b/unittests/CMakeLists.txt
-@@ -1,6 +1,15 @@
- add_custom_target(ClangUnitTests)
- set_target_properties(ClangUnitTests PROPERTIES FOLDER "Clang tests")
-
-+if(CLANG_BUILT_STANDALONE)
-+ # LLVMTestingSupport library is needed for some of the unittests.
-+ if (EXISTS ${LLVM_MAIN_SRC_DIR}/lib/Testing/Support
-+ AND NOT TARGET LLVMTestingSupport)
-+ add_subdirectory(${LLVM_MAIN_SRC_DIR}/lib/Testing/Support
-+ lib/Testing/Support)
-+ endif()
-+endif()
-+
- # add_clang_unittest(test_dirname file1.cpp file2.cpp)
- #
- # Will compile the list of files together and link against the clang
---
-2.23.0
-
diff --git a/sys-devel/clang/files/9.0.0/0002-Initialize-all-fields-in-ABIArgInfo.patch b/sys-devel/clang/files/9.0.0/0002-Initialize-all-fields-in-ABIArgInfo.patch
deleted file mode 100644
index cc397f7c078a..000000000000
--- a/sys-devel/clang/files/9.0.0/0002-Initialize-all-fields-in-ABIArgInfo.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 3398b3f937dd025c81d75a7322a6b7b2205ca8da Mon Sep 17 00:00:00 2001
-From: Serge Guelton <sguelton@redhat.com>
-Date: Thu, 19 Sep 2019 00:54:40 +0000
-Subject: [PATCH] Initialize all fields in ABIArgInfo.
-
-Due to usage of an uninitialized fields, we end up with
-a Conditional jump or move depends on uninitialised value
-
-Fixes https://bugs.llvm.org/show_bug.cgi?id=40547
-
-Commited on behalf of Martin Liska <mliska@suse.cz>
-
-llvm-svn: 372281
----
- clang/include/clang/CodeGen/CGFunctionInfo.h | 10 ++++------
- 1 file changed, 4 insertions(+), 6 deletions(-)
-
-diff --git a/clang/include/clang/CodeGen/CGFunctionInfo.h b/clang/include/clang/CodeGen/CGFunctionInfo.h
-index 1f81072e23d..5069d9af42a 100644
---- a/include/clang/CodeGen/CGFunctionInfo.h
-+++ b/include/clang/CodeGen/CGFunctionInfo.h
-@@ -109,14 +109,12 @@ private:
- UnpaddedCoerceAndExpandType = T;
- }
-
-- ABIArgInfo(Kind K)
-- : TheKind(K), PaddingInReg(false), InReg(false) {
-- }
--
- public:
-- ABIArgInfo()
-+ ABIArgInfo(Kind K = Direct)
- : TypeData(nullptr), PaddingType(nullptr), DirectOffset(0),
-- TheKind(Direct), PaddingInReg(false), InReg(false) {}
-+ TheKind(K), PaddingInReg(false), InAllocaSRet(false),
-+ IndirectByVal(false), IndirectRealign(false), SRetAfterThis(false),
-+ InReg(false), CanBeFlattened(false), SignExt(false) {}
-
- static ABIArgInfo getDirect(llvm::Type *T = nullptr, unsigned Offset = 0,
- llvm::Type *Padding = nullptr,
---
-2.23.0
-
diff --git a/sys-devel/clang/files/9.0.0/0003-Fix-Driver-modules.cpp-test-to-work-when-build-direc.patch b/sys-devel/clang/files/9.0.0/0003-Fix-Driver-modules.cpp-test-to-work-when-build-direc.patch
deleted file mode 100644
index 250302da8e4c..000000000000
--- a/sys-devel/clang/files/9.0.0/0003-Fix-Driver-modules.cpp-test-to-work-when-build-direc.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From f18d747107de3504ceac73abc1ec351fe8f58c95 Mon Sep 17 00:00:00 2001
-From: Tom Stellard <tstellar@redhat.com>
-Date: Mon, 30 Sep 2019 23:42:17 +0000
-Subject: [PATCH] Fix Driver/modules.cpp test to work when build directory name
- contains '.s'
-
-Reviewers: dyung, rsmith, hansw
-
-Subscribers: mati865, mgorny, cfe-commits
-
-Tags: #clang
-
-Differential Revision: https://reviews.llvm.org/D66176
-
-llvm-svn: 373275
----
- clang/test/Driver/modules.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/clang/test/Driver/modules.cpp b/clang/test/Driver/modules.cpp
-index 7c549c1300f..4f4e3a41400 100644
---- a/test/Driver/modules.cpp
-+++ b/test/Driver/modules.cpp
-@@ -15,7 +15,7 @@
- // RUN: %clang -std=c++2a %t/module.pcm -S -o %t/module.pcm.o -v 2>&1 | FileCheck %s --check-prefix=CHECK-COMPILE
- //
- // CHECK-COMPILE: -cc1 {{.*}} {{-emit-obj|-S}}
--// CHECK-COMPILE-SAME: -o {{.*}}.{{pcm.o|s}}
-+// CHECK-COMPILE-SAME: -o {{.*}}module{{2*}}.pcm.o
- // CHECK-COMPILE-SAME: -x pcm
- // CHECK-COMPILE-SAME: {{.*}}.pcm
-
---
-2.23.0
-