summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-04-07 11:05:44 +0200
committerMichał Górny <mgorny@gentoo.org>2018-04-07 23:29:48 +0200
commit132e9a33cfbdaf22c518f8c0a231b3599b2c6ad2 (patch)
treeba8234e00c1b46d832d932a815b27149de07c493 /sys-devel/clang
parentdev-perl/CGI: stable 4.360.0 for ia64, bug #652502 (diff)
downloadgentoo-132e9a33cfbdaf22c518f8c0a231b3599b2c6ad2.tar.gz
gentoo-132e9a33cfbdaf22c518f8c0a231b3599b2c6ad2.tar.bz2
gentoo-132e9a33cfbdaf22c518f8c0a231b3599b2c6ad2.zip
sys-devel/clang: Include LLVMTestingSupport lib in -9999 checkout
Include the lib/Testing/Support directory in LLVM checkout since the clangd tests (part of clang-tools-extra) require that library now. The code still needs a fix upstream to actually build the library.
Diffstat (limited to 'sys-devel/clang')
-rw-r--r--sys-devel/clang/clang-9999.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/sys-devel/clang/clang-9999.ebuild b/sys-devel/clang/clang-9999.ebuild
index d769bda1d033..8bc9b08cc459 100644
--- a/sys-devel/clang/clang-9999.ebuild
+++ b/sys-devel/clang/clang-9999.ebuild
@@ -99,7 +99,8 @@ src_unpack() {
"${S}"/tools/extra
if use test; then
git-r3_checkout https://llvm.org/git/llvm.git \
- "${WORKDIR}"/llvm '' utils/{lit,llvm-lit,unittest}
+ "${WORKDIR}"/llvm '' \
+ lib/Testing/Support utils/{lit,llvm-lit,unittest}
fi
git-r3_checkout "${EGIT_REPO_URI}" "${S}"
}