summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-01-12 11:42:31 +0100
committerMichał Górny <mgorny@gentoo.org>2017-01-12 16:25:25 +0100
commit1e3085b70acf6415641776991563553b42fff18c (patch)
tree8f82785fdd6e52cf413e4256b2067114a152d647 /sys-devel/clang
parentsys-devel/llvm: Stop using custom build type in -9999 (diff)
downloadgentoo-1e3085b70acf6415641776991563553b42fff18c.tar.gz
gentoo-1e3085b70acf6415641776991563553b42fff18c.tar.bz2
gentoo-1e3085b70acf6415641776991563553b42fff18c.zip
sys-devel/clang: Switch to CMAKE_BUILD_TYPE=RelWithDebInfo
Diffstat (limited to 'sys-devel/clang')
-rw-r--r--sys-devel/clang/clang-9999.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/sys-devel/clang/clang-9999.ebuild b/sys-devel/clang/clang-9999.ebuild
index fb2c2eaae1b7..ce785b0b0402 100644
--- a/sys-devel/clang/clang-9999.ebuild
+++ b/sys-devel/clang/clang-9999.ebuild
@@ -5,6 +5,8 @@
EAPI=6
: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+# (needed due to CMAKE_BUILD_TYPE != Gentoo)
+CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
inherit check-reqs cmake-utils flag-o-matic git-r3 multilib-minimal \
@@ -50,6 +52,9 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
|| ( ${ALL_LLVM_TARGETS[*]} )
multitarget? ( ${ALL_LLVM_TARGETS[*]} )"
+# least intrusive of all
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
# Multilib notes:
# 1. ABI_* flags control ABIs libclang* is built for only.
# 2. clang is always capable of compiling code for all ABIs for enabled