summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-01-06 12:16:59 +0100
committerMichał Górny <mgorny@gentoo.org>2016-01-06 12:18:41 +0100
commit1e6ada801653c52dafd1115011ec6ae2a3619994 (patch)
treef34db6a5a82dece89c4761ddbaf85ca86fb5fcc7 /sys-devel/clang
parentwww-client/vivaldi: Old. (diff)
downloadgentoo-1e6ada801653c52dafd1115011ec6ae2a3619994.tar.gz
gentoo-1e6ada801653c52dafd1115011ec6ae2a3619994.tar.bz2
gentoo-1e6ada801653c52dafd1115011ec6ae2a3619994.zip
sys-devel/{clang,llvm}: Bump to 3.7.1
Diffstat (limited to 'sys-devel/clang')
-rw-r--r--sys-devel/clang/clang-3.7.1-r100.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-devel/clang/clang-3.7.1-r100.ebuild b/sys-devel/clang/clang-3.7.1-r100.ebuild
new file mode 100644
index 000000000000..8f3633d6b6da
--- /dev/null
+++ b/sys-devel/clang/clang-3.7.1-r100.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib-build
+
+DESCRIPTION="C language family frontend for LLVM (meta-ebuild)"
+HOMEPAGE="http://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="UoI-NCSA"
+SLOT="0/3.7"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="debug multitarget python +static-analyzer"
+
+RDEPEND="~sys-devel/llvm-${PV}[clang(-),debug=,multitarget?,python?,static-analyzer,${MULTILIB_USEDEP}]"
+
+# Please keep this package around since it's quite likely that we'll
+# return to separate LLVM & clang ebuilds when the cmake build system
+# is complete.
+
+pkg_postinst() {
+ if has_version ">=dev-util/ccache-3.1.9-r2" ; then
+ #add ccache links as clang might get installed after ccache
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ fi
+}
+
+pkg_postrm() {
+ if has_version ">=dev-util/ccache-3.1.9-r2" && [[ -z ${REPLACED_BY_VERSION} ]]; then
+ # --remove-links would remove all links, --install-links updates them
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ fi
+}