summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-08-28 16:47:03 +0200
committerMichał Górny <mgorny@gentoo.org>2016-08-28 18:19:26 +0200
commit5cd2c0a262c54abd65120aaefc107c2bf3042026 (patch)
treeba9c85f9f742435900584848c6c3ab8e19214d64 /sys-devel/clang
parentsys-devel/llvm: Bump to 3.9.0rc3 (diff)
downloadgentoo-5cd2c0a262c54abd65120aaefc107c2bf3042026.tar.gz
gentoo-5cd2c0a262c54abd65120aaefc107c2bf3042026.tar.bz2
gentoo-5cd2c0a262c54abd65120aaefc107c2bf3042026.zip
sys-devel/clang: Bump to 3.9.0rc3
Diffstat (limited to 'sys-devel/clang')
-rw-r--r--sys-devel/clang/clang-3.9.0_rc3-r100.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-devel/clang/clang-3.9.0_rc3-r100.ebuild b/sys-devel/clang/clang-3.9.0_rc3-r100.ebuild
new file mode 100644
index 000000000000..2df2ecad09fe
--- /dev/null
+++ b/sys-devel/clang/clang-3.9.0_rc3-r100.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib-build
+
+DESCRIPTION="C language family frontend for LLVM (meta-ebuild)"
+HOMEPAGE="http://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="UoI-NCSA"
+SLOT="0/3.8"
+KEYWORDS="~amd64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug multitarget python +static-analyzer"
+
+RDEPEND="~sys-devel/llvm-${PV}[clang(-),debug=,multitarget?,python?,static-analyzer?,${MULTILIB_USEDEP}]"
+
+# Please keep this package around since it's quite likely that we'll
+# return to separate LLVM & clang ebuilds when the cmake build system
+# is complete.
+
+pkg_postinst() {
+ if has_version ">=dev-util/ccache-3.1.9-r2" ; then
+ #add ccache links as clang might get installed after ccache
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ fi
+}
+
+pkg_postrm() {
+ if has_version ">=dev-util/ccache-3.1.9-r2" && [[ -z ${REPLACED_BY_VERSION} ]]; then
+ # --remove-links would remove all links, --install-links updates them
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ fi
+}