summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-04-04 14:27:49 +0200
committerMichał Górny <mgorny@gentoo.org>2018-04-04 15:56:03 +0200
commit64c144a8d2c2fce9015477b4a1f3d16ddc629baf (patch)
tree9a4d53112cf7b5be054ae0285f25ba7e31d68aa1 /sys-devel/clang
parentsys-devel/llvm: Inform about opt-viewer scripts in postinst (diff)
downloadgentoo-64c144a8d2c2fce9015477b4a1f3d16ddc629baf.tar.gz
gentoo-64c144a8d2c2fce9015477b4a1f3d16ddc629baf.tar.bz2
gentoo-64c144a8d2c2fce9015477b4a1f3d16ddc629baf.zip
sys-devel/clang: Inform about utility scripts in postinst
Closes: https://bugs.gentoo.org/652234
Diffstat (limited to 'sys-devel/clang')
-rw-r--r--sys-devel/clang/clang-5.0.1.ebuild5
-rw-r--r--sys-devel/clang/clang-6.0.0-r1.ebuild7
-rw-r--r--sys-devel/clang/clang-6.0.9999.ebuild7
-rw-r--r--sys-devel/clang/clang-9999.ebuild7
4 files changed, 26 insertions, 0 deletions
diff --git a/sys-devel/clang/clang-5.0.1.ebuild b/sys-devel/clang/clang-5.0.1.ebuild
index 400d07487577..8ff413171d9e 100644
--- a/sys-devel/clang/clang-5.0.1.ebuild
+++ b/sys-devel/clang/clang-5.0.1.ebuild
@@ -309,6 +309,11 @@ pkg_postinst() {
if [[ ${ROOT} == / && -f ${EPREFIX}/usr/share/eselect/modules/compiler-shadow.eselect ]] ; then
eselect compiler-shadow update all
fi
+
+ elog "You can find additional utility scripts in:"
+ elog " ${EROOT}/usr/lib/llvm/${SLOT}/share/clang"
+ elog "To use these scripts, you will need Python 2.7. Some of them are vim"
+ elog "integration scripts (with instructions inside)."
}
pkg_postrm() {
diff --git a/sys-devel/clang/clang-6.0.0-r1.ebuild b/sys-devel/clang/clang-6.0.0-r1.ebuild
index a8ab8bbb6b6a..3a5f777fc01d 100644
--- a/sys-devel/clang/clang-6.0.0-r1.ebuild
+++ b/sys-devel/clang/clang-6.0.0-r1.ebuild
@@ -308,6 +308,13 @@ pkg_postinst() {
if [[ ${ROOT} == / && -f ${EPREFIX}/usr/share/eselect/modules/compiler-shadow.eselect ]] ; then
eselect compiler-shadow update all
fi
+
+ elog "You can find additional utility scripts in:"
+ elog " ${EROOT}/usr/lib/llvm/${SLOT}/share/clang"
+ elog "To use these scripts, you will need Python 2.7. Some of them are vim"
+ elog "integration scripts (with instructions inside). The run-clang-tidy.py"
+ elog "scripts requires the following additional package:"
+ elog " dev-python/pyyaml"
}
pkg_postrm() {
diff --git a/sys-devel/clang/clang-6.0.9999.ebuild b/sys-devel/clang/clang-6.0.9999.ebuild
index 509b47b788fb..5ab3ba4c9fc4 100644
--- a/sys-devel/clang/clang-6.0.9999.ebuild
+++ b/sys-devel/clang/clang-6.0.9999.ebuild
@@ -280,6 +280,13 @@ pkg_postinst() {
if [[ ${ROOT} == / && -f ${EPREFIX}/usr/share/eselect/modules/compiler-shadow.eselect ]] ; then
eselect compiler-shadow update all
fi
+
+ elog "You can find additional utility scripts in:"
+ elog " ${EROOT}/usr/lib/llvm/${SLOT}/share/clang"
+ elog "To use these scripts, you will need Python 2.7. Some of them are vim"
+ elog "integration scripts (with instructions inside). The run-clang-tidy.py"
+ elog "scripts requires the following additional package:"
+ elog " dev-python/pyyaml"
}
pkg_postrm() {
diff --git a/sys-devel/clang/clang-9999.ebuild b/sys-devel/clang/clang-9999.ebuild
index 10c2dbd94ce6..3b9669f61013 100644
--- a/sys-devel/clang/clang-9999.ebuild
+++ b/sys-devel/clang/clang-9999.ebuild
@@ -281,6 +281,13 @@ pkg_postinst() {
if [[ ${ROOT} == / && -f ${EPREFIX}/usr/share/eselect/modules/compiler-shadow.eselect ]] ; then
eselect compiler-shadow update all
fi
+
+ elog "You can find additional utility scripts in:"
+ elog " ${EROOT}/usr/lib/llvm/${SLOT}/share/clang"
+ elog "To use these scripts, you will need Python 2.7. Some of them are vim"
+ elog "integration scripts (with instructions inside). The run-clang-tidy.py"
+ elog "scripts requires the following additional package:"
+ elog " dev-python/pyyaml"
}
pkg_postrm() {