summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-08-29 23:41:24 +0200
committerMichał Górny <mgorny@gentoo.org>2016-08-29 23:43:20 +0200
commit9046a22556866234773a494af9dd1657f2765d1a (patch)
treeb0da633dfc4b038ccfa79114db3cc9907a6fbd70 /sys-devel/clang
parentsys-devel/llvm: Fix cmake unused arg warnings with USE=-doc (diff)
downloadgentoo-9046a22556866234773a494af9dd1657f2765d1a.tar.gz
gentoo-9046a22556866234773a494af9dd1657f2765d1a.tar.bz2
gentoo-9046a22556866234773a494af9dd1657f2765d1a.zip
sys-devel/clang: Fetch llvm src with USE=test, to support unittests
Diffstat (limited to 'sys-devel/clang')
-rw-r--r--sys-devel/clang/clang-9999.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/sys-devel/clang/clang-9999.ebuild b/sys-devel/clang/clang-9999.ebuild
index 5d965090b067..8d472dab3401 100644
--- a/sys-devel/clang/clang-9999.ebuild
+++ b/sys-devel/clang/clang-9999.ebuild
@@ -75,10 +75,19 @@ pkg_setup() {
src_unpack() {
git-r3_fetch "http://llvm.org/git/clang-tools-extra.git
https://github.com/llvm-mirror/clang-tools-extra.git"
+ if use test; then
+ # needed for patched gtest
+ git-r3_fetch "http://llvm.org/git/llvm.git
+ https://github.com/llvm-mirror/llvm.git"
+ fi
git-r3_fetch
git-r3_checkout http://llvm.org/git/clang-tools-extra.git \
"${S}"/tools/clang/tools/extra
+ if use test; then
+ git-r3_checkout http://llvm.org/git/llvm.git \
+ "${WORKDIR}"/llvm
+ fi
git-r3_checkout
}
@@ -140,10 +149,12 @@ multilib_src_configure() {
-DCLANG_ENABLE_ARCMT=$(usex static-analyzer)
-DCLANG_ENABLE_STATIC_ANALYZER=$(usex static-analyzer)
)
+ use test && mycmakeargs+=(
+ -DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
+ )
if multilib_is_native_abi; then
mycmakeargs+=(
- # TODO: docs don't work out-of-llvm
-DLLVM_BUILD_DOCS=$(usex doc)
-DLLVM_ENABLE_SPHINX=$(usex doc)
-DLLVM_ENABLE_DOXYGEN=OFF