summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2022-08-23 17:10:47 +0200
committerSam James <sam@gentoo.org>2022-08-25 03:09:27 +0100
commit77bd9e6e0304ab640f23a34e54ef43bee28e2b41 (patch)
tree60959a8de1745d30deb3861a3db15bc746926c16 /sys-devel/cproc/cproc-0_pre20220805.ebuild
parentsys-devel/qbe: new package from ::guru, add 1.0-r1, 9999 (diff)
downloadgentoo-77bd9e6e0304ab640f23a34e54ef43bee28e2b41.tar.gz
gentoo-77bd9e6e0304ab640f23a34e54ef43bee28e2b41.tar.bz2
gentoo-77bd9e6e0304ab640f23a34e54ef43bee28e2b41.zip
sys-devel/cproc: new package from ::guru, add 0_pre20220805, 9999
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/26978 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/cproc/cproc-0_pre20220805.ebuild')
-rw-r--r--sys-devel/cproc/cproc-0_pre20220805.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-devel/cproc/cproc-0_pre20220805.ebuild b/sys-devel/cproc/cproc-0_pre20220805.ebuild
new file mode 100644
index 000000000000..74f03bd8630d
--- /dev/null
+++ b/sys-devel/cproc/cproc-0_pre20220805.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ "${PV}" = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~mcf/cproc"
+else
+ CPROC_COMMIT="6fabc79d81de56b6c1cdcc2242933fd792e2ddf9"
+ CPROC_P="${PN}-${CPROC_COMMIT}"
+ SRC_URI="https://git.sr.ht/~mcf/cproc/archive/${CPROC_COMMIT}.tar.gz -> ${CPROC_P}.tar.gz"
+ S="${WORKDIR}/${CPROC_P}"
+
+ KEYWORDS="~amd64 ~arm64 ~riscv"
+fi
+
+DESCRIPTION="C11 compiler using QBE as backend"
+HOMEPAGE="https://sr.ht/~mcf/cproc/"
+LICENSE="ISC"
+SLOT="0"
+
+DEPEND="sys-devel/qbe:="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ rm -r "${S}/qbe" || die
+}
+
+src_configure() {
+ ./configure --prefix=/usr || die
+}