summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-01-20 18:54:16 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2018-01-20 18:55:24 +0000
commit5239f0b88b067302a5897a199554c76afa61b1bc (patch)
treed713ff6fdc421c67d932dc21f777e35f7247fc5b /sys-devel/crossdev/crossdev-20180120.ebuild
parentdev-python/git-review: version bump to 1.26.0 (diff)
downloadgentoo-5239f0b88b067302a5897a199554c76afa61b1bc.tar.gz
gentoo-5239f0b88b067302a5897a199554c76afa61b1bc.tar.bz2
gentoo-5239f0b88b067302a5897a199554c76afa61b1bc.zip
sys-devel/crossdev: bump up to 20180120
Closes: https://bugs.gentoo.org/644930 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-devel/crossdev/crossdev-20180120.ebuild')
-rw-r--r--sys-devel/crossdev/crossdev-20180120.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-devel/crossdev/crossdev-20180120.ebuild b/sys-devel/crossdev/crossdev-20180120.ebuild
new file mode 100644
index 000000000000..edf23ce34c9b
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20180120.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/crossdev.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ >=app-portage/portage-utils-0.55
+ app-shells/bash
+ sys-apps/gentoo-functions
+ !sys-devel/crossdev-wrappers"
+DEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+
+ if [[ "${PV}" == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED%/}"/usr/bin/crossdev || die
+ fi
+}