summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-11-29 22:37:58 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-11-29 22:38:08 +0000
commitb9d9ecb23fce8499407370eace81ca9544970345 (patch)
treef4f221e9cd799d512a693b1077cb81035fd0e9b5 /sys-devel/crossdev/crossdev-20201129.ebuild
parentx11-misc/synergy: Update remote-id (diff)
downloadgentoo-b9d9ecb23fce8499407370eace81ca9544970345.tar.gz
gentoo-b9d9ecb23fce8499407370eace81ca9544970345.tar.bz2
gentoo-b9d9ecb23fce8499407370eace81ca9544970345.zip
sys-devel/crossdev: bump up to 20201129
Single new change: - explicitly avoid USE=hardened for gcc on mingw targets Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/crossdev/crossdev-20201129.ebuild')
-rw-r--r--sys-devel/crossdev/crossdev-20201129.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-devel/crossdev/crossdev-20201129.ebuild b/sys-devel/crossdev/crossdev-20201129.ebuild
new file mode 100644
index 000000000000..809478863946
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20201129.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/crossdev.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Crossdev"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=sys-apps/portage-2.1
+ >=app-portage/portage-utils-0.55
+ app-shells/bash
+ sys-apps/gentoo-functions
+"
+DEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+
+ if [[ "${PV}" == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
+ fi
+}