summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-01-16 23:00:54 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-01-16 23:00:54 +0000
commit6e8a54c3d2bdcd6aeb7d21d187e2b246a990af06 (patch)
tree3efcec8ee52bfdad9de815e617a64c3fa58c2e8a /sys-devel/crossdev
parentsys-devel/crossdev: drop old (diff)
downloadgentoo-6e8a54c3d2bdcd6aeb7d21d187e2b246a990af06.tar.gz
gentoo-6e8a54c3d2bdcd6aeb7d21d187e2b246a990af06.tar.bz2
gentoo-6e8a54c3d2bdcd6aeb7d21d187e2b246a990af06.zip
sys-devel/crossdev: bump up to 20181202
Single change: uclibc tuples now default to uclibc-ng, not uclibc library. Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/crossdev')
-rw-r--r--sys-devel/crossdev/Manifest1
-rw-r--r--sys-devel/crossdev/crossdev-20181202.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-devel/crossdev/Manifest b/sys-devel/crossdev/Manifest
index 5ab79de1d6e6..af17f5afddae 100644
--- a/sys-devel/crossdev/Manifest
+++ b/sys-devel/crossdev/Manifest
@@ -1,2 +1,3 @@
DIST crossdev-20171230.tar.xz 23016 BLAKE2B 4661b3f9fac314b7346f0de7227d12ae2d6851e448f6d065471499df8ada5d699ef91c6b6bca285b2aefcbf67ab351fefbe9344c0884a7c0d33ff27215c8ed9c SHA512 bf8761a3018790501adb4bb173e3281d1d7628de8f65a1aa5df0b328a4af8088be466dbe8c185e7ed44aca31b078320a4f62c56351f4b7cbf832349184d9709f
DIST crossdev-20181020.tar.xz 27172 BLAKE2B 8a388d5201ab419b865b96a4314190a693a7e00f3b5ecc2db2efdf36efca102206b5c4c5633e5e4ee508f5433ff4e086460501462bacc86c2adb10cab33a0244 SHA512 dd7fa9522ce6f58684b54ddc57e088f19a8ad5392ff45ed5b2b1f95f4be7dbc753442adc1c2591a785d94070979200936ca713913e547e84ae02b05c83bf8cde
+DIST crossdev-20181202.tar.xz 27184 BLAKE2B d1770f5148d666b22a20576b638e71bf6325e8a61776b8b47ecaf2e5437150554f6973c5306d233a836e4ffe3ff0480167c9b877c5f9e733681fd502016a19d4 SHA512 896bf050c81f3f34b2be187a851832494c039aa93177c806b689a75d16567f178e4ca33c21282fc320506b76e09b0cde8a45976b6309bf9bc5be8290db3dd8af
diff --git a/sys-devel/crossdev/crossdev-20181202.ebuild b/sys-devel/crossdev/crossdev-20181202.ebuild
new file mode 100644
index 000000000000..aba306ab0492
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20181202.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/crossdev.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ || (
+ >=sys-apps/portage-2.1
+ sys-apps/portage-mgorny
+ )
+ >=app-portage/portage-utils-0.55
+ app-shells/bash
+ sys-apps/gentoo-functions
+ !sys-devel/crossdev-wrappers"
+DEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+
+ if [[ "${PV}" == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED%/}"/usr/bin/crossdev || die
+ fi
+}