summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-devel/ct-ng
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-devel/ct-ng')
-rw-r--r--sys-devel/ct-ng/Manifest3
-rw-r--r--sys-devel/ct-ng/ct-ng-1.19.0-r1.ebuild44
-rw-r--r--sys-devel/ct-ng/ct-ng-1.20.0-r1.ebuild44
-rw-r--r--sys-devel/ct-ng/ct-ng-1.21.0.ebuild44
-rw-r--r--sys-devel/ct-ng/files/ct-ng-kconfig-respect-flags.patch14
-rw-r--r--sys-devel/ct-ng/metadata.xml21
6 files changed, 170 insertions, 0 deletions
diff --git a/sys-devel/ct-ng/Manifest b/sys-devel/ct-ng/Manifest
new file mode 100644
index 000000000000..440460d00c6c
--- /dev/null
+++ b/sys-devel/ct-ng/Manifest
@@ -0,0 +1,3 @@
+DIST crosstool-ng-1.19.0.tar.bz2 1901456 SHA256 cd54f20bb8190533b21c9cf7f93c9073c22d59541f52774c3f3053264ba53a93 SHA512 ad9a1763a3178acf028f36c189d4588372c325d4494ec90cb4fccc5a889a89595cc85586f0380bed8238cff4ce07e49ef5f47779048da2956d3bf380bd4d2f17 WHIRLPOOL d2d1f03f05809e6c3607edd9901cfafae56a3158f8273736929a9a282ed5830d07efa116d8e606471fe598ed9cfdc0157627c4cef5e77ccdb55853632faf3a95
+DIST crosstool-ng-1.20.0.tar.bz2 2035181 SHA256 bfb1d251a3b5dbd262f6eb8416532b9920bb7f122ae4fb861a1824fe30c73464 SHA512 42aa93fbdfb2daa9055d7aeba7539a59960caad9d674fb3ca8ed74353da75a49a799896777cf9511a54b4d47de0cb5d206fd7c5200f19067f9c8090a46b39653 WHIRLPOOL 8b8a025567d5af29142c0809aca62230951b080db889b8f3073a87925d12d971e42bd42b42ff2221ea9fd85d229b43d24e15d0d736c5c696708e9b76651c2cb7
+DIST crosstool-ng-1.21.0.tar.bz2 19883048 SHA256 c64493dd033dee0eb25903e66cf53ff5113ee33d193a8ff1df7ebebe47bdac46 SHA512 ab2e341a920f43ef4c621579777b7e709b773dd38aeb68f2b1b567652497b912666ab841ff501f406c34b266e8dbe7859d67f63471972a2200044824848cf061 WHIRLPOOL 4d869c25741700afe4e9e398a8e124acd8cb513eba5609b85980c921966b08ac16ec2a884ed2a885fd44acdbbda01ff05623bce609152bcec5fa14b2c632202c
diff --git a/sys-devel/ct-ng/ct-ng-1.19.0-r1.ebuild b/sys-devel/ct-ng/ct-ng-1.19.0-r1.ebuild
new file mode 100644
index 000000000000..e953beb7ff14
--- /dev/null
+++ b/sys-devel/ct-ng/ct-ng-1.19.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools bash-completion-r1 eutils
+
+DESCRIPTION="crosstool-ng is a tool to build cross-compiling toolchains"
+HOMEPAGE="http://crosstool-ng.org"
+MY_P=${P/ct/crosstool}
+S=${WORKDIR}/${MY_P}
+SRC_URI="http://ymorin.is-a-geek.org/download/crosstool-ng/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="net-misc/curl
+ dev-util/gperf
+ dev-vcs/cvs
+ dev-vcs/subversion"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-kconfig-respect-flags.patch
+
+ #Upstream provides ${S}/bootstrap which runs autoconf -Wall --force
+ #We'll use eautoconf to be portage friendly
+ eautoconf -Wall --force
+}
+
+src_configure () {
+ econf --with-install="/usr/bin/install"
+}
+
+src_install() {
+ emake DESTDIR="${D%/}" install
+ newbashcomp ${PN}.comp ${PN}
+ dodoc README TODO
+ use doc && mv "${D}"/usr/share/doc/crosstool-ng/"${PN}.${PVR}"/* \
+ "${D}"/usr/share/doc/"${PF}"
+ rm -rf "${D}"/usr/share/doc/crosstool-ng
+}
diff --git a/sys-devel/ct-ng/ct-ng-1.20.0-r1.ebuild b/sys-devel/ct-ng/ct-ng-1.20.0-r1.ebuild
new file mode 100644
index 000000000000..e953beb7ff14
--- /dev/null
+++ b/sys-devel/ct-ng/ct-ng-1.20.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools bash-completion-r1 eutils
+
+DESCRIPTION="crosstool-ng is a tool to build cross-compiling toolchains"
+HOMEPAGE="http://crosstool-ng.org"
+MY_P=${P/ct/crosstool}
+S=${WORKDIR}/${MY_P}
+SRC_URI="http://ymorin.is-a-geek.org/download/crosstool-ng/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="net-misc/curl
+ dev-util/gperf
+ dev-vcs/cvs
+ dev-vcs/subversion"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-kconfig-respect-flags.patch
+
+ #Upstream provides ${S}/bootstrap which runs autoconf -Wall --force
+ #We'll use eautoconf to be portage friendly
+ eautoconf -Wall --force
+}
+
+src_configure () {
+ econf --with-install="/usr/bin/install"
+}
+
+src_install() {
+ emake DESTDIR="${D%/}" install
+ newbashcomp ${PN}.comp ${PN}
+ dodoc README TODO
+ use doc && mv "${D}"/usr/share/doc/crosstool-ng/"${PN}.${PVR}"/* \
+ "${D}"/usr/share/doc/"${PF}"
+ rm -rf "${D}"/usr/share/doc/crosstool-ng
+}
diff --git a/sys-devel/ct-ng/ct-ng-1.21.0.ebuild b/sys-devel/ct-ng/ct-ng-1.21.0.ebuild
new file mode 100644
index 000000000000..f63d6ec98e0d
--- /dev/null
+++ b/sys-devel/ct-ng/ct-ng-1.21.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools bash-completion-r1 eutils
+
+DESCRIPTION="crosstool-ng is a tool to build cross-compiling toolchains"
+HOMEPAGE="http://crosstool-ng.org"
+MY_P=${P/ct/crosstool}
+S=${WORKDIR}
+SRC_URI="http://ymorin.is-a-geek.org/download/crosstool-ng/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="net-misc/curl
+ dev-util/gperf
+ dev-vcs/cvs
+ dev-vcs/subversion"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-kconfig-respect-flags.patch
+
+ #Upstream provides ${S}/bootstrap which runs autoconf -Wall --force
+ #We'll use eautoconf to be portage friendly
+ eautoconf -Wall --force
+}
+
+src_configure () {
+ econf --with-install="/usr/bin/install"
+}
+
+src_install() {
+ emake DESTDIR="${D%/}" install
+ newbashcomp ${PN}.comp ${PN}
+ dodoc README TODO
+ use doc && mv "${D}"/usr/share/doc/crosstool-ng/"${PN}.${PVR}"/* \
+ "${D}"/usr/share/doc/"${PF}"
+ rm -rf "${D}"/usr/share/doc/crosstool-ng
+}
diff --git a/sys-devel/ct-ng/files/ct-ng-kconfig-respect-flags.patch b/sys-devel/ct-ng/files/ct-ng-kconfig-respect-flags.patch
new file mode 100644
index 000000000000..e6b48142a6df
--- /dev/null
+++ b/sys-devel/ct-ng/files/ct-ng-kconfig-respect-flags.patch
@@ -0,0 +1,14 @@
+diff -Naur crosstool-ng-1.15.3.orig//kconfig/Makefile crosstool-ng-1.15.3/kconfig/Makefile
+--- crosstool-ng-1.15.3.orig//kconfig/Makefile 2012-07-17 16:39:55.000000000 -0400
++++ crosstool-ng-1.15.3/kconfig/Makefile 2012-08-07 12:06:59.000000000 -0400
+@@ -6,8 +6,8 @@
+ @true # Just be silent, you fscking son of a fscking beach...
+
+ # Build flags
+-CFLAGS = -DCONFIG_=\"CT_\" -DPACKAGE="\"crosstool-NG $(VERSION)\""
+-LDFLAGS =
++CFLAGS += -DCONFIG_=\"CT_\" -DPACKAGE="\"crosstool-NG $(VERSION)\""
++#LDFLAGS =
+
+ # Compiler flags to use gettext
+ ifeq ($(gettext),)
diff --git a/sys-devel/ct-ng/metadata.xml b/sys-devel/ct-ng/metadata.xml
new file mode 100644
index 000000000000..ba79d94bdc79
--- /dev/null
+++ b/sys-devel/ct-ng/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <maintainer>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ </maintainer>
+ <longdescription lang="en">
+ crosstool-NG is a utility for building cross-compiling toolchains.
+ It will only build the toolchain. It is up to use how you want to
+ use it after that.
+
+ It is an alternative to sys-devel/crossdev.
+
+ For more information, see http://ymorin.is-a-geek.org/projects/crosstool
+ </longdescription>
+</pkgmetadata>