summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-02-10 17:05:26 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-02-10 17:06:56 +0100
commit866ab4db4fbdb6a2768152e82137edc6e4a9c9bc (patch)
tree18c08b0d8272a32ca0421803a10adf39a4ba2061 /sys-devel/distcc
parentapp-emulation/libvirt: Also update 6.0.0 (diff)
downloadgentoo-866ab4db4fbdb6a2768152e82137edc6e4a9c9bc.tar.gz
gentoo-866ab4db4fbdb6a2768152e82137edc6e4a9c9bc.tar.bz2
gentoo-866ab4db4fbdb6a2768152e82137edc6e4a9c9bc.zip
sys-devel/distcc: Revbump adding TMPDIR handling to init script
With kind permission from mgorny Committed straight to stable as we don't change upstream default without action from the user Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-devel/distcc')
-rw-r--r--sys-devel/distcc/distcc-3.3.3-r1.ebuild (renamed from sys-devel/distcc/distcc-3.3.3.ebuild)0
-rw-r--r--sys-devel/distcc/files/distccd.confd5
-rw-r--r--sys-devel/distcc/files/distccd.initd4
3 files changed, 8 insertions, 1 deletions
diff --git a/sys-devel/distcc/distcc-3.3.3.ebuild b/sys-devel/distcc/distcc-3.3.3-r1.ebuild
index 826019c73427..826019c73427 100644
--- a/sys-devel/distcc/distcc-3.3.3.ebuild
+++ b/sys-devel/distcc/distcc-3.3.3-r1.ebuild
diff --git a/sys-devel/distcc/files/distccd.confd b/sys-devel/distcc/files/distccd.confd
index bc08d40777d3..736527a4a899 100644
--- a/sys-devel/distcc/files/distccd.confd
+++ b/sys-devel/distcc/files/distccd.confd
@@ -35,3 +35,8 @@ DISTCCD_OPTS="${DISTCCD_OPTS} --allow 192.168.0.0/24"
# set this for niceness
# Default is 15
DISTCCD_OPTS="${DISTCCD_OPTS} -N 15"
+
+# By default distccd stores temporary files in /tmp
+# Make sure to give distcc user write permission to
+# the given TMPDIR
+#TMPDIR="/tmp"
diff --git a/sys-devel/distcc/files/distccd.initd b/sys-devel/distcc/files/distccd.initd
index 7673ff2cf429..963f7b74c12e 100644
--- a/sys-devel/distcc/files/distccd.initd
+++ b/sys-devel/distcc/files/distccd.initd
@@ -1,5 +1,5 @@
#!/sbin/openrc-run
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
depend() {
@@ -11,3 +11,5 @@ command="${DISTCCD_EXEC:-usr/bin/distccd}"
command_args="--user distcc --daemon --no-detach ${DISTCCD_OPTS}"
command_background="true"
pidfile="/run/${RC_SVCNAME}.pid"
+
+export TMPDIR="${TMPDIR:-/tmp}"