summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-07 05:53:40 +0100
committerSam James <sam@gentoo.org>2022-06-07 05:56:11 +0100
commit960e52330ab1979cc35077fbcea1e3ea7c63415f (patch)
treefc355cdbcd4b9272c773cd47ae1ff2626a6d2795 /sys-devel/distcc
parentsys-kernel/gentoo-kernel-bin: Bump to 5.4.197 (diff)
downloadgentoo-960e52330ab1979cc35077fbcea1e3ea7c63415f.tar.gz
gentoo-960e52330ab1979cc35077fbcea1e3ea7c63415f.tar.bz2
gentoo-960e52330ab1979cc35077fbcea1e3ea7c63415f.zip
sys-devel/distcc: update EAPI 7 -> 8, Python 3.10
Seems to mostly work with Python 3.10, although I get a test failure, it's better than it was pre-patch. Closes: https://bugs.gentoo.org/846320 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/distcc')
-rw-r--r--sys-devel/distcc/distcc-3.4-r1.ebuild181
-rw-r--r--sys-devel/distcc/files/distcc-3.4-pump-tests.patch153
2 files changed, 334 insertions, 0 deletions
diff --git a/sys-devel/distcc/distcc-3.4-r1.ebuild b/sys-devel/distcc/distcc-3.4-r1.ebuild
new file mode 100644
index 000000000000..7495c3fff4fe
--- /dev/null
+++ b/sys-devel/distcc/distcc-3.4-r1.ebuild
@@ -0,0 +1,181 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit autotools flag-o-matic prefix python-single-r1 systemd
+
+DESCRIPTION="Distribute compilation of C code across several machines on a network"
+HOMEPAGE="https://github.com/distcc/distcc"
+SRC_URI="https://github.com/distcc/distcc/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="gssapi gtk hardened ipv6 selinux xinetd zeroconf"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/popt
+ gssapi? ( net-libs/libgssglue )
+ gtk? ( x11-libs/gtk+:3 )
+ zeroconf? ( >=net-dns/avahi-0.6[dbus] )
+"
+DEPEND="${RDEPEND}
+ sys-libs/binutils-libs"
+BDEPEND="
+ sys-devel/autoconf-archive
+ virtual/pkgconfig"
+RDEPEND+="
+ acct-user/distcc
+ dev-util/shadowman
+ >=sys-devel/gcc-config-1.4.1
+ selinux? ( sec-policy/selinux-distcc )
+ xinetd? ( sys-apps/xinetd )"
+
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-3.0-xinetd.patch"
+ # SOCKSv5 support needed for Portage, bug #537616
+ eapply "${FILESDIR}/${PN}-3.2_rc1-socks5.patch"
+ eapply "${FILESDIR}/${PN}-3.4-pump-tests.patch"
+ eapply_user
+
+ # Bugs #120001, #167844 and probably more. See patch for description.
+ use hardened && eapply "${FILESDIR}/distcc-hardened.patch"
+
+ sed -i \
+ -e "/PATH/s:\$distcc_location:${EPREFIX}/usr/lib/distcc/bin:" \
+ -e "s:@PYTHON@:${EPYTHON}:" \
+ pump.in || die "sed failed"
+
+ sed \
+ -e "s:@EPREFIX@:${EPREFIX:-/}:" \
+ -e "s:@libdir@:/usr/lib:" \
+ "${FILESDIR}/distcc-config" > "${T}/distcc-config" || die
+
+ # TODO: gdb tests fail due to gdb failing to find .c file
+ sed -i -e '/Gdb.*Case,/d' test/testdistcc.py || die
+
+ hprefixify update-distcc-symlinks.py src/{serve,daemon}.c
+ python_fix_shebang update-distcc-symlinks.py "${T}/distcc-config"
+ eautoreconf
+}
+
+src_configure() {
+ # https://github.com/distcc/distcc/issues/454
+ append-cppflags -DPY_SSIZE_T_CLEAN
+
+ local myconf=(
+ --disable-Werror
+ --libdir="${EPREFIX}"/usr/lib
+ $(use_enable ipv6 rfc2553)
+ $(use_with gtk)
+ --without-gnome
+ $(use_with gssapi auth)
+ $(use_with zeroconf avahi)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ # sandbox breaks some tests, and hangs some too
+ # retest once #590084 is fixed
+ local -x SANDBOX_ON=0
+ emake -j1 check
+}
+
+src_install() {
+ # override GZIP_BIN to stop it from compressing manpages
+ emake -j1 DESTDIR="${D}" GZIP_BIN=false install
+ python_optimize
+
+ newinitd "${FILESDIR}/distccd.initd" distccd
+ systemd_newunit "${FILESDIR}/distccd.service-1" distccd.service
+ systemd_install_serviced "${FILESDIR}/distccd.service.conf"
+
+ cp "${FILESDIR}/distccd.confd" "${T}/distccd" || die
+ if use zeroconf; then
+ cat >> "${T}/distccd" <<-EOF || die
+
+ # Enable zeroconf support in distccd
+ DISTCCD_OPTS="\${DISTCCD_OPTS} --zeroconf"
+ EOF
+
+ sed -i '/ExecStart/ s|$| --zeroconf|' "${D}$(systemd_get_systemunitdir)"/distccd.service || die
+ fi
+ doconfd "${T}/distccd"
+
+ newenvd - 02distcc <<-EOF || die
+ # This file is managed by distcc-config; use it to change these settings.
+ # DISTCC_LOG and DISTCC_DIR should not be set.
+ DISTCC_VERBOSE="${DISTCC_VERBOSE:-0}"
+ DISTCC_FALLBACK="${DISTCC_FALLBACK:-1}"
+ DISTCC_SAVE_TEMPS="${DISTCC_SAVE_TEMPS:-0}"
+ DISTCC_TCP_CORK="${DISTCC_TCP_CORK}"
+ DISTCC_SSH="${DISTCC_SSH}"
+ UNCACHED_ERR_FD="${UNCACHED_ERR_FD}"
+ DISTCC_ENABLE_DISCREPANCY_EMAIL="${DISTCC_ENABLE_DISCREPANCY_EMAIL}"
+ DCC_EMAILLOG_WHOM_TO_BLAME="${DCC_EMAILLOG_WHOM_TO_BLAME}"
+ EOF
+
+ keepdir /usr/lib/distcc
+
+ dobin "${T}/distcc-config"
+
+ if use gtk; then
+ einfo "Renaming /usr/bin/distccmon-gnome to /usr/bin/distccmon-gui"
+ einfo "This is to have a little sensability in naming schemes between distccmon programs"
+ mv "${ED}/usr/bin/distccmon-gnome" "${ED}/usr/bin/distccmon-gui" || die
+ dosym distccmon-gui /usr/bin/distccmon-gnome
+ fi
+
+ if use xinetd; then
+ insinto /etc/xinetd.d
+ newins "doc/example/xinetd" distcc
+ fi
+
+ insinto /usr/share/shadowman/tools
+ newins - distcc <<<"${EPREFIX}/usr/lib/distcc/bin"
+ newins - distccd <<<"${EPREFIX}/usr/lib/distcc"
+
+ rm -r "${ED}/etc/default" || die
+ rm "${ED}/etc/distcc/clients.allow" || die
+ rm "${ED}/etc/distcc/commands.allow.sh" || die
+}
+
+pkg_postinst() {
+ # remove the old paths when switching from libXX to lib
+ if [[ $(get_libdir) != lib && ${SYMLINK_LIB} != yes && \
+ -d ${EROOT}/usr/$(get_libdir)/distcc ]]; then
+ rm -r -f "${EROOT}/usr/$(get_libdir)/distcc" || die
+ fi
+
+ if [[ -z ${ROOT} ]]; then
+ eselect compiler-shadow update distcc
+ eselect compiler-shadow update distccd
+ fi
+
+ elog
+ elog "Tips on using distcc with Gentoo can be found at"
+ elog "https://wiki.gentoo.org/wiki/Distcc"
+ elog
+ elog "distcc-pump is known to cause breakage with multiple packages."
+ elog "Do NOT enable it globally."
+ elog
+ elog "To use the distccmon programs with Gentoo you should use this command:"
+ elog "# DISTCC_DIR=\"${DISTCC_DIR:-${BUILD_PREFIX}/.distcc}\" distccmon-text 5"
+
+ if use gtk; then
+ elog "Or:"
+ elog "# DISTCC_DIR=\"${DISTCC_DIR:-${BUILD_PREFIX}/.distcc}\" distccmon-gnome"
+ fi
+}
+
+pkg_prerm() {
+ if [[ -z ${REPLACED_BY_VERSION} && -z ${ROOT} ]]; then
+ eselect compiler-shadow remove distcc
+ fi
+}
diff --git a/sys-devel/distcc/files/distcc-3.4-pump-tests.patch b/sys-devel/distcc/files/distcc-3.4-pump-tests.patch
new file mode 100644
index 000000000000..db392b7f3632
--- /dev/null
+++ b/sys-devel/distcc/files/distcc-3.4-pump-tests.patch
@@ -0,0 +1,153 @@
+https://github.com/distcc/distcc/pull/460
+
+From 45d9c4a1ef66451ed45a6afdec7098ed02082390 Mon Sep 17 00:00:00 2001
+From: Rosen Matev <rosen.matev@cern.ch>
+Date: Fri, 29 Apr 2022 15:42:28 +0200
+Subject: [PATCH] Fix tests in pump mode
+
+`make check` is also running tests for the pump mode
+(`pump-maintainer-check` target) but they were all falling back to
+the usual preprocessor mode as the include server was not started.
+
+This is solved by prepending `pump` to the distcc invocations and
+also some trivially failing tests are fixed or disabled when they
+make no sense in pump mode.
+---
+ Makefile.in | 2 +-
+ pump.in | 13 +++++++++++--
+ test/testdistcc.py | 28 ++++++++++++++++++++++++----
+ 3 files changed, 36 insertions(+), 7 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index f240ca6f..79e28380 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -583,7 +583,7 @@ distccmon-gnome@EXEEXT@: $(mon_obj) $(gnome_obj)
+ # the distcc version, the source location, the CPP flags (for location of the
+ # includes), and the build location.
+ include-server:
+- if test -z "$(PYTHON)"; then \
++ @if test -z "$(PYTHON)"; then \
+ echo "Not building $@: No suitable python found"; \
+ else \
+ mkdir -p "$(include_server_builddir)" && \
+diff --git a/pump.in b/pump.in
+index 8e46f458..08a32c0e 100755
+--- a/pump.in
++++ b/pump.in
+@@ -218,7 +218,9 @@ PrintIncludeServerStatusMessage() {
+ }
+
+ Announce() {
+- echo "__________Using distcc-pump from $DISTCC_LOCATION"
++ if [ "$verbose" = 1 ]; then
++ echo "__________Using distcc-pump from $DISTCC_LOCATION"
++ fi
+ }
+
+ # Starts up the include server. Sets $socket, $socket_dir, and
+@@ -359,7 +361,9 @@ ShutDown() {
+ # Always -- at exit -- shut down include_server and remove $socket_dir
+ if [ -n "$include_server_pid" ] && \
+ ps -p "$include_server_pid" > /dev/null; then
+- echo '__________Shutting down distcc-pump include server'
++ if [ "$verbose" = 1 ]; then
++ echo '__________Shutting down distcc-pump include server'
++ fi
+ kill $include_server_pid
+ # Wait until it's really dead. We need to do this because the
+ # include server may produce output after receiving SIGTERM.
+@@ -508,6 +512,11 @@ Main() {
+
+ Initialize
+
++ # Do not write on stdout if we're testing pump mode
++ if [ "0$DISTCC_TESTING_INCLUDE_SERVER" -ne "0" ]; then
++ verbose=0
++ fi
++
+ case "$*" in
+ --startup)
+ # Don't put ordinary progress messages on stdout,
+diff --git a/test/testdistcc.py b/test/testdistcc.py
+index dfdf2f13..6377d0b6 100755
+--- a/test/testdistcc.py
++++ b/test/testdistcc.py
+@@ -258,7 +258,11 @@ def valgrind(self):
+ return _valgrind_command;
+
+ def distcc(self):
+- return self.valgrind() + "distcc "
++ if "cpp" not in _server_options:
++ return self.valgrind() + "distcc "
++ else:
++ return "DISTCC_TESTING_INCLUDE_SERVER=1 " + self.valgrind() + "pump distcc "
++
+
+ def distccd(self):
+ return self.valgrind() + "distccd "
+@@ -422,6 +426,11 @@ class BogusOption_Case(SimpleDistCC_Case):
+ Now that we support implicit compilers, this is passed to gcc,
+ which returns a non-zero status."""
+ def runtest(self):
++ # Disable the test in pump mode since the pump wrapper fails
++ # before we can run distcc.
++ if "cpp" in _server_options:
++ raise comfychair.NotRunError('pump wrapper expects DISTCC_HOSTS')
++
+ error_rc, _, _ = self.runcmd_unchecked(self._cc + " --bogus-option")
+ assert error_rc != 0
+ self.runcmd(self.distcc() + self._cc + " --bogus-option", error_rc)
+@@ -432,7 +441,7 @@ def runtest(self):
+ class CompilerOptionsPassed_Case(SimpleDistCC_Case):
+ """Test that options following the compiler name are passed to the compiler."""
+ def runtest(self):
+- out, err = self.runcmd("DISTCC_HOSTS=localhost "
++ out, err = self.runcmd("DISTCC_HOSTS=localhost%s " % _server_options
+ + self.distcc()
+ + self._cc + " --help")
+ if re.search('distcc', out):
+@@ -1422,7 +1431,8 @@ def source(self):
+
+ def setupEnv(self):
+ Compilation_Case.setupEnv(self)
+- os.environ['DISTCC_HOSTS'] = '127.0.0.1:%d,lzo' % self.server_port
++ os.environ['DISTCC_HOSTS'] = (
++ '127.0.0.1:%d,lzo' % self.server_port + _server_options)
+
+ class DashONoSpace_Case(CompileHello_Case):
+ def compileCmd(self):
+@@ -1525,6 +1535,11 @@ def source(self):
+ """
+
+ def runtest(self):
++ # Disable the test in pump mode since the pump wrapper fails
++ # before we can run distcc.
++ if "cpp" in _server_options:
++ raise comfychair.NotRunError('pump wrapper expects DISTCC_HOSTS')
++
+ # -P means not to emit linemarkers
+ self.runcmd(self.distcc()
+ + self._cc + " -E testtmp.c -o testtmp.out")
+@@ -1828,7 +1843,7 @@ class NoServer_Case(CompileHello_Case):
+ """Invalid server name"""
+ def setup(self):
+ self.stripEnvironment()
+- os.environ['DISTCC_HOSTS'] = 'no.such.host.here'
++ os.environ['DISTCC_HOSTS'] = 'no.such.host.here' + _server_options
+ self.distcc_log = 'distcc.log'
+ os.environ['DISTCC_LOG'] = self.distcc_log
+ self.createSource()
+@@ -1874,6 +1889,11 @@ class NoHosts_Case(CompileHello_Case):
+ We expect compilation to succeed, but with a warning that it was
+ run locally."""
+ def runtest(self):
++ # Disable the test in pump mode since the pump wrapper fails
++ # before we can run distcc.
++ if "cpp" in _server_options:
++ raise comfychair.NotRunError('pump wrapper expects DISTCC_HOSTS')
++
+ # WithDaemon_Case sets this to point to the local host, but we
+ # don't want that. Note that you cannot delete environment
+ # keys in Python1.5, so we need to just set them to the empty
+