summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2016-09-10 16:27:25 +0200
committerFabian Groffen <grobian@gentoo.org>2016-09-10 16:40:27 +0200
commit0a332ebfc381b406c308baa37cde8e4b9e7573c7 (patch)
tree133bc672f6a658eebb2beae52a010bf139bf50d3 /sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r2.ebuild
parentprofiles: forcably enable gnome/gnome-keyring for chromium (diff)
downloadgentoo-0a332ebfc381b406c308baa37cde8e4b9e7573c7.tar.gz
gentoo-0a332ebfc381b406c308baa37cde8e4b9e7573c7.tar.bz2
gentoo-0a332ebfc381b406c308baa37cde8e4b9e7573c7.zip
sys-devel/gcc-apple: bump to EAPI=5 and remove all conditional code from global scope, bug #593392
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r2.ebuild')
-rw-r--r--sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r2.ebuild39
1 files changed, 19 insertions, 20 deletions
diff --git a/sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r2.ebuild b/sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r2.ebuild
index 1f088b901215..3540664d68cc 100644
--- a/sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r2.ebuild
+++ b/sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="3"
+EAPI="5"
inherit eutils toolchain flag-o-matic autotools prefix
@@ -16,17 +16,6 @@ SRC_URI="http://www.opensource.apple.com/darwinsource/tarballs/other/gcc-${APPLE
fortran? ( mirror://gnu/gcc/gcc-4.2.4/gcc-fortran-4.2.4.tar.bz2 )"
LICENSE="GPL-2 GPL-3"
-case ${CHOST} in
- *-darwin1*|i?86-*-darwin9|powerpc-*-darwin9)
- LIBSTDCXX_APPLE_VERSION=39
- ;;
- *)
- # pre Leopard has no dtrace, which is required by 37.11 and above
- # Leopard only has 32-bits version of dtrace
- LIBSTDCXX_APPLE_VERSION=16
- ;;
-esac
-
SLOT="42"
KEYWORDS="~ppc-macos ~x64-macos ~x86-macos"
IUSE="fortran nls +openmp objc objc++ +cxx"
@@ -52,14 +41,6 @@ S=${WORKDIR}/gcc-${APPLE_VERS}
# TPREFIX is the prefix of the CTARGET installation
export TPREFIX=${TPREFIX:-${EPREFIX}}
-LIBPATH=${EPREFIX}/usr/lib/gcc/${CTARGET}/${GCC_VERS}
-if is_crosscompile ; then
- BINPATH=${EPREFIX}/usr/${CHOST}/${CTARGET}/gcc-bin/${GCC_VERS}
-else
- BINPATH=${EPREFIX}/usr/${CTARGET}/gcc-bin/${GCC_VERS}
-fi
-STDCXX_INCDIR=${LIBPATH}/include/g++-v${GCC_VERS/\.*/}
-
do_bootstrap() {
is_crosscompile && return 1
[[ ${CHOST} != ${CBUILD} ]] && return 1
@@ -82,6 +63,16 @@ src_prepare() {
fi
# move in libstdc++
+ case ${CHOST} in
+ *-darwin1*|i?86-*-darwin9|powerpc-*-darwin9)
+ LIBSTDCXX_APPLE_VERSION=39
+ ;;
+ *)
+ # pre Leopard has no dtrace, which is required by 37.11 and above
+ # Leopard only has 32-bits version of dtrace
+ LIBSTDCXX_APPLE_VERSION=16
+ ;;
+ esac
mv "${WORKDIR}"/libstdcxx-${LIBSTDCXX_APPLE_VERSION}/libstdcxx/libstdc++-v3 .
if [[ ${LIBSTDCXX_APPLE_VERSION} == 16 ]] ; then
epatch "${FILESDIR}"/libstdc++-${LIBSTDCXX_APPLE_VERSION}.patch # does it apply on 37?
@@ -167,6 +158,14 @@ src_configure() {
use objc++ && langs="${langs/,objc/},objc,obj-c++" # need objc with objc++
use fortran && langs="${langs},fortran"
+ LIBPATH=${EPREFIX}/usr/lib/gcc/${CTARGET}/${GCC_VERS}
+ if is_crosscompile ; then
+ BINPATH=${EPREFIX}/usr/${CHOST}/${CTARGET}/gcc-bin/${GCC_VERS}
+ else
+ BINPATH=${EPREFIX}/usr/${CTARGET}/gcc-bin/${GCC_VERS}
+ fi
+ STDCXX_INCDIR=${LIBPATH}/include/g++-v${GCC_VERS/\.*/}
+
local myconf="${myconf} \
--prefix=${EPREFIX}/usr \
--bindir=${BINPATH} \