summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-09-23 23:21:50 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-09-23 23:36:02 +0100
commite943dceb25c0b1635d337c5bf0e228609f40e820 (patch)
tree56ed018e697bce97cddc05abd31b5aff91f9f367 /sys-devel/gcc/gcc-4.1.2-r1.ebuild
parentsys-devel/gcc: cut 1.5 patchset for 4.2.4 (diff)
downloadgentoo-e943dceb25c0b1635d337c5bf0e228609f40e820.tar.gz
gentoo-e943dceb25c0b1635d337c5bf0e228609f40e820.tar.bz2
gentoo-e943dceb25c0b1635d337c5bf0e228609f40e820.zip
sys-devel/gcc: cut 1.7 patchset for 4.1.2
One new patch: + 96_all_ucontext-to-ucontext_t.patch fix build failure against glibc-2.28 Bug: https://bugs.gentoo.org/629502 Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'sys-devel/gcc/gcc-4.1.2-r1.ebuild')
-rw-r--r--sys-devel/gcc/gcc-4.1.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-4.1.2-r1.ebuild b/sys-devel/gcc/gcc-4.1.2-r1.ebuild
new file mode 100644
index 000000000000..d18c5e7ec05f
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.1.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PATCH_VER="1.7"
+UCLIBC_VER="1.0"
+D_VER="0.24"
+
+inherit eutils toolchain
+
+KEYWORDS="-* ~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ ppc? ( >=${CATEGORY}/binutils-2.17 )
+ ppc64? ( >=${CATEGORY}/binutils-2.17 )
+ >=${CATEGORY}/binutils-2.15.94"
+
+src_prepare() {
+ toolchain_src_prepare
+
+ use vanilla && return 0
+
+ # Fix cross-compiling
+ epatch "${FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
+
+ epatch "${FILESDIR}"/4.1.0/gcc-4.1.0-fast-math-i386-Os-workaround.patch
+}