summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-09-23 22:31:05 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-09-23 23:35:59 +0100
commit780a9add5d2a0bef127307b6cbba7ca8e54beaba (patch)
treeb0efa13c71a821f4921c58bfeb7b356c94179cfe /sys-devel/gcc/gcc-4.7.4-r2.ebuild
parentsys-devel/gcc: cut 1.4 patchset for 4.8.5 (diff)
downloadgentoo-780a9add5d2a0bef127307b6cbba7ca8e54beaba.tar.gz
gentoo-780a9add5d2a0bef127307b6cbba7ca8e54beaba.tar.bz2
gentoo-780a9add5d2a0bef127307b6cbba7ca8e54beaba.zip
sys-devel/gcc: cut 1.5 patchset for 4.7.4
Two new patches and two updates: + 34_all_libjava-classpath-locale-sort.patch fix sortting on cs_CZ locale + 95_all_ucontext-to-ucontext_t.patch fix build failure against glibc-2.28 Bug: https://bugs.gentoo.org/629502 Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'sys-devel/gcc/gcc-4.7.4-r2.ebuild')
-rw-r--r--sys-devel/gcc/gcc-4.7.4-r2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-4.7.4-r2.ebuild b/sys-devel/gcc/gcc-4.7.4-r2.ebuild
new file mode 100644
index 000000000000..6367a6297c71
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.7.4-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PATCH_VER="1.5"
+UCLIBC_VER="1.0"
+
+# Hardened gcc 4 stuff
+PIE_VER="0.5.5"
+SPECS_VER="0.2.0"
+SPECS_GCC_VER="4.4.3"
+# arch/libc configurations known to be stable with {PIE,SSP}-by-default
+PIE_GLIBC_STABLE="x86 amd64 ppc ppc64 arm ia64"
+PIE_UCLIBC_STABLE="x86 arm amd64 ppc ppc64"
+SSP_STABLE="amd64 x86 ppc ppc64 arm"
+# uclibc need tls and nptl support for SSP support
+# uclibc need to be >= 0.9.33
+SSP_UCLIBC_STABLE="x86 amd64 ppc ppc64 arm"
+#end Hardened stuff
+
+inherit eutils toolchain
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 -amd64-fbsd -x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.8 )
+ >=${CATEGORY}/binutils-2.18"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
+fi
+
+src_prepare() {
+ if has_version '<sys-libs/glibc-2.12' ; then
+ ewarn "Your host glibc is too old; disabling automatic fortify."
+ ewarn "Please rebuild gcc after upgrading to >=glibc-2.12 #362315"
+ EPATCH_EXCLUDE+=" 10_all_default-fortify-source.patch"
+ fi
+
+ toolchain_src_prepare
+
+ use vanilla && return 0
+
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
+}