summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-12-30 23:41:27 -0500
committerMike Frysinger <vapier@gentoo.org>2015-12-31 00:30:22 -0500
commitce361724b2d2bba4122630b08ba8ae38bb5e9703 (patch)
treeb6459ee028ac9af595dd443977a2e35e7ee2c306 /sys-devel/gcc/gcc-4.8.3.ebuild
parentgames-puzzle/construo: use default install (diff)
downloadgentoo-ce361724b2d2bba4122630b08ba8ae38bb5e9703.tar.gz
gentoo-ce361724b2d2bba4122630b08ba8ae38bb5e9703.tar.bz2
gentoo-ce361724b2d2bba4122630b08ba8ae38bb5e9703.zip
sys-devel/gcc: move old 4.8 and 4.9 versions to toolchain overlay
Diffstat (limited to 'sys-devel/gcc/gcc-4.8.3.ebuild')
-rw-r--r--sys-devel/gcc/gcc-4.8.3.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/sys-devel/gcc/gcc-4.8.3.ebuild b/sys-devel/gcc/gcc-4.8.3.ebuild
deleted file mode 100644
index 3b9c0b6dc90b..000000000000
--- a/sys-devel/gcc/gcc-4.8.3.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-PATCH_VER="1.1"
-UCLIBC_VER="1.0"
-
-# Hardened gcc 4 stuff
-PIE_VER="0.5.9"
-SPECS_VER="0.2.0"
-SPECS_GCC_VER="4.4.3"
-# arch/libc configurations known to be stable with {PIE,SSP}-by-default
-PIE_GLIBC_STABLE="x86 amd64 mips ppc ppc64 arm ia64"
-PIE_UCLIBC_STABLE="x86 arm amd64 mips ppc ppc64"
-SSP_STABLE="amd64 x86 mips ppc ppc64 arm"
-# uclibc need tls and nptl support for SSP support
-# uclibc need to be >= 0.9.33
-SSP_UCLIBC_STABLE="x86 amd64 mips ppc ppc64 arm"
-#end Hardened stuff
-
-inherit eutils toolchain
-
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- elibc_glibc? ( >=sys-libs/glibc-2.8 )
- >=${CATEGORY}/binutils-2.20"
-
-if [[ ${CATEGORY} != cross-* ]] ; then
- PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
-fi
-
-src_prepare() {
- if has_version '<sys-libs/glibc-2.12' ; then
- ewarn "Your host glibc is too old; disabling automatic fortify."
- ewarn "Please rebuild gcc after upgrading to >=glibc-2.12 #362315"
- EPATCH_EXCLUDE+=" 10_all_default-fortify-source.patch"
- fi
-
- toolchain_src_prepare
-
- use vanilla && return 0
- #Use -r1 for newer piepatchet that use DRIVER_SELF_SPECS for the hardened specs.
- [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env-r1.patch
-}