summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-05-02 23:21:42 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-05-02 23:22:12 +0100
commit1b40350d6c07914196bf0ba99c3390798c5df4ec (patch)
tree4a5dfd91147f9ad731d46bb231cfb7339926b72b /sys-devel/gcc/gcc-8.1.0.ebuild
parentwww-apps/kibana-bin: drop old. (diff)
downloadgentoo-1b40350d6c07914196bf0ba99c3390798c5df4ec.tar.gz
gentoo-1b40350d6c07914196bf0ba99c3390798c5df4ec.tar.bz2
gentoo-1b40350d6c07914196bf0ba99c3390798c5df4ec.zip
sys-devel/gcc: bump up to 8.1.0 (1.0 patchset), unkeyworded
No keywords yet as it is very lightly tested. 1.0 patchset is a copy of 7.3.0 patchset with the folowing changes: - 11_all_default-warn-format-security.patch tweaked for gcc-8.1.0 - 91_all_bmi-i386-PR-target-81763.patch dropped (was a backport) - 55_all_extra-options.patch dropped, does not apply and needs a port Package-Manager: Portage-2.3.33, Repoman-2.3.9
Diffstat (limited to 'sys-devel/gcc/gcc-8.1.0.ebuild')
-rw-r--r--sys-devel/gcc/gcc-8.1.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-8.1.0.ebuild b/sys-devel/gcc/gcc-8.1.0.ebuild
new file mode 100644
index 000000000000..c2c32e4d7889
--- /dev/null
+++ b/sys-devel/gcc/gcc-8.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PATCH_VER="1.0"
+#UCLIBC_VER="1.0"
+
+inherit toolchain
+
+#needs minimal test before unkeywording
+#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.13 )
+ >=${CATEGORY}/binutils-2.20"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.13 )"
+fi
+
+src_prepare() {
+ toolchain_src_prepare
+}